PDA

View Full Version : Burned motor terminals on CWD872



JohnGreg
21-11-2016, 11:06 AM
Hi All!

I have a customer that is getting a recurring fault on his stepper drive where the motor terminals are burning out. There are 2 identical drives and motors on the machine but only one drive has this problem. I haven't had chance to put a meter on the motor but just wondered if this is a common fault. The have replaced the drive 3 times now.

Best regards,


John.

Neale
21-11-2016, 03:57 PM
Well, you can take the "Pass" sticker off that drive...

Slightly more seriously, that's definitely just the output pins for one coil that are burnt, which suggests a wiring or motor fault downstream of this point. Seems very unlikely to be due to the driver itself. Intermittent short circuit? Pinched insulation somewhere that causes a momentary short when the machine is in certain positions?

JohnGreg
21-11-2016, 07:43 PM
Thanks Neale,
The customer hasn't reported any other fault with the drive (apart from the fact that they have to change the drive every 6 months!) I'll see if I can get any more info from him. It's a 6 hour round trip to site just to stick the meter on but I'll see if I can get their maintenance guy to take some initial measurements and check the cabling.

JAZZCNC
21-11-2016, 11:08 PM
Thats what you get with cheap shity drives that don't have protection built in.!! This will 99% be motor fault either due to wiring or phase trouble.

Considering it's such long trip IMO it would be cheaper to change out motor/Drive and wiring. While at it fit good quality drives that will protect them selfs.
Personanlly I couldn't sleep at night worrying next time it might not stop at burning the connector and start on burning the building.!!