PDA

View Full Version : WinNc Sinumerik 810D/840D can't accept tool length compensation



Maxiscnc
24-02-2019, 12:15 PM
Hi everyone,
I'm very new with Siemens controllers and I have a problem with measuring the tools in the ATC. This is Emco PC Mill 155 with PC based WinNc Sinumerik 810D/840D control. I've measured all the tools with touch sensor ( 10 in the turret ) and saved the G54 zero offset to the top of the surface of a foam block.
All seems to be fine, but when tryed to start a simple program
------------------
G54
S2000 T2...10 M6
G0 Z0 F100
M30
------------------
some of the tools were in exact zero position but others are 10 - 15mm higher of the surface. One of them were few mm into the material.
I've measured again .. all of them and the result is the same.
What I'm doing wrong? Do I need to save it someware or to call for a special G command for tool compensation.
Any help is very welcome. Thanks

johngoodrich
24-02-2019, 03:57 PM
how are you currently setting them. can you post a vid?

Maxiscnc
24-02-2019, 05:31 PM
Hello again John! Yes I will do it tomorrow. I’m following step-by-step the attached manual. In the tool library in the field “ Length 1” I can see the differences between tools but in the MDI or AUTO programs they doesn’t work. Thank you!
25474

Maxiscnc
24-02-2019, 05:38 PM
And this is the full manual.
https://www.emco-world.com/uploads/tx_commerce/Sinumerik840D_Mill_en_G_02.pdf

johngoodrich
24-02-2019, 06:45 PM
That's great I'll have a read of it to see what is different to our machines. Basically y if you can do a vid or pics of each screen in you tool setup procedure I can tell you how to go about it. I find that Siemens manuals are sometimes overly complex and can be simplified alot

Maxiscnc
25-02-2019, 12:45 PM
Hi John

I think all works well now. I've just added a G1 after the tool number and now works.

G54
S2000 T2...10 D1 M6
G0 Z0 F100
M30

Thank you very much for the replies mate! All the best