PDA

View Full Version : 3.0Nm stepper from Zapp stopped working / faulty



Jonathan
19-11-2010, 07:37 PM
One of these stepper motors that I have is not working properly:

http://www.slidesandballscrews.com/sy60sth883008-nema-stepper-motor-p-118.html?cPath=45_81

The max rpm has suddenly decreased greatly - won't go above 620 rpm with no load. It just misses steps, or just stalls whilst accelerating. :thumbdown:

I've tried it on to other identical, PM752, drivers running on 70v and get the same symptoms - so it's not the driver that's the problem.

My other 3 of these steppers are all fine...

Any ideas what could be wrong / where to go from here?

Jonathan
19-11-2010, 07:43 PM
Ok well that was weird ... it's suddenly started working just fine!
Still, I'd like to know what might have caused it so it can't happen whilst the machine is running.

Robin Hewitt
19-11-2010, 09:41 PM
Is it possible you overheated the rotor and it eventually cooled down?

Jonathan
19-11-2010, 10:03 PM
No, the motor had only been on a few seconds, and off for about a month. Not warm at all. It happened just after I'd installed 4th stepper driver and cleaned out all the dust from the computer.

Desertboy
10-05-2017, 05:51 PM
Maybe dodgy connections since you rewired it several times if it is a dodgy connection I would think it inside the stepper motor.

You can split steppers to check have a look on you tube.

I wouldn't trust a motor that had done that to me unless I traced the reason it happened because it'll cost a lot more than a new motor would if it starts skipping steps on a work piece.

Clive S
10-05-2017, 07:28 PM
You do realise this post is 7 years old. Also it is not a good idea to open a stepper motor.

Desertboy
10-05-2017, 07:46 PM
No I didn't lol, I would think as long as you de-energized the coil you have nothing to lose going inside. I'm going to rip one open to see what's inside but it's a scrap one.

Jonathan
10-05-2017, 09:59 PM
I have no recollection of this incident, though I can say that 7 years later all the 3Nm motors I have from Zapp and CNC4You are still working well.

I agree with Clive on not dismantling without good reason - apparently this can result in demagnetisation.

Gary
10-05-2017, 09:59 PM
If you remove the rotor from a stepper motor it will demagnetise very quickly and then when you re assemble, it will not have the rated torque that it had before you stripped it down.