View Full Version : Motor noise

24-11-2010, 04:56 PM
What would I need to quieten electrical noise from a coolant pump being switched off.

Single phase via a relay.


Sent from my HTC Desire using Tapatalk

25-11-2010, 12:33 AM
On the AC or DC side?
Have you got a diode to absorb the surge on the DC side from the relay being turned of?

25-11-2010, 10:34 AM
Thanks, the motor noise manifests itself as glitches in Mach3

The way my relay is switched is as follows i use a solid state relay package that is operated by Mach3 via a bob

This operates the bigger 240v 10a relay. I am switching the live and the neutral.

My pump motor is single phase as was the spindle motor when i got the machine, it was run from a 13a plug.

As i said in my post it only seems to happen at switch off.

The coolant motor is maybe 20+ years old the spindle motor in new along with the VFD and they are quality makes.


25-11-2010, 11:49 AM
Just to clarify, is the relay coil powered by AC or DC?

For this bit, I'm going to assume AC, as DC switching SSR's aren't that common.
Can you not power the coolant pump direct from the SSR?
A coolant pump isn't likely to draw any more than an amp or so while running (any coolant pumps I've seen are only 1/3hp), although there will be a bit higher of a surge during startup.
Also, I would try only switching the Live, so that the motor winding is still connected to something as it slows down.

25-11-2010, 01:06 PM
Hi and thanks, the relay coil is powered 12VDC

Good point about the live only switching