View Full Version : Additional info System 4 DIYCNC

04-02-2011, 12:17 PM
Hiya folks,

Upgrade time and looking at a system 4 as have had good results with Roy's equipment. What I need to know is will the board handle 42V DC as it is recommended for 24-30V?

I have a 24V unit (also from Roy) and a 42V unit (PS407 from Zapp) and would like to use the 42V to insure that there is enough juice for both the Steppers (now up to 4) and the spindle motor (Kress 1050W that finally have found the info for slaving to Mach3). So there is my reasoning and if not can always go with the modern version of the system 1 V2. I am currently running the PCPPS with Charge Pump.

Any information would be great as need to get cutting product as have interested clients just need finished product to sell.:whistling:

Thanks all for any and all information.


PS I hope everyone is safe as we are having some pretty fierce winds today here in Scotland.

04-02-2011, 01:27 PM

i probably wouldnt risk it, roys probably your best bet to ask, though everyone has different opinions on how much extra voltage their kit will take. Usually its better to play safe unless you plan on liquid cooling the board :D.. I've got a system 1 v2 board and as you say its got everything you'd need for your setup including the 70v pre regulator and 4 stepper outputs(1 slaved) you may well have to buy the plug in module for your spindle if you want full control of it. its pretty well priced. i'd go for that if i were you.

07-02-2011, 03:54 PM
Did some more digging and 30V is the limit according to the information Roy puts out and will hold that as fact from him. Still ordering it though as with the EXMOD cards I can still power the one NEMA35 I have on A axis and with the spindle board run power to the spindle and control spindle speed which will be very nice indeed. Than once I can afford it move into the enclosure he has designed and truly have a much nicer and neater set up for the system.

Thanks for th info folks and have a great day, I am (even though busy as heck)


14-02-2011, 03:13 PM
Well folks Board is here and got X,Y,Z running fine should have the Spindle control up today or tomorrow. Only problem is that the A axis is now not responding. I have a PM752 as the driver for the board and with the PCPPS V2 with charge pump it ran with the bridge cable connected to the 5V no problem. My problem is that it will lock with power now when I wire that to ground but I don't get any motion from it all now.

Does anyone know what the wiring would be for that driver board to Roy's System 4?

Thanks and yes I am e-mailing Roy as well.


14-02-2011, 05:59 PM
Sure enough found a solution not two hours later. So once again the gremlins don't like being jinxed.


14-02-2011, 08:04 PM
Hi Michael,

Glad to hear you are making progress with the system4 upgrade. I'm running the earlier system 3 and couldn't be happier with it.

Have you posted a build log for this machine? If not, would be great to see a few pictures of it and the electronic upgrades . . .

Good to see Roy is offering enclosures now - when I built mine a few years ago he didn't stock anything like that.

Hope the storms have passed and your shed / garage roof is still on.

15-02-2011, 01:04 PM
I will be getting some pic's up in the near future and have also loaded up some video of it cutting. Starting to get much better at the speeds and feeds for the small bits I use (largest is 6.2mm diameter). Still trying to set up the spindle control for the board with a Kress 1050 FME (the two wiring diagrams of similar boards don't quite work and don't want to blow a board). Other than that Love the system it works great and the motors run so much quieter and that is really nice (also cooler but need to wire the mains back into the E- stop to cut power and keep the boards cooler as using the EXMOD boards with the older DRV25PS boards for X,Y,Z).

Take care folks