PDA

View Full Version : EMC2 home/limit switches... only acting as limit?



vputz
14-03-2011, 05:04 AM
I've set up my mill using stepconf to have "Minimum X + home" or such--in other words to have both limit and home on the same NC switch. But whenever I "home axis", it will travel until the switch triggers and then shut down the mill because a limit switch was tripped. I've even tried the "latch" setting to both "same" and "opposite" but to no avail. What obvious thing am I missing?

NB70
14-03-2011, 09:00 AM
I use the same home/limit switch configuration as you. You need to set
HOME_IGNORE_LIMITS = YES

in your config file. This will ignore the limit switch and allow you to finish the homing sequence

Link: EMC homing (http://linuxcnc.org/docs/html/config_ini_homing.html)

vputz
15-03-2011, 12:49 AM
Hmm... same thing; hits limit switch and then EMC2 stops with joint limit switch error.

Here's my axis_0 section:



[AXIS_0]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 0.95
MAX_ACCELERATION = 30.0
STEPGEN_MAXACCEL = 37.5
SCALE = 40000.0
FERROR = 0.05
MIN_FERROR = 0.01
MIN_LIMIT = -2.0
MAX_LIMIT = 3.0
HOME_OFFSET = -0.250000
HOME_SEARCH_VEL = 0.050000
HOME_LATCH_VEL = -0.012500
HOME_IGNORE_LIMITS = YES
HOME_SEQUENCE = 1

What's obviously wrong there? Table limits are wonky but I wasn't clear what to set them to, and not sure this affected it.

NB70
15-03-2011, 09:01 AM
Hi there,
I think it might be something to do with your MAX_LIMIT and MIN_LIMIT setting, and the directions of your HOME_SEARCH_VEL. MAX_LIMIT and MIN_LIMIT are the software limits (some people use only the software limits and no physical switches), if you try command a move that goes outside these limits the machine should stop.
When you are confident everything is working you can set MAX_LIMIT closer to the actual limit of your machine (but always less than where your physical maximum limit switch is).

You have HOME = 0.0, but your home search velocity is positive, so your machine moves to the positive limit switch ( at position 3.0) during homing your machine. So the first thing I would try is to change the signs of HOME_SEARCH_VEL and HOME_LATCH_VEL if you want to home at 0.0.

This is the section from my config file (units are MM) - the limits of the table are 0 and 794mm. My physical limit switch is set further out than 794mm - so I can machine out to 794 without tripping it. It homes at 0.0 - so home search velocity is negative. Home latch velocity is positive to move it forward off the limit/homing switch.

[AXIS_0]
TYPE = LINEAR
HOME = 0.0
MAX_VELOCITY = 20.0
MAX_ACCELERATION = 100.0
STEPGEN_MAXACCEL = 525.0
SCALE = -640.0
FERROR = 1
MIN_FERROR = .25
MIN_LIMIT = -0.001
MAX_LIMIT = 794.0
HOME_OFFSET = 0.000000
HOME_SEARCH_VEL = -20.000000
HOME_LATCH_VEL = 0.781250
HOME_IGNORE_LIMITS = YES
HOME_SEQUENCE = 1

StevenT
15-10-2014, 10:51 AM
Hi
I found this in the LunuxCNC "Getting started Manual"

• Home Switch Location - The location at which the home switch trips or releases reletive to the machine origin. This item
and the two below only appear when Home Switches were chosen in the Parallel Port Pinout. If you combine home and limit
switches the home switch location can not be the same as the home position or you will get a joint limit error.

Hope it help