View Full Version : Spindle cooling pump

03-11-2011, 05:07 PM
I have a 1.5kW water cooled spindle. The machine was supplied with a 3000lph pond type pump. The problem that I have is, this pump is not really suited to this application as it is a high volume low pressure pump. When you connect this to the spindle, the pump struggles due to the back pressure caused by the small orifices in the spindle and it stalls after approx 10mins running. Obviously not ideal!
Anybody found a suitable inexpensive solution.

Perhaps this:


04-11-2011, 01:05 AM
I doubt the pump you have linked to will be any good.

As long as the existing pump is mounted at roughly the same altitude/height and you're not using tiny pipes it should work just fine. It's the head of that type of pump that is poor, but by doing this your making the head close to zero so it's not an issue. Works for me...

04-11-2011, 09:26 AM
Hi Jonathan

That's precisely my problem. the pump is located in a bucket on the same table as the machine, therefore there is limited head difference.

After approx 10mins running, the pump stalls but will start again after a short delay. I have taken the pump apart and found no obvious problems. I have therefore assumed the problem is an overheating issue due to the limited flow through the pump.


04-11-2011, 12:58 PM
To increase the flow through the pump, put a tee in the discharge line and a valve back to the sump from the tee. This way, you can increase the flow through the pump yet restrict how much goes back into the sump.