PDA

View Full Version : Top speed failing after a bit



Robin Hewitt
09-11-2011, 07:13 PM
I thought I was cutting with the G0 rapid set to step at 20mm/s, blissfully unaware that the end of cut lift was hard programmed at 25mm/s :whistling:

All went swimmingly for 20 - 30 minutes then the 25mm/s lift failed and I blew a tool trying to plunge it through a hardened steel, hold down fixture at 20mm/s. It managed a couple of mm before the tool exploded :naughty:

I've now fixed the 25mm/s override bug, but the question is...

If it failed to handle 25mm/s after things warmed up, is 20mm/s a bit close to the knuckle and likely to fail sometime? I am rather assuming it's a hot motor demagnetising fault, because it worked okay when cold. I could be wrong.

The Z axis motor is necessarily further from it's controller than the X and Y. In the past I have compensated by favouring the G0 vertical with a slower rate than the X and Y, but I was thinking the 240 Volt stepper drivers would make that unnecessary.

I do like the 20mm/s rate because it's really zippy, but not if it's going to get expensive in tooling and metal.

blackburn mark
09-11-2011, 08:06 PM
Hi Robin, i had a bit of trauma a couple of days ago, one of my X axis motors started losing stepps.... lots of them... i hate making scrap :thumbdown:

took me a while to suss that it was heat realated, i turned the fan up to full on the driver heat sink (5 axis all in one job)

i was really starting to trust this machine :smile: im a tad twitchy now :eek:... its been ok now for a couple of days..... fingers crossed

Robin Hewitt
09-11-2011, 08:52 PM
im a tad twitchy now :eek:

That's it in a nutshell :naughty:

Something goes wrong, you think you know what it is, you apply a patch, possibly unnecessarily, and then live with it for ever more.

It's a tiny step between "a tad twitchy" and "raging paranoia" :rofl:

blackburn mark
10-11-2011, 12:32 AM
It's a tiny step between "a tad twitchy" and "raging paranoia" :rofl:


mmm... now then.... iv got spare couplers a spare 5 axis driver board a spare stepper and five spindles, i should just build a spare machine :smile:

my machine is starting to pay its keep now so its my best mate, its become a bit of an obsession :eek: ... i used to be a slob and proud of it :smile: i could sit under a tree all day and ponder the magnitude of existance.... cant do it any more! i can sit under a tree but now i ponder tool paths and design solutions and want to go home and start cutting.

if my machine died now :eek::eek::eek::eek: .... id need drugs!!!!...... lots of drugs!!!!!

i might just buy a couple more steppers and a slack handful of couplers LOL:smile:

Robin Hewitt
10-11-2011, 10:07 AM
Nothing wrong with a bit of healthy paranoia, so long as you can rise above it :smile:

My mill worked at 25mm/s for a couple of parts then failed one lift.

One failure in one axis and I'm seriously considering cutting all axes below 20mm/s forever more. Obviously I think the machine is out to get me.

What I should do is figure out why 25mm/s failed, fix it and go for 30mm/s. :naughty:

Jonathan
10-11-2011, 03:25 PM
What I should do is figure out why 25mm/s failed, fix it and go for 30mm/s. :naughty:

Sounds like what I'd do!

After finishing the new frame on my router I started with X and Y on 250mm/s ... which was fine, then X developed a stalling habit so I got the ballnuts better aligned and threadlocked anything in sight. Went down to 200mm/s just to be safe ... couple of months later it randomly stalled so I reduced X again, and again ... now I'm at only 150mm/s.
That's clearly sufficient and I guess it's generally less wear at that speed (the ballnuts will last longer), but I do wonder if it might still go at 250mm/s.

The same was true for my mill - started off fast then decreased. If I put my milling vice on I have to drop the feeds because it's so heavy.

If you really want 25mm/s have you considered changing the pulleys? I did that to the extreme on my router and got 1000mm/s on Y (not tried X yet)...just depends if you can live with a little less resolution. Try it and see? Add about 30% more teeth to the motor pulley.

I'm not sure if the stepper heating affects the torque. The magnetic flux from the permanent magnets will decrease marginally with temperature, but I don't know it the effect is enough to notice without modelling it.

Robin Hewitt
12-11-2011, 11:46 AM
If you really want 25mm/s have you considered changing the pulleys? I did that to the extreme on my router and got 1000mm/s on Y (not tried X yet)...just depends if you can live with a little less resolution. Try it and see? Add about 30% more teeth to the motor pulley.


Been there, done that already :naughty:

I quarter step at .005 mm so the positioning is already a bit springy and I can be up to minus 0.01 mm out on a width according Mr Mitutoyo. It never seems to go plus for some reason.

I prefer to call it 0.4 thou, or maybe 10 microns, because that sounds better :whistling:

I gave it a few hours with 15 mm/s rapids yesterday without losing position. Think I will wind it up to 20 mm/s next time I have a job where I am not particularly worried if it goes tits up.