View Full Version : Upgraded leadscrew now stepper stalls on Z axis. What are my options?

20-11-2011, 01:26 PM
As a treat for #3 (CNC not wife!), I recently bought her a set of leadscrews and precision nuts from http://www.abssac.co.uk from a very helpful guy called Phil who gave an excellent service and a bloody good price.

The lead screws were to replace the M8 all-thread rod on my latest hobby CNC router (http://crapworks.blogspot.com/2011/11/my-third-cnc-router-project.html) that I use for cutting ply and MDF. I drive this beastie from a fast PC using EMC2 on Ubuntu.


However my Z-axis is now stalling at all but the slowest speeds due to my hasty purchase. This will teach me (again) not to impulse buy, but of course it probably will not. Sigh!

So what should I do now? Upgrade the motors/drivers and PSU?

Forget all about CNC and take up crochet?

I have been looking forward to a much improved and faster #3 CNC router, but alas I made an ar$e of it, and not for the first time.

Instead of impulse buying yet again, I thought I would reach out for some advice from you generous guys.

I have learned from reading other posts that you like numbers:

Weight of Z-axis and spindle = 4.5kg

Existing Power supply = 30V at 2A

Current Motor Stats
Weedy Astrosyn Nema 23, MY103H702, wired Bi-Polar Parallel

Current Routout Driver Stats
2.5A Routout Driver Card (http://www.routoutcnc.co.uk/2-5ampdriver.pdf) set to quarter step

New Z axis, Lead Screw Stats
Thread = 5/16-8-4
Thread Diameter (inch) = 0.313 (7.95mm)
Threads per Inch = 8 (3.1mm Pitch)
Thread Starts = 4
Thread Type = stub acme
Thread Lead (inch) = 0.5000

I was thinking that I would need to replace the motors, drivers and PSU, and i was thinking of this kit (http://www.zappautomation.co.uk/product_info.php?cPath=139_33&products_id=364) from ZappAutomation (http://www.zappautomation.co.uk/index.php);

"This CNC Driver kit is designed for 3 axis of stepper control (X, Y & Z)

This kit consists of the following:

1 X ZP5A-INT Breakout board

3 X 4.2A PM542 Microstepping Drivers

3 X 3 Nm SY60 Stepper motors

1 X EP002 - 43V, 500W regulated power supply"

Is that motor/driver/psu setup going to be up to the job?

I have about 250 to spend and would prefer to continue to use EMC2.

What would you propose I replace or reconfigure?

Thanks in advance, BigAl.
The Crapworks (http://crapworks.blogspot.com/)

21-11-2011, 09:03 PM

i used the same steppers with 12x3 square thread on less voltage than you on my last machine and got good results. Yours should be fine so some tweaking in EMC2 looks like a turn before splashing out. You would be better off spending the cash on ballscrews and nuts with better rails and bearings. Throw us you config for a look and let us know if your motors are wired bipolar or uni?

22-11-2011, 12:01 PM
Throw us you config for a look and let us know if your motors are wired bipolar or uni?

Config will be useful. He said they're wired bipolar parallel, so that's good.

Yes I agree ballscrews will be a better upgrade, however to answer your question those 3Nm motors are good. Especially with the PM752 drivers and 70 volts, but for your size machine 50V and PM542 will be fine - you'll find them a lot cheaper on eBay.

I have some of those motors too. Their inductance, 10mH, is very very high for that size motor so they will never go particularly fast on only 30V. You can get round that by using pulleys to lower the motor speed for a given feedrate, i.e. put a big timing pulley on the motor and a smaller one on the screw. Ideally HTD pulleys. But wait and see what the configuration is first...

Your screws are 8 TPI, so the pitch is 3.175mm, but they're 4 start so the lead is that multiplied by 4, which is 12.7mm. Have you entered 3.175mm in EMC instead of 12.7mm? If so then the Z-axis is actually going 4 times faster than it says which probably explains why it can only go 'slow'?

Probably stating the obvious, but check that you can spin the screw freely by hand and that there's no tight spots?