View Full Version : feedtrate on NCstudio for Artcam problem

06-10-2012, 02:45 PM
So can anyone help with this problem?
I canít work out what the federate should be set in NCstudio. Below are the machines stats :

Spindle spec:

Spec: 65*210 mm (Diameter:65mm x Length:210mm)
Power: 800W
Voltage: 220V~250V
Frequency: 400 Hz
Speed: 8000-24000 R/min
ER11 collet chuck

Stepper drivers:

Input Voltage: 220V-240 V, 50/60HZ
Output Voltage: 0-240 VAC
Output Power: 1.5 KW
Output Frequency: 0-400 Hz
Output Current: 7.0 A
Capacity: 2.8 KVA
Overload Capacity: 10.5 (60s)(A)

Stepper Motors:

Step Angle: 1.8 degree
Voltage: 1.8V
Current: 3.0A/phase
Resistance: 0.50hm/phase
Inductance: 1.8mH/phase
Torque: >=450mN. m
Number of wire leads: 4
Length: 65 mm

The default seems to be set at 2200 in the picture its set to 600


If you open the parameters you can alter these as below on the fly, I cant work out what they mean by G01 G02 G03 and then the other G00?


My machine is rated at 4000 mm/min


And the artcam feedrate for the tool is 76 mm/min


You can also set them in the main parameters settings


The problem I have is when I run a job I have to lower the feed rate to 20% this cuts the correct width and length but 3 xís to deep, I canít seem to work out how to set up the G00 code etc to match the machine.

06-10-2012, 04:18 PM
G00/01/02/03 are motion commands

G0 is the G-code to command a rapid motion at the previously set speed to, typically, XYZ, e.g. G00 F50 X0 Y0 Z100. which will move rapidly to 0,0,100 at 50mm/min. In your setup the speed is defaulted to 5000mm/min

G1 would typically be used to command a cutting motion e.g. G1 F10 X100 which would move at 10mm/min to location X100 (Y and Z being what was previously set). In your setting F = 4000mm/min, however the NC setup of 76mm/sec is 4560mm/min which is too fast and likely to stall the motors, but its overridden by NCStudio. The operational number must be less than the fastest motor setting

G2/G3 are clockwise and anticlockwise circular motions

The distance moved should be independent of the speed moved at. Changing the speed should NOT alter the distance moved, just how fast it gets there...

If its cutting too deep/moving too far it probably means that the steps/mm setting for the relevant axis is wrong rather than the G-code. There must be another setting somewhere...