View Full Version : Newall DRO broken;-(

27-06-2013, 06:58 PM
My DRO shows SF,[signal failure] on both axis.
I am guessing it's not a scale problem, but something common to both channels as it was fine and next time I looked it it had SF on both. It had to be left on as it you turned it on from cold it would output a bit of nonsense for a while, numbers fluctuating, next morning it would be as it should be.
I wonder if anyone has any experience of these things?

I had one stop working in 2006 and I posted on somewhere that it had stopped working, I got an email from someone who said he had repaired them and to send it to him, I do still have the mail address he gave then but it's not active, and then someone offered me another unit for 30, I went for the 30 quid one..

27-06-2013, 11:42 PM
Have a search over on The Home Shop Machinist & Machinist's Workshop Magazine's BBS (http://bbs.homeshopmachinist.net/forum.php) as there's been a couple threads about Newall DROs that I know of.

28-06-2013, 01:18 AM
Cheers for that, I wasn't aware of that forum, but I stuck my user name in and it completed the password automatically so I guess I have seen it before. So many Newall results on a search, I don't know where to start;-)
After posting I searched my mail archive for the "I can mend you Newall" blokes email address and found I asked him a question about an ebay item in 2004 and he still uses the same ebay username, I mailed him on ebay and got a response, so keep your email archive..