PDA

View Full Version : How to wire the enable pin on a stepper drive?



cncJim
23-12-2015, 05:49 PM
Hi All,

Maybe a stupid question but I really don't want to fry anything! Can someone tell me how I should connect the enable pins on my stepper drive?

16895

The drive has an ENA+ and ENA- but my BoB only has an ENA-.

Thanks,
Jim

JAZZCNC
23-12-2015, 07:04 PM
What Bob is it Jim.? . . . . Also do you realise you don't have to use the enable on the drive if you don't want to. ?

cncJim
23-12-2015, 07:17 PM
Hi Jazz,

Sorry its not so clear in the image I uploaded is it...

Its a pcpps bob
http%3A%2F%2Fwww.diycnc.co.uk%2Fforms%2FPCPPSV3.pd f
And the drive is a leadshine m752.

I have been running without using the enable function (nothing connected on the drive) but i wanted to understand how it could work really.

Cheers,
Jim

JAZZCNC
23-12-2015, 07:51 PM
Yes I had a feeling it was PCPPS.

just take Ena(+) on drive to Ena pin on BOB and Ena (-) on drive to Gnd on BOB. You'll then have to set the Enable output in mach and tell it which pin number.

cncJim
24-12-2015, 09:39 AM
Great, thanks for that Jazz I will give it a go. :)

Follow up question, should there be a power up order for the PC, BoB, stepper drives, Vfd etc?

Cheers,
Jim

Clive S
24-12-2015, 10:01 AM
Great, thanks for that Jazz I will give it a go. :)

Follow up question, should there be a power up order for the PC, BoB, stepper drives, Vfd etc?

Cheers,
JimIt is always good to power the PC up first the BOB and Drives would come on together and it is optional for the VFD as you might want to get the holding down and zeroing done before powering that up.

JAZZCNC
24-12-2015, 07:29 PM
Clives correct but really if control is done correctly it would go like this.!
PC First then turn on Power to control box which turns on the BOB and Low voltage PSU for safety. Then the drives etc come on when you push the Reset button and only if every thing is safe do so.
This way if the Control software isn't in control and ready. ie: PC crashed Bob will disable motor outputs because no charge pump.
Or if the E-stop is pressed safety system won't turn on the drives, vfd etc.
Or if limit is pressed the system will reset and drives will turn on but won't enable there outputs and also shouldn't allow control softare to reset.

cncJim
25-12-2015, 05:26 PM
Merry Christmas! Thanks for the replies and advice Clive and Jazz.

I am following the sample circuit from the Mach3 manual:-
16908

Would using this give everything needed or is there something extra to do/add?

When talking about the charge pump, is that essentially the ENA- pin of my BoB?

Thanks,

Jim

cncJim
01-01-2016, 04:10 PM
Hi all,

I haven't got round to testing the enable pins on the drives yet as I need to order the correct connectors (http://uk.rs-online.com/web/p/non-fused-terminal-blocks/1896010/ in case it's useful to others).

I have tested the enable pin on th BoB and got a slightly odd result:-

1. BoB off, PC on - 2.26v
2. BoB off, PC on, Mach 3 loaded - 1.09v
3. Mach3 loaded, BoB on, emergency stop active - 4.97v
4. Mach3 loaded, BoB on, ES reset - 195mv
5. Mach3 not running, BoB on - 4.9v
6. PC off, BoB on - 4.9v

So they all look ok to me except for number 2. From what I understand TTL levels a Low is 0v to 0.8v and a High level is 2v to 5v so a voltage of 1.09v is neither low of high which may or may not cause problems.

Anyone expirence this kind of thing before?

Thanks,
Jim