Thread: Emco PC120 Turn

Page 9 of 15 FirstFirst ... 7891011 ... LastLast
  1. #81
    Chaz's Avatar
    Lives in Ickenham, West London, United Kingdom. Last Activity: 10 Hours Ago Has been a member for 5-6 years. Has a total post count of 1,185. Received thanks 85 times, giving thanks to others 54 times.
    Quote Originally Posted by cropwell View Post
    They are all over eBay, just search for 'relay module 5v' and limit to UK if you want it fast.

    Here's one example of a supplier - http://www.ebay.co.uk/itm/1-2-4-8-16...f5lyx157fF9xGQ

    Cheers,

    Rob
    So I bought one of these and finally tried to install it today. Nothing works. Ive tried every option. The state of P17 doesnt change, even if I press E Stop whatever. It could be that the board is damaged.

    Are you able to indicate what the wiring should look like from a board like this please?

    http://www.ebay.co.uk/itm/5-Axis-Cnc...item3d32792356


  2. Sorry Chaz, but I can't get my CNC fired up at the moment. First, you need the relay jumper disconnected and then in Mach3 you need to command the P17 with an output set to pin17 and that output linked to M8 on the Spindle Control screen, so then M8 in your code sets coolant on and M9 turns it off.

    You can use any spare axis pulse or direction pin to do the same thing btw, if you want to use the onboard relay for spindle control, which is hard wired into P17 when the jumper is on.

    PM me your Mach3 configuration file (you will need to copy it and change the extension to .txt) and |I will have a look at it. I can't remember exactly where we got on this.

    Cheers,

    Rob

    In the meantime I will look at my CNC PC to see why it is not firing up properly !!!! - Have looked at it system SSD is dead, will need to rebuild Operating system and reload software --- S H I T -- !!!!
    Last edited by cropwell; 11-03-2017 at 03:32 PM.
    Albert Einstein may have been a genius, but his brother Frank, was a monster

    Having just moved to Windows 10 (which is crap) My stress levels are through the roof !!!

  3. #83
    Chaz's Avatar
    Lives in Ickenham, West London, United Kingdom. Last Activity: 10 Hours Ago Has been a member for 5-6 years. Has a total post count of 1,185. Received thanks 85 times, giving thanks to others 54 times.
    Quote Originally Posted by cropwell View Post
    Sorry Chaz, but I can't get my CNC fired up at the moment. First, you need the relay jumper disconnected and then in Mach3 you need to command the P17 with an output set to pin17 and that output linked to M8 on the Spindle Control screen, so then M8 in your code sets coolant on and M9 turns it off.

    You can use any spare axis pulse or direction pin to do the same thing btw, if you want to use the onboard relay for spindle control, which is hard wired into P17 when the jumper is on.

    PM me your Mach3 configuration file (you will need to copy it and change the extension to .txt) and |I will have a look at it. I can't remember exactly where we got on this.

    Cheers,

    Rob

    In the meantime I will look at my CNC PC to see why it is not firing up properly !!!! - Have looked at it system SSD is dead, will need to rebuild Operating system and reload software --- S H I T -- !!!!
    Thanks. Ill get the config later (its in the garage).

    I tried with the relay setting on and off. I did damage the board however previously when I miswired the on board relay. Cheap enough to replace. I then made Output 3 try both pin 16 and 17 but nothing changes the state of them. Im using output 3 for coolant and triggering it doesnt change anything. Perhaps I need another board first. Id love to go CS Labs as its something I understand but too pricy for a machine ill likely be selling.

  4. #84
    Nothing works. Ive tried every option.
    Have you put power on the 12-24v power supply as well as the pc 5v.

    As I think that the inputs are powered from the 12-24v supply (don't quote me though)
    ..Clive
    The more you know, The better you know, How little you know

  5. I am sure you are right Clive, the 5v from the PC is only to power the input optos. I have the board in front of me and the 12v track is on the top face and disappears under components, so I can't trace it through.

    (Chaz) The board you show as an example on eBay is overpriced, you can get them from China for less than a fiver and not much more than that from a UK supplier.

    Rob
    Last edited by cropwell; 11-03-2017 at 05:36 PM.
    Albert Einstein may have been a genius, but his brother Frank, was a monster

    Having just moved to Windows 10 (which is crap) My stress levels are through the roof !!!

  6. #86
    the PC is only to power the input optos
    Rob do you mean the outputs just for clarity
    ..Clive
    The more you know, The better you know, How little you know

  7. #87
    Chaz's Avatar
    Lives in Ickenham, West London, United Kingdom. Last Activity: 10 Hours Ago Has been a member for 5-6 years. Has a total post count of 1,185. Received thanks 85 times, giving thanks to others 54 times.
    Quote Originally Posted by Clive S View Post
    Have you put power on the 12-24v power supply as well as the pc 5v.

    As I think that the inputs are powered from the 12-24v supply (don't quote me though)
    Ah, no. There is a Ground, VCC and two inputs. What voltage goes into the trigger (5V?) and 24V into VCC?

  8. Quote Originally Posted by Clive S View Post
    Rob do you mean the outputs just for clarity
    Probably, but I am sure they do more than just provide clarity

    I am up to my neck in computer problems at the moment. The computer says press any key to boot from CD.... and I can't find the 'ANY' key - none of the ones on the wireless USB keyboard work and I haven't got any other sort.
    Albert Einstein may have been a genius, but his brother Frank, was a monster

    Having just moved to Windows 10 (which is crap) My stress levels are through the roof !!!

  9. Quote Originally Posted by Chaz View Post
    Ah, no. There is a Ground, VCC and two inputs. What voltage goes into the trigger (5V?) and 24V into VCC?
    Are you talking about the relay board ? Because if you look at the back of the BoB it is clearly printed on. The relay board takes GND, 5v on Vcc and the two inputs are 5v max.
    Albert Einstein may have been a genius, but his brother Frank, was a monster

    Having just moved to Windows 10 (which is crap) My stress levels are through the roof !!!

  10. #90
    Chaz's Avatar
    Lives in Ickenham, West London, United Kingdom. Last Activity: 10 Hours Ago Has been a member for 5-6 years. Has a total post count of 1,185. Received thanks 85 times, giving thanks to others 54 times.
    Quote Originally Posted by cropwell View Post
    Are you talking about the relay board ? Because if you look at the back of the BoB it is clearly printed on. The relay board takes GND, 5v on Vcc and the two inputs are 5v max.
    So to be sure.

    Relay board has 4 connections.

    One is Ground, once is VCC and two are triggered inputs (5V)? The VCC is 24V? If that is the case, I did not connect 24V.

Page 9 of 15 FirstFirst ... 7891011 ... LastLast

Similar Threads

  1. Mach Turn
    By Kai in forum CAD & CAM Software
    Replies: 5
    Last Post: 02-08-2016, 01:40 PM
  2. Denford Star Turn 3
    By MarkBrown in forum Workshop & Equipment
    Replies: 2
    Last Post: 02-12-2014, 09:57 PM
  3. Getting the stepper to turn
    By thorphar in forum General Electronics
    Replies: 0
    Last Post: 16-09-2014, 06:48 PM
  4. 11 hours of trying to get the motors to turn, help please
    By Wotsit in forum Stepper & Servo Motors
    Replies: 19
    Last Post: 05-02-2013, 02:07 AM
  5. LED not turn on
    By Awel in forum Motor Drivers & Controllers
    Replies: 1
    Last Post: 06-12-2011, 05:59 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •