Page 2 of 3 FirstFirst 123 LastLast
  1. #11
    Quote Originally Posted by Neale View Post
    It's a Sieg X1 and appears to have 3mm pitch trapezoidal leadscrews.
    Did you actually check the movement.? Could it be multi start lead screw.?

  2. Didn't appear to be multi-start. I quickly checked pitch with a caliper, mainly to make sure that it was 3mm and not 8tpi, bit it's not the most accurate measurement to do. The x54 move giving about 56mm movement is slightly odd as that doesn't tie up with either pitch. Unless steps per has got itself changed. The current motor mounts are a bit crude (plan is to remake) but I can't see how any flexibility in that or missed steps would give too much movement. X and y axes seem to move smoothly enough. Should have done a bit more testing...

  3. #13
    hi, this is on the proxxon mill, not the sieg mill. I was hoping to make the mounting plates on the proxxon. will reload mach3 today, and see what happens.

  4. Quote Originally Posted by terry1956 View Post
    hi, this is on the proxxon mill, not the sieg mill. I was hoping to make the mounting plates on the proxxon. will reload mach3 today, and see what happens.
    Sorry - all bets off, then! Good chance that the 54mm/56mm means that steps per unit settings are wrong but this doesn't explain why the gcode doesn't do as expected. Let's see what a Mach3 reload does for things.

  5. #15
    Any chance you're using an "exotic" license?

  6. #16
    hi. just an update. I made a small demo shape using lazy cam and then used this on the proxxon. the machine cut the shape. so it must be a fault in the way the artcam g code is being read by Mach3, and not the machine itself or the way Mach3 is set up on the machine.
    anyone any ideas on this.

  7. #17
    OK - if you post your settings file here from your c:\mach3 folder. It's usually called Mach3Mill.xml

  8. #18
    Quote Originally Posted by terry1956 View Post
    hi. just an update. I made a small demo shape using lazy cam and then used this on the proxxon. the machine cut the shape. so it must be a fault in the way the artcam g code is being read by Mach3, and not the machine itself or the way Mach3 is set up on the machine.
    anyone any ideas on this.
    @terry1956:
    As an outsider looking in please would you mention whether you tried any of the previous well considered suggestions and/or the results of those suggestions, so we can all learn.
    Thanks, Andy
    Last edited by AndyGuid; 15-09-2016 at 11:48 AM.

  9. #19
    Ok.update on this so far. The mach3 software is my own. The proxxon mill cuts to scale on all the test g codes to set up in mach3. The over upscaling comes into play when I used g code written by art cam express and used this program to post the g code in mach3 tap format. Using a cam edit software to view the g code turned up know errors.but mach 3 did not like the code and upscaled the work. To make sure it was not the mach software at fault I used an old test g code which resulted in the mill cutting the design correctly..at the moment it looks to me like the fault lays between the art cam way of writing g code and mach3 reading the art cam g code.
    I am going to try a second program later today to write the g code.Will post how I get on later this week.

  10. #20
    Terry like Andy ask's did you try any of the suggestions and do the corrections.?

    The G-code works fine so it's not the code. it's also very simple code nothing fancy.
    There are very few settings in mach3 other than wrong steps per that will make it do what you describe. I've mentioned most of them.

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Arc movement issue
    By lukecnc2012 in forum Metalwork Discussion
    Replies: 4
    Last Post: 09-08-2015, 06:15 PM
  2. Up-scaling CNC Sidewinder to cut 8x4?
    By toby in forum Machine Discussion
    Replies: 4
    Last Post: 11-05-2015, 08:15 AM
  3. Replies: 16
    Last Post: 29-04-2015, 11:34 AM
  4. THC Setting Issue?
    By Davek0974 in forum Plasma Table Machines
    Replies: 8
    Last Post: 17-10-2014, 06:53 AM
  5. Ref all home issue? A hand would be great just here!
    By suesi34e in forum Artsoft Mach
    Replies: 4
    Last Post: 24-09-2014, 08:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •