Page 3 of 3 FirstFirst 123
  1. #21
    GND's Avatar
    Lives in Cambridge, United Kingdom. Last Activity: 3 Days Ago Has been a member for 2-3 years. Has a total post count of 55. Received thanks 1 times, giving thanks to others 9 times.
    No problem. Recently switched to the 4Nm NEMA-23 steppers from CNC4YOU, driven by some pretty basic drivers which I inherited - Motion Control Products MSD980. This is all run at 68v, which is a bit higher than ideal I know, but dates from when the machine was fitted with NEMA-32 "super bricks", which is how it came to me. I had resonance and speed problems, so swapped out to the smaller motors a little while back. They don't seem to run too hot, hence for now I'm assuming they are ok. Otherwise I will need to downgrade the toroidal!

    Cheers
    Graeme

  2. #22
    68V is perfect voltage for 4Nm 23 so don't change. The MSD980 where not bad drive and can handle 80V so no issues there provided setup and wired correctly.
    So provided setup correctly regards current etc then this shouldn't be your issue and you'll have plenty of power. So can rule out lack of power.

    If your sure that you have no mechanical issues and Stiffness isn't so bad and all electricly sound then all thats left is the dreaded parallel port/PC. (I pressume your using PP.?)

    First thing to do is change the Parallel cable. Not uncommon for parallel cable to give problems.
    Next is control software, if Mach3 then I'd back up your XML file and do fresh install. Again I've seen mach3 do strange things and re-install cure them.
    PC would be my next swap out. If possible I'd try another PC.

    Best of all is to dump the PP and fit motion control card. Preferably Ethernet based. USB is better than PP but I'd avoid if can afford it.

    If Still have problems and does turn out to be stiffness/weakness then I wouldn't try to make silk purse out of sows ear. Just sell it on and build another better machine.

  3. #23
    GND's Avatar
    Lives in Cambridge, United Kingdom. Last Activity: 3 Days Ago Has been a member for 2-3 years. Has a total post count of 55. Received thanks 1 times, giving thanks to others 9 times.
    Thanks for the thought process, JAZZ. Actually I feel the last line is probably the way it will end up going, and getting used to the idea sooner rather than later will likely save me a lot of grief. I can of course re-use many of the components - especially the electronics and motors - as they are likely not letting me down.

    Just as a point of note, I am using the Parallel Port, but via my own design BOB. And before any alarm bells start to ring, I'm an electronics engineer by profession and did it all properly. AFAIK it is rock solid, and just to back up that rash assertion, my weird axis behaviour does not change if I swap the X & Y motor wires over. More specifically the axis behaviour remains unchanged, despite the X and Y drives and therefore BOB signalling and Mach3 paths are swapped.

    And that's why I think your last line probably applies!

    Cheers
    Graeme

Page 3 of 3 FirstFirst 123

Similar Threads

  1. mach 3 scaling issue
    By terry1956 in forum Artsoft Mach
    Replies: 20
    Last Post: 16-09-2016, 12:31 PM
  2. Up-scaling CNC Sidewinder to cut 8x4?
    By toby in forum Machine Discussion
    Replies: 4
    Last Post: 11-05-2015, 08:15 AM
  3. Motorcalc spreadsheet errors
    By jimbo_cnc in forum General Discussion
    Replies: 7
    Last Post: 10-03-2015, 06:02 PM
  4. What the hell do I need ?? (humourous replies expected :-) )
    By alboy in forum Marketplace Discussion
    Replies: 9
    Last Post: 08-09-2013, 11:42 AM
  5. Two ball screws for my x axis and two motors, do i need two drivers?
    By luke11cnc in forum Gantry/Router Machines & Building
    Replies: 26
    Last Post: 11-08-2011, 11:55 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •