. .
Page 1 of 2 12 LastLast
  1. #1
    I'm having some difficulty getting my head round how to connect my BOB to a nos Altivar 18 inverter. I can get the BOB to do the switching functions ie run, reverse etc, but I can't work out how to get it to control the speed. I think I have Mach3 correctly configured to the BOB, but I'm unsure how to connect for speed control.

    Here's the BOB I have:
    Click image for larger version. 

Name:	BOB.jpg 
Views:	4019 
Size:	177.7 KB 
ID:	19934

    And this is the Altivar 18 wiring diagram:

    Click image for larger version. 

Name:	Altivar18.jpg 
Views:	3130 
Size:	67.1 KB 
ID:	19935

    I'm guessing that "0-10 Spindle Speed Output", labelled on the board as gnd and 10v, should connect to "com" and "AI2" but this doesn't work. What am I missing?
    Last edited by Agathon; 09-12-2016 at 12:38 AM.

  2. #2
    Are you feeding the BOB with a 12v supply the the terminals above the 0-10v ?
    Failing that have you changed the parameter for the pot ?
    Last edited by John S; 09-12-2016 at 12:38 AM.
    John S -

  3. #3
    Thanks for the quick reply. I tried feeding 24v from the inverter to the 12-24v input but it just lit up a led on the BOB - not sure what the purpose of the 12-24v input is.

    I haven't altered anything in the inverter programming for the pot - you may have hit on it. I've been using these things for years, don't know why I didn't think of it straight away. I'll check it in the morning. Thanks.

  4. #4
    I know nothing about that inverter, but for my Chinese inverter I had to set parameters to accept a 0-10V input (rather than front-panel controls). But, yes, the idea is to connect the 0-10V output (and ground) to the COM/A12 on the inverter.

  5. #5
    Quote Originally Posted by Agathon View Post
    I'm guessing that "0-10 Spindle Speed Output", labelled on the board as gnd and 10v, should connect to "com" and "AI2" but this doesn't work. What am I missing?
    You are correct with wiring Gnd to Com 10v to AI2.

    Can you control the speed from the front panel of the VFD.? . . . . If yes then you need to change parameter for Frequency Control to external source. The default is nearly always front panel.
    Last edited by JAZZCNC; 09-12-2016 at 08:32 PM.

  6. #6
    Thanks for all the replies. The inverter doesn't have speed control from the front panel. According to the manual AIC and AI2 are already configured and certainly if I connect a 1.5v battery between com and AI2 the inverter runs at about 15% as one might expect. If connect directly between +10 and AI2 the inverter runs at full speed, again as expected. So no problem with the inverter configuration.

    Having played around with Mach3 and thought more about this two things occur to me:

    1. I can get Mach3 to switch the spindle relay on, but the spindle DRO does not display an RPM and altering the speed doesn't alter any of the numbers from 0. Surely, even with nothing connected it should show values if it is generating pulses?
    2. The inverter is looking for 0-10v between com and AI2, but where does the BOB get 10v from if it only has a 5v power supply? Do I need the 12-24v supply connected? I can take 24v from the inverter.

  7. #7
    OK. Just connected up the 24v from the inverter to the 12-24v input on the BOB and punching in a speed on the SDRO makes the inverter run. However, at 100% it's only giving 89hz instead of 100hz and it goes up slightly if I touch the 10v output with a screwdriver or meter probe - wierd. I'm getting around 9v across 10v and gnd.

    Maybe I need to use a separate 12-24v supply to the BOB.

  8. #8
    Quote Originally Posted by Agathon View Post
    Thanks for all the replies. The inverter doesn't have speed control from the front panel. According to the manual AIC and AI2 are already configured and certainly if I connect a 1.5v battery between com and AI2 the inverter runs at about 15% as one might expect. If connect directly between +10 and AI2 the inverter runs at full speed, again as expected. So no problem with the inverter configuration.

    Having played around with Mach3 and thought more about this two things occur to me:

    1. I can get Mach3 to switch the spindle relay on, but the spindle DRO does not display an RPM and altering the speed doesn't alter any of the numbers from 0. Surely, even with nothing connected it should show values if it is generating pulses?
    2. The inverter is looking for 0-10v between com and AI2, but where does the BOB get 10v from if it only has a 5v power supply? Do I need the 12-24v supply connected? I can take 24v from the inverter.
    hai agathon , nice to meet u here.

    i got the same issue with my mach3 to control the spindle. i can turn on the spindle with mach3 and then the spindle run to max rpm 24000.
    after that i can not control the speed anymore.

    have u solved this issue ? i use the same BOB like yours and the HY 1,5 kw inverter.


    regards,

    eddy.

  9. #9
    Quote Originally Posted by edipelangi View Post
    hai agathon , nice to meet u here.

    i got the same issue with my mach3 to control the spindle. i can turn on the spindle with mach3 and then the spindle run to max rpm 24000.
    after that i can not control the speed anymore.

    have u solved this issue ? i use the same BOB like yours and the HY 1,5 kw inverter.


    regards,

    eddy.
    Hi Eddy - my spindle now working as it should, but I don't think I can advise about your set-up as I'm not familiar with your inverter. Maybe someone else here can help. David

  10. #10
    If it's working now it would be a great idea to let others know what you did.
    Spelling mistakes are not intentional, I only seem to see them some time after I've posted

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Schneider Altivar 320 wiring / setup help needed
    By TadasM in forum Spindles & Drive Motors
    Replies: 31
    Last Post: 21-10-2016, 06:43 AM
  2. Breakout board HG08 wiring help need
    By GeoDurie in forum Machine Discussion
    Replies: 7
    Last Post: 04-02-2015, 11:00 PM
  3. Replies: 0
    Last Post: 03-01-2015, 02:40 PM
  4. eBay: UIM2901-5A Mach3 breakout board with spindle speed control
    By Fivetide in forum Items On eBay UK
    Replies: 0
    Last Post: 05-02-2013, 06:25 PM
  5. Stepper Driver / PSU / Breakout board Wiring ?
    By manofgresley in forum General Electronics
    Replies: 2
    Last Post: 16-08-2012, 04:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •