1. #1
    I'm back to converting my Boxford TCL160 after quite a long break.
    I'm using ESS Smoothstepper with a CM106 BOB and MAch3 Turn
    The Spindle and X and Z axis are now all working.
    I now need to hook up the original encoder to give me the speed of the Spindle.
    The disc on the end of the spindle shaft has 100 holes and on the outer rim there is one hole.
    There is a dual slotted opto used to sense the speed. is has 4 wires, yellow,red,blue,green,

    I need to hook these into my breakout board which is a CM106
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	CM106.jpg 
Views:	57 
Size:	58.7 KB 
ID:	20855   Click image for larger version. 

Name:	Slotted.jpg 
Views:	52 
Size:	75.0 KB 
ID:	20856  

  2. #2
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 14 Hours Ago Has been a member for 9-10 years. Has a total post count of 2,121. Received thanks 233 times, giving thanks to others 5 times.
    What's the model/part number on the sensor?
    Avoiding the rubbish customer service from AluminiumWarehouse since July '13.

  3. #3
    OPB866T55
    RS306-061

    Two of them mounted and offset.
    Attached Thumbnails Attached Thumbnails OPTO.pdf  
    Last edited by Len-Tikular; 19-02-2017 at 08:04 PM.

  4. #4
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 14 Hours Ago Has been a member for 9-10 years. Has a total post count of 2,121. Received thanks 233 times, giving thanks to others 5 times.
    First up, as you're using Mach with an ESS, you'll only need the single slot (that's unless Warp9 have finally added the multislot capability they've been promising for however many years).

    You'll need to add a resistor to the LED supply. You need a voltage of 1.2V at 20mA over the LED, so assuming a 5V supply, you need a 190ohm resistor. I think - I'm a bit tired, and not worked it out for a while! (5-1.2v)/0.02A = 190ohm
    Or at 24V, a 1140ohm resistor (1.2K should do)

    Do you have the input specs for the BOB?
    It may be easier to connect directly to the ESS, as by the looks of your schematic, the inputs are all 24V, so you'd need a buffer board/circuit to boost the sensor output.
    Avoiding the rubbish customer service from AluminiumWarehouse since July '13.

  5. #5
    Attachment 20862
    Many thanks, heres the diagram of the opto's as they are configured on the lathe. Modified sketch included along with Spec
    Can you help with the connections to
    Green, Blue, Red and Yellow.

    George
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	TCL160 Indexer.jpg 
Views:	28 
Size:	33.5 KB 
ID:	20870   Click image for larger version. 

Name:	RS306-061.jpg 
Views:	27 
Size:	143.5 KB 
ID:	20871  
    Last edited by Len-Tikular; 22-02-2017 at 11:24 AM. Reason: added image

  6. #6
    That looks to me as though you have the LEDs and transistors transposed, so the LEDs should be on the right and the transistors on the left.

    If that were the case, green would be ground, yellow would be power and the red and blue would be your inputs.

    Adrian.

  7. #7
    Thanks Adrian,

    I have amended my sketch and I think it is now correct,
    Blu = In1
    Red = In2
    Green = Gnd
    Yellow = Vcc What would you recommend the supply voltage ?? Specification attached.
    How do I configure MAch3 turn to read both these signals ?


    However
    Just in case we cant get this working I have fitted a single inductive pickup which gives a spindle out as follows.

    M3 S1000 = Indicated True Speed = 60
    M3 S5000 = Indicated True Speed = 360
    M3 S10,000 = Indicated True Speed = 740
    M3 S15,000 = Indicated True Speed = 1120
    M3 S20,000 = Indicated True Speed = 1500
    M3 S25,000 = Indicated True Speed = 1888

    It looks fairly linear. But how do I get the requested M3 speed to be equal to the Indicated true speed ?
    The output from my BOB is a 0-5Vdc
    I have set pulley No1 to min speed to 0 and Max speed to 25,000
    Spindle feedback and Spindle averaging are both checked.



    George
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	TCL160 Indexer.jpg 
Views:	29 
Size:	33.5 KB 
ID:	20869   Click image for larger version. 

Name:	RS306-061.jpg 
Views:	30 
Size:	143.5 KB 
ID:	20868  
    Last edited by Len-Tikular; 22-02-2017 at 06:19 PM.

  8. #8
    That diagram is still wrong. The LEDs should be powered continuously. It is the transistors which are generating the signals on the blue and red leads.

    When the solid part of the disc is between the LED and the transistor, there is no light reaching the transistor, so it does not conduct. This allows the red/blue wires will be pulled high by the BOB.
    When the gap in the disc comes round, the light from the LED passes through it, hits the transistor and it switches on. This pulls the red/blue wire to ground, generating the pulse needed.

    > What would you recommend the supply voltage ??

    The Boxford circuit diagram appears to show the sensors powered by 10V, so the sensors should have resistors for that supply already.

    > How do I configure MAch3 turn to read both these signals ?

    Sorry, I've never used Mach3 so cannot say.

  9. The Following User Says Thank You to Saracen For This Useful Post:


  10. #9
    Many thanks, sorry for being a pain, I didn't realise you were not a Mach3 user.
    I did have the Boxford Schematics but somehow lost them in the course of time.
    Can you remind me of a link where I can get them.

    Good news is I now have the spindle true speed and requested speed allllllmost the same and
    Using a macro M6start I am now able to run my toolchanger, it needs tweeking and the addition of a homing sensor on the turret would be a big help.

    Thanks

    George

Similar Threads

  1. Chinese 300W DC spindle - is the spindle shaft grounded?
    By HankMcSpank in forum Spindles & Drive Motors
    Replies: 44
    Last Post: 26-11-2016, 06:25 PM
  2. Replies: 5
    Last Post: 29-09-2014, 01:42 PM
  3. SOLD: Indexer, ISEL CSD 405-IMC and GFM 4433 controllers
    By badgerman in forum Items For Sale
    Replies: 7
    Last Post: 27-06-2014, 09:46 AM
  4. Replies: 0
    Last Post: 13-11-2013, 06:50 PM
  5. DIY Spindle - What type of bearings are best suited for a spindle.
    By 8iggles in forum Spindles & Drive Motors
    Replies: 18
    Last Post: 09-02-2011, 09:15 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •