Page 2 of 2 FirstFirst 12
  1. #11

    from the error message it appears the controller hijacks the G31 as well so not much difference in G31 & M31.

    I will try again today but not holding out much hope, CSL support is so slow as to be annoying as well, beginning to regret the purchase a bit :(

    Yes, analog servo drives 10-0-10v control.

  2. #12
    Quote Originally Posted by matt-b2 View Post

    Has anyone had any luck getting Mach3 with a CSMIO/IP-M controller to work with a probe properly?

    The probe I'm using works fine, G31 and CS Lab's M31 macro ( both work in that both cause my CNC router to move until either the probe triggers or the specified distance is reached.

    What does not work is, variables 2000-2002 (which are supposed to contain the X, Y & Z coordinates of the probe event) do not update properly. For some reason, variable 2000 updates consistently with the Y coordinate (when it is supposed to contain the X coordinate), but variables 2001 and 2002 either contain zero or nonsensical values.

    Mach3 and the CSMIO/IP-M firmware are both up-to-date (R3.043.066 and V2.91 respectively). I have the probe tip diameter set on Mach3's Settings screen.

    Ideas/suggestions much appreciated.

    Dear Matt,

    I use also the CNC controller CSMIO IP-M together with Mach 3 in the newest version and the last CSMIO firmware.
    For tool probing I got always the Y value for var(2002). I contacted CS-Lab support for help but the answer was that I do not understand the macro.
    I was shure to use the macro right and tried everything to find the fault. So I checked the connection of the motors and the channels.
    That was the solution and I changed my wiring.
    I connected the x-axis to Channel 0, the y-axis to channel 1 and the z-axis to channel 3. After that I tried the tool length measurement again and got the
    right values.

    I hope this information will help you.


  3. #13
    Yes XYZ is channel 0-1-2 and so on.

    I have my probe working well now - the secret is to allow some time in the macro so pad it with "Sleep(100)" lines after a DRO update etc also it ONLY works with soft limits turned off - i just made the macro turn limits off then on when the move was made.

    Its going well now.

  4. #14
    Yes, that's a bit of a gotcha - that "sleep" after a DRO update is absolutely vital, as is the "while moving" loop so you wait for the machine to reach target position before carrying out the next action. However, my version works fine with soft limits, so not sure what's going on there.

  5. #15
    Yes, its only a 0.1s wait and it needs going after every DRO update, i also padded it after every DRO read, plus the totally essential while-ismoving loop on ANY call that creates movement of an axis.

    Doing this likely added 5s to the macro run time but thats no bother if its what it takes to make it work 100%

    The soft limits thing i'm going to play with again - it seems very version dependant so now I have the timings sorted, ill try leaving it on and see what occurs. CSLABS said they had never heard of it BUT they always run v022 so that may be why.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. csmio/ip-m z probe
    By charlieuk in forum CS-Lab (CSMIO)
    Replies: 0
    Last Post: 16-09-2017, 09:49 AM
  2. mach3 csmio ips errors
    By Web Goblin in forum Artsoft Mach
    Replies: 7
    Last Post: 07-01-2017, 10:47 PM
  3. Mach3 oem buttons with CSMIO-IP/S
    By Web Goblin in forum Artsoft Mach
    Replies: 2
    Last Post: 07-11-2016, 07:14 AM
  4. CSMIO-M Tool Probe Connection - +24v to earth
    By Noplace in forum CS-Lab (CSMIO)
    Replies: 1
    Last Post: 10-04-2016, 09:17 PM
  5. Weird problem - stepped/staged deceleration on Huanyang 2.2kw Spindle
    By glynster in forum Spindles & Drive Motors
    Replies: 0
    Last Post: 25-01-2016, 01:39 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts