1. Hi,

    I am suffering from an emergency being triggered in Mach3 for no apperent reason. The error is quite rare some sessions its not there other sessions its happens 10 - 20 times The error obviously stops the machine dead. I can reset and continue normal movements. Sometimes the machine will error and stop when using manual rapid travel to reposition the cutter. I have a latched relay on the Emergency/Limits circuit, if there is a true emergency then I need to push a button to re-latch that relay before being able to reset in Mach3. When this (fake) error is shown in Mach3 the emergency relay is not de-latched. I first thought is was the limit relays bouncing from cutter vibration and becuase it was a very short time period for the error the relay did not have time to de-latch but Mach3 caught it. I ruled this out becuase I shorted the emergency cicuit and it still occurs. Today the emergency was being triggered a lot, this followed me making a change in Fusion360 when post processing, I used smoothing which from what I can tell dramatically reduces G-Code line count by replacing point to point movements with fewer radius movements. The smoothed G-Code wont run but the normal will. The smoothed G-Code is around 9k lines the normal is 32k.
    Can anyone suggest a reason or how and where to look first. Its running kit from CNC4YOU, HG08, CW-5045, SwitchMode PSU, WinXP 2.4MhZ
    Regards
    Simon

  2. #2
    It's likely to be electro-magnetic noise, have you tried setting the debounce timing to a much higher setting?
    You think that's too expensive? You're not a Model Engineer are you? :D

  3. Quote Originally Posted by magicniner View Post
    It's likely to be electro-magnetic noise, have you tried setting the debounce timing to a much higher setting?
    Never set debounce Any suggestion on starting value? Cheers

    Sent from my GT-I9305 using Tapatalk

  4. #4
    Try 1000, if that's still problematic try 2000, then 3000 and 4000.
    Something else worth trying is running the PC from a separate socket as far from the machine as possible via an extension lead, don't ask why but this does work, I swapped the mains feed to the 1hp VFD on my little CNC mill to a socket 5m away and it eliminated the noise issues,
    Regards,
    Nick
    You think that's too expensive? You're not a Model Engineer are you? :D

  5. #5
    I had this, or a similar problem, where the Estop was triggered randomly with a 'Driver Watchdog' error. I found a setting in General Config which sorted it. To the best of my recollection it was 'Use Watchdogs', which when ticked cured the fault.

    What error message do you get when the Estop is activated ?

Similar Threads

  1. work piece showing outside table display
    By terry1956 in forum Artsoft Mach
    Replies: 11
    Last Post: 09-01-2017, 09:36 AM
  2. Long shot - emergency lathing!
    By Rogue in forum General Discussion
    Replies: 5
    Last Post: 26-06-2015, 12:44 PM
  3. Sieg KX1 & Mach3 won't come out of emergency reset
    By lateAtNight in forum Gantry/Router Machines & Building
    Replies: 32
    Last Post: 19-06-2015, 05:37 PM
  4. Proximity Sensors / Mach3 not showing
    By dudz in forum General Electronics
    Replies: 21
    Last Post: 15-06-2013, 07:47 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •