1. #1
    Evening all,

    Hoping someone can help me with our Mach3 version 2 at work. We have a Cobra MD router and use DXF drawings then into CAMBAM to create the G code.

    We needed something making in a hurry, our engineer was out and I had a go using Fusion 360. All came out fine, high 5's and pats on backs all round.

    So, engineer comes back loads one of his usual files, zero the z height using a touch off probe and we get a warning message Insufficient Z clearance. Z clearance plane is above Z axis Home Switch, retract safely below switch or press cancel to exit operation.

    It was nowhere near the limit switch, tried taking it all the way up to activate the switch then retried to re-zero z but still same error.

    I think what is happening is the safe retract Z height set in Fusion360 has replaced whatever was previously saved for the Z limit position.

    I know enough to operate the router but when something like this happens I'm stuck.

    Can anyone help with how to clear this please, I'm not very popular at work at the moment.

    Thanks

    Mike

  2. #2
    Did you 'home' the machine first and zero the DROs ?
    Spelling mistakes are not intentional, I only seem to see them some time after I've posted

  3. #3
    Quote Originally Posted by RocketBoy View Post
    I think what is happening is the safe retract Z height set in Fusion360 has replaced whatever was previously saved for the Z limit position.
    Well, wouldn't worry because it's nothing you have done unless been messing around with settings within Mach. G-code cannot overwrite the Safe Z height which is a setting within mach3.

    But what it can do is set Coordinate offset by using G92 and this will most likely send your Probe routine in to melt down. To cancel this issue G92.1 in MDI.
    Another potential problem G-code for probe routine is G43 which sets a Tool Offset. Issue G49 to set tool offset to Zero.

    Thou to be honest decent Cam program would cancel G92 with G92.1 when finished.
    Likewise, good G-code would Zero tool offsets at the top G-code file before running so if this case then your engineer is at fault, not you.

    But all this said I think you'll find in the morning all is well because pretty sure the parameters which get changed by G92 are reset on startup. As are any tool offsets which have not been saved in tool table.

  4. #4
    Your "Engineer" isn't setting his Co-ordinate zero in his code.

    Clumsy Bastard!
    You think that's too expensive? You're not a Model Engineer are you? :D

  5. #5
    Ger21's Avatar
    Lives in Detroit, United States. Last Activity: 18 Hours Ago Has been a member for 6-7 years. Has a total post count of 585. Received thanks 81 times, giving thanks to others 0 times. Referred 1 members to the community.
    Those sound like messages from my 2010 Screenset macros?
    Do you have home switches on the machine? Just home the Z axis first.
    Otherwise, Jog the Z to the top of the travel, and Ref Z while it's there.
    If neither fixes the issue, then your Clearance Plane is too high, like the message says.
    Gerry
    ______________________________________________
    UCCNC 2017 Screenset

    Mach3 2010 Screenset

    JointCAM - CAM for Woodworking Joints

  6. As ger and jazz said ...

    You need to follow the exact same procedure as the previous practice.
    In start-up, zero, etc.

    For many reasons, a screen that looks the same is not the same.
    And yes, this is wrong.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •