1. #1
    OK I am looking at replacing the Chinese components in the control box to hopefully fix an issue with my machine jumping (checked frame for alignment and all seems in order) so possibly down to some electric noise or cheap board.
    Now I have researched enough to attempt install the following however I don't know which to buy and gratefully ask for assistance:
    a break out board (preferably with Ethernet connector)
    3 stepper controllers
    screened wiring
    48v power supply
    my only issue is I am on a budget and when looking at breakout boards/stepper controllers they vary in price greatly (cheapest BoB I have seen is 3 with most expensive BoB short of 100) smooth steppers pricing goes higher in three digits.
    my price range I am looking at for a breakout board is around 50
    for stepper motors around 20 each
    screened wiring I just cant get my head round all the types I keep ending up looking at audio cables with 4 screened wires.
    The screen shots are of my currant control box
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	cnc motor[1].jpg 
Views:	32 
Size:	283.0 KB 
ID:	23724   Click image for larger version. 

Name:	cnc interior[1].jpg 
Views:	35 
Size:	357.8 KB 
ID:	23725  
    Last edited by Palletlad; 09-02-2018 at 10:32 PM.

  2. #2
    Copper braided CY cable is what you want. Doesn't need to be big for the motors, but if the problem is happening without the spindle running I very much doubt noise is the problem. Just change one thing at a time, try the PSU first as that was what caused the same issue for me and they're not all that dear. Also try it with a different PC as that can cause the issue if it doesn't run fast and smooth.

    The cluster bomb approach could very well end up costing you a lot more than it needs to for little/no real benefit.
    Last edited by Snapper; 09-02-2018 at 11:20 PM.

  3. #3
    Doddy's Avatar
    Lives in Preston, United Kingdom. Last Activity: 5 Hours Ago Has been a member for 4-5 years. Has a total post count of 293. Received thanks 33 times, giving thanks to others 10 times.
    I'm with Snapper on this one - take a breath and think logically what is going on before a blind replace-and-see that, only at best will break-even over the cost of replacing the correct item, and at worst will see you throw your money away.

    I'd also agree - if you are to replace the cabling to the steppers - 0.5mm2 csa CY cable is the way to go, with the screen grounded at the controller end. Simply because of geography I tend to use "CB17088" order code from CPC (part of the Farnell group) - it's 0.75mm2 (which is better, but more ) as the only spec that they sell by the metre (0.89/m + vat). Don't use screened audio cable - it's unlikely to be specced to carry the current you're talking about with steppers which will manifest itself with lower mechanical energy out of the stepper.

    That photo of your controller box - there's a big ferrite across the spindle supply - that's to suppress any noise induced by the spindle - it should help things - which makes me wonder what your problem truly is - you mention missed steps, but that's a little vague to try to isolate the problem and offer sensible advice. You miss steps how, and when, and as Snapper queries - whether its related to spindle noise. Have you tried, for example, touching a fine bit against the bed (or sacrificial bed) at work coords {0,0,0}, raising Z, then air-cutting a complex/fast outline, then returning to {0,0,0} to verify the position of the spindle, with both spindle on, and spindle disconnected?, that'd tell you immediately if the problem is with noise before spending money.

    Do you lose steps on one axis or more? Do you lose steps in one location on the machine (mechanical), or anywhere (possibly more electrical)?

    You ask about alternatives to (a) stepper controllers, (b) BoB (pref. ethernet), (c) screened wiring, (d) 48v power supply.

    (a) - why?, does the controller you have not work? - for a 20 replacement you're unlikely to get anything substantially better than the TB6560 solution on your board already. Unless you definitely need (/want) to replace the parallel-port drive with something else - and you'll have seen there that basically takes you on a 100/ethernet board + 3x20 stepper controller journey of 160. Which might not cure your problem.
    (b) Tied in with reply to (a). What's the problem with the BoB now?, missed steps?, then why do you think a replacement will resolve that? I *did* go with the cheap ethernet BoB/motion controller replacement at around 100 (NVEM controller) - and have some experience - would I do the same again?, possibly not - but I understand some of the limitations with them.
    (c) Cable - depends on what you have at the moment - I'm assuming you're talking from the controller to the machine?, it could help, and the advice above - CY cable holds true, but I'm not convinced yet that is your problem. Although cheap to try.
    (d) 48V PSU - affects the performance of the router at speed. Try a lower feed rate/acceleration. If that solves your problem then the PSU could be a contender, but I wouldn't replace without testing.

    I suffer "squirrel" moments on here and get easily distracted (this reply alone is an avoidance mechanism from finishing my control panel for my mill) - I can't remember if you've posted about your missing steps issue - if you have, point me at your thread. If not it might be worth opening up a new thread to try to resolve your real issue (just found your "Fountain of Knowledge" thread - but that ends without a conclusion).

    Feel free to PM me if I'm going over old ground that's been discussed elsewhere - I don't want to take this thread off track.
    Last edited by Doddy; 10-02-2018 at 09:10 AM.

Similar Threads

  1. Dead 6040 controller box
    By Splinter in forum General Electronics
    Replies: 12
    Last Post: 16-08-2017, 09:07 PM
  2. FOR SALE: Parts For Sale - Servo Drives, Controller, 3Kw Motor, Transformers
    By MrBurns in forum Items For Sale
    Replies: 0
    Last Post: 27-01-2017, 05:13 PM
  3. New 6040 owner looking for advice from others with a chinese 6040/3040
    By itsmillertime in forum Machine Discussion
    Replies: 11
    Last Post: 06-01-2016, 12:45 AM
  4. 200khz USB bob upgrading to 4th axis
    By dudz in forum Motor Drivers & Controllers
    Replies: 9
    Last Post: 05-04-2015, 10:06 PM
  5. WANTED: Need electronics, anyone upgrading??
    By fasteddy in forum Items Wanted
    Replies: 2
    Last Post: 25-09-2009, 05:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •