1. #1
    Hi all,

    After Mr Leadhead of these forums very kindly popped by to check over my Chinese 4x4' router and discovered the Leadshine M542-05 Y axis driver was indeed shot, I bought a JMC 2DM542 and installed it, connecting the wires like-for-like.

    Y axis now moves in the wrong direction.

    Now, if i was using Mach 3 i seem to remember there was a toggle to mirror an axis BUT i'm still stuck on NC Studio until i can afford a new control board (thinking Planetary; have heard good things) but in the meantime: anyone know a quick fix?

    NC Studio has 2 identical checkboxes labelled Mirror Axis, but neither do anything.

    The 2DM542 manual has a couple of wiring diagrams, nothing i can make sense of.

    The manual also has a chapter on parameter settings, but apparently i need an HISU adjuster to alter them. There's one called Initial Direction Selection which looks nice.

    SO, any hints and tips before i start switching PUL+/-; DIR+/- wires around on the driver?

    Many thanks,

    Will in Portsmouth

  2. #2
    Doddy's Avatar
    Lives in Preston, United Kingdom. Last Activity: 5 Hours Ago Has been a member for 4-5 years. Has a total post count of 297. Received thanks 34 times, giving thanks to others 10 times.
    Swap the two wires of ONE motor winding over.

  3. The Following User Says Thank You to Doddy For This Useful Post:


  4. #3
    AHA! Ok, so A+ to A-, or B+ to B-, but only switching either A's or B's?Click image for larger version. 

Name:	IMG_2538.jpg 
Views:	39 
Size:	86.7 KB 
ID:	24198

  5. #4
    Doddy's Avatar
    Lives in Preston, United Kingdom. Last Activity: 5 Hours Ago Has been a member for 4-5 years. Has a total post count of 297. Received thanks 34 times, giving thanks to others 10 times.
    That's the plan. Don't forget to remove power before you do it

  6. The Following User Says Thank You to Doddy For This Useful Post:


  7. #5
    Many thanks! Works perfectly. IOU a beer.

    I love this forum.

    W

Similar Threads

  1. Dumb Reverse
    By Leadhead in forum General Discussion
    Replies: 3
    Last Post: 03-10-2016, 11:41 AM
  2. Is this motor faulty?
    By Chaz in forum General Electronics
    Replies: 12
    Last Post: 30-11-2015, 09:26 PM
  3. Reverse engineering
    By mikewatch in forum Probing, Digitizing & Scaning
    Replies: 1
    Last Post: 13-04-2013, 09:20 PM
  4. 3 axis driver...Fuses keep blowing
    By dudz in forum Motor Drivers & Controllers
    Replies: 5
    Last Post: 28-01-2013, 07:05 PM
  5. Zapp Automation CNC Driver Kit 4 Axis
    By whensparksfly in forum Motor Drivers & Controllers
    Replies: 7
    Last Post: 01-03-2012, 12:54 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •