1. #1
    Hi all

    hope you are all well

    simple sanity question, in mach3.. under MDI

    I type G0 Y10

    AND THE Y AXIS MOVES TO POSITION 10, 10MM (MACHINE MOVES CORRECTLY AND MACH DRO READS 10)

    I TYPE G0 Y0

    AND Y MOVES BACK TO POSITION 0 SAME AS ABOVE APPLIES


    I DO THE SAME WITH Z (STARTING FROM 0 DRO ALSO 0)

    G0 Z10 - AND Z MOVES TO 22.92 AND THE DRO REFLECTS THAT
    THEN G0 Z0 AND IT MOVES TO 12.92

    I HAVE MACH3 UNITS PROFILE SET TO MM

    IF IT MAKES ANY DIFFERENCE I AM IN THE PLASMA PROFILE

    ANY HELP GRATELY APPRECIATED

    (IF I JOG THE Z (OBVIOUSLY NOT VERY ACCURATELY) BUT 1.0MM ON DRO IS 1MM PHYSICAL ON Z

  2. #2
    Did you home the axis first? Is Z0 at the top? If so all moves need to be negative so G0 Z-10 should move 10mm down.
    Building a CNC machine to make a better one since 2010 . . .
    MK1 (1st photo), MK2, MK3, MK4

  3. #3
    Have you checked that you don't have a scaling factor set on the rogue axis?
    You think that's too expensive? You're not a Model Engineer are you? :D

  4. #4
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Current Activity: Viewing Has been a member for 9-10 years. Has a total post count of 2,038. Received thanks 225 times, giving thanks to others 5 times.
    Looks like there's some kind of offset being applied to the Z axis.
    Avoiding the rubbish customer service from AluminiumWarehouse since July '13.

  5. #5
    Doddy's Avatar
    Lives in Preston, United Kingdom. Last Activity: 18 Hours Ago Has been a member for 4-5 years. Has a total post count of 249. Received thanks 22 times, giving thanks to others 9 times.
    Just a little possibility to throw into the soup - I once was trying to calibrate/tune the axis and got asymmetrical offsets positive and negative - took me a while to realise the column was at the limits of its travel (I only have home switches at the top of the column)

Similar Threads

  1. Replies: 9
    Last Post: 17-04-2018, 08:32 PM
  2. The best CAD/CAM suggestion, Gcode and Mach3
    By petes in forum CAD & CAM Software
    Replies: 1
    Last Post: 29-01-2015, 10:06 AM
  3. Help needed for a 3d part gcode for mach3
    By Rebekah_harper in forum Computer Software
    Replies: 33
    Last Post: 04-11-2013, 12:55 AM
  4. Replies: 1
    Last Post: 20-10-2012, 01:50 PM
  5. Mach3 Using a physical button to repeat current gcode
    By RLKS Rob in forum Artsoft Mach
    Replies: 2
    Last Post: 12-08-2012, 12:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •