. .
  1. #1
    JimK's Avatar
    Lives in Cromer, Australia. Last Activity: 25-09-2019 Has been a member for 0-1 years. Has a total post count of 4.
    I have 2 upgrade 5 axis breakout boards which both have the same problem. I can't energize the relays. I have unchecked the 'Disable relay' box in 'Spindle Settings' and assigned output #1 to the M3 and the M4 boxes. I have also assigned Port1 and pin 9 to output #1 in the ports and pins screen. I have of course green checked Output #1.
    Going to the MDI screen and entering M3 should activate the relay bu it doesn't. The computer running the Mach3 program activates the relay on another router, which has the same type of breakout board, when the M3 command is sent.
    I am of the belief that both boards may have the same fault despite them being new. Is there something that I have missed?


  2. #2
    Going by my notes for the breakout board
    pin 9 controls the relay

    Click image for larger version. 

Name:	chinese breakout board.jpg 
Views:	59 
Size:	161.3 KB 
ID:	26186

    one issue I found is the +5V supply is missing from pin 14 of the 74HC14 IC used to buffer the 5 inputs connection to the printerport


  3. #3
    Doddy's Avatar
    Lives in Preston, United Kingdom. Last Activity: 6 Hours Ago Has been a member for 6-7 years. Has a total post count of 805. Received thanks 129 times, giving thanks to others 34 times. Referred 1 members to the community.
    Have you tried removing the parallel cable and shorting (carefully!) pin 1 and pin 9 on the BoB to 5V? (if you have one, use a current limiting resistor between the 5V supply to the pins... any value from 100R through 10k should be good... if you don't have one just be careful). If that doesn't work then I'd be serious glaring at the BoB.

  4. #4
    JimK's Avatar
    Lives in Cromer, Australia. Last Activity: 25-09-2019 Has been a member for 0-1 years. Has a total post count of 4.
    Many thanks to all for your suggestions. Both boards have either a faulty PNP relay driver transistor or an incorrect one. Both boards are now working ok after I replaced the transistors with known PNP types.

  5. #5
    Great to see you have solved the problem


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help connecting servos to breakout board Mach3
    By Agathon in forum Stepper & Servo Motors
    Replies: 35
    Last Post: 02-09-2017, 03:19 PM
  2. Breakout board to Telemechanique Altivar 18 wiring (Mach3)
    By Agathon in forum Motor Drivers & Controllers
    Replies: 14
    Last Post: 08-07-2017, 06:12 PM
  3. which breakout board?
    By johngoodrich in forum General Electronics
    Replies: 4
    Last Post: 12-03-2017, 12:54 AM
  4. Replies: 0
    Last Post: 03-01-2015, 02:40 PM
  5. eBay: UIM2901-5A Mach3 breakout board with spindle speed control
    By Fivetide in forum Items On eBay UK
    Replies: 0
    Last Post: 05-02-2013, 06:25 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts