. .

Thread: New member

  1. #1
    Kenm's Avatar
    Lives in Wrexham, United Kingdom. Last Activity: 2 Weeks Ago Has been a member for 0-1 years. Has a total post count of 3.
    new member about to build cnc plasma cutter 2500mm x 1250mm using mach4, smothstepper, mb3 bob, rack and pinion X and Y axis ballscrew Z axis using 4Nm steppers (twin on X axis).
    Previous cnc experience - built cnc router in early 90's using SMCU+ software from North East Electronics with 1/2 step drivers (micro stepping was a very expensive new technology). Software ran on dos and came on 4 no. five and a quarter inch floppy disks, all g code had to be computed manually and entered line by line on the keyboard.
    Machine still in use today although now on 4th router head and computer upgraded from old 286 to 486 running windows 95.
    Obviously got to learn new control software so any hints and tips would be a great help.

  2. #2
    Kitwn's Avatar
    Lives in Exmouth, Australia. Last Activity: 11 Hours Ago Has been a member for 2-3 years. Has a total post count of 590. Received thanks 78 times, giving thanks to others 15 times.
    Welcome to the forum Ken,

    Things have changed a bit since you built your first machine, I assume you have already moved to computer generated G-code. Clicking a button to get 20,000 lines of code in a few seconds from a PC produced drawing is probably the biggest change since you started.

    Engineering is the art of doing for ten shillings what any fool can do for a pound.

  3. #3
    Hi Ken

    Do you still use the GPS Nee software to import any new G-code into the Nee controller or have you managed to work around this problem.
    I'm interested to know as I also have a North East Electronics 6 axis controller, which is still working, micro stepping was a very expensive new technology
    You are not kidding.

    I have the licensed dongle, which has stopped working. It is really frustrating when a bit of software costing £400 "then" has stopped a machine costing £10,000 and I can do nothing about fixing it.

    Because I cannot import some G-code into the software, it makes the controller and the whole machine unusable,
    Odd that you mention 486, I remember them, that was my first CAD machine. I wonder if that is the problem, I've upgraded my computer speed but still running windows 98s
    Any help on the matter, from anyone would be very appreciated.

    Machine still in use today although now on 4th router head and computer upgraded from old 286 to 486 running windows 95.

    Sorry to jump into your opening membership speech with my rantings.

    all the best

  4. #4
    Kenm's Avatar
    Lives in Wrexham, United Kingdom. Last Activity: 2 Weeks Ago Has been a member for 0-1 years. Has a total post count of 3.
    Hi Montegoman,

    yes still using nee software and controller and the security device is still functioning. The machine is now a bit long in the tooth but still working. Programs were all written out by hand - no cam software at the time (at least that I could have afforded then.)
    Some of the G codes are different than the latest ones - G81 for instance.
    I have noticed that the cam routines generated are quite long to take into account the speed of the latest machines, nothing like the short compact routines I had to come up with because of slow speed of the software inside my skull.

  5. #5
    Hello Ken

    Thank you for replying to my questions.

    One of the reasons for purchasing the Nee controller back then was it's ability to produce the G-codes from a drawing, thereby I would not need to learn G-coding or machine codes. However little did I know that I would find myself in the position I find myself today with no access to the controller to export code into it.

    I'm hoping you might be able to help me, right now I cannot decide if the dongle has broken down or there is a software counter inside the dongle, i.e. a time clock or a counter on how many times it has be fitted to different computer parallel ports Or the output from these three computers parallel ports is giving out the wrong voltage or speed signals.
    Having read your comments on the 486 I am now cobbling together a very old computer to see if that does the trick, but I am not holding my breath.

    I'm being forced to have a look at other controllers i.e. the Mach3 but having read the Mach3 installation manual on page 34 it shows the pin out on the parallel port and it also states there could be a problem with parallel ports for the very same reason. I have no idea how the hi or the low voltage on each pin is set or where you set it from, this sort of stuff is beyond me.
    Do you have any ideas on how, a parallel port outputs can be tested, it would be interesting to find out what the three computers are sending out to the parallel port.

    In the Bios there are a number of different option on the parallel ports, what is your Nee computer set at? On the Nee GPS installation software Cd there is a statement from Rainbow, who have a SET SSI_ACT. exe file in there, I am assuming that ties up with the Bios setting.
    I have downloaded and got going both lots of dongle finding software from Sentinel/Rainbow but even that could not find the dongle i.e. dongle not found.

    By the way I have traced down the family tree of the Nee controller, and who eventually purchased it, the final owners is ITT who closed everything down 10 years ago, so we are both trying to keep obsolete equipment going, just like my car.
    Right now I am spending hours trying to get this problem solved but until it is one way or another I cannot move forward but it does not look good.

    Please keep in touch
    kind regards

  6. #6
    Kenm's Avatar
    Lives in Wrexham, United Kingdom. Last Activity: 2 Weeks Ago Has been a member for 0-1 years. Has a total post count of 3.
    Hi Montegoman,

    your system must be a lot newer than mine - software came on 5¼ inch floppies. Nee supplied the parallel lead so no idea of the connections. The security device is still functioning fine. Although I now operate with a 486 machine it boots into dos to run the software, if I want to run windows I have to run that as a separate program but only do that to clean up the stored program directory as it's difficult to keep on top of the programs just using the dos 8.3 character names.

    Lektronix apparently can repair nee controllers, probably worth a call. https://www.lektronix.com/equipment/...cs-smcu/119853


  7. #7
    Hello Ken

    Sorry about the delay in replying, I had to do some research.
    Here are the results of, trying to find any firm who could help.
    As you have already stated Lektronix will repair the hardware, i.e. electronics side of things, they repaired one in 2017.

    No firm was able to help with the dongle/software problem I have been lumbered with.
    I have listed the firms below that have Nee stuff on their websites but cannot help with any software problems.
    Cleveland Motion Control
    Lincoln electrics of the USA, Germany and the UK.
    CR Onsrud have not worked on a Nee controller for 12 years.
    Thales in the UK

    I'm now back to square one, however I'm still going to try the 486 to see if that works.

    all the best

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts