. .
Page 1 of 5 123 ... LastLast
  1. #1
    my boxford 250 cnc lathe running on mach3 running ok yesterday fired it up today mach3 turn wont reset getting a message external emg stop requested checked switch all seems to be ok iam a machinist not a electronics expert any pointers as what to check
    thanks Geoff

  2. #2
    Do the drives turn on.? It's difficult to help without knowing how it's wired so what I'm trying to determine is if the e-stop is hard-wired and running through a relay that controls the whole system and then just sends a message to Mach3 that E-stop happened. Or if it's wired directly to the controller, in which case if the switch is ok it should reset.

    If it's hard wired through a relay then you could have a dead relay or blown fuse which is stopping it power up so mach3 won't get the OK and won't reset. But also the drives won't power up or will power up so easy to spot.
    A safe system would use such a setup and it fits with mach3 not coming out of reset if the E-stop switch is ok.

    The other thing it could be is a broken wire on the E-stop loop so even thou the switch is ok the signal is still not getting thru. Check the E-stop loop at the BOB with a meter for continuity.

    But Like I say it's difficult to tell you where to look without knowing more about how it's wired.

    I presumed you've tried this but just in case close down the computer and restart. Not just Mach3. If you are using a parallel port then check the cable hasn't come out as well because mach3 could see this as charge pump failure and E-stop.

  3. #3
    thanks for the reply
    all the electronics and computer are in the back of the machine when i sited the machine it is against the workshop wall i knew i would need accesses so it means removing the metal shed outside wall and two ton of crap stacked against it will let you no how i get on

  4. #4
    now the weather is find and we are in lockdown i have moved all the crap and taken back wall of the shed out to get to the electrics please see pictures cant see any fuses and two relays
    Click image for larger version. 

Name:	IMG_1106.jpg 
Views:	63 
Size:	270.9 KB 
ID:	27675
    Click image for larger version. 

Name:	IMG_1096.jpg 
Views:	60 
Size:	281.2 KB 
ID:	27674
    Click image for larger version. 

Name:	IMG_1092.jpg 
Views:	58 
Size:	305.3 KB 
ID:	27676
    Click image for larger version. 

Name:	IMG_1113.jpg 
Views:	56 
Size:	311.1 KB 
ID:	27677
    Click image for larger version. 

Name:	IMG_1099.jpg 
Views:	51 
Size:	183.3 KB 
ID:	27678
    Click image for larger version. 

Name:	IMG_1091.jpg 
Views:	50 
Size:	249.9 KB 
ID:	27679
    two of the black boxes have leds showing green the other box does not have leds on it
    thanks Geoff

  5. #5
    Tell us exactly what's happening or not, please.

    How do you normally start up the machine.? Step by step, so I can get an idea of how it might be wired.

  6. #6
    hi Jazz thanks for the reply
    first off a lot of the setting up and homing is done with a play station controller
    the start up sequence is as followers
    switch on 240 at the wall socket
    switch on playstation
    switch on computer remote button on front control panel of lathe
    click mach 3 loader
    current profile mach 3 click ok
    mach 3 screen
    all fires up computer side but cant reset emg stop so icant move forward on homing machine etc
    hope this helps thanks Geoff

  7. #7
    Erm ok well the PlayStation controller and it's plug-in is a prime suspect because it probably handles the E-stop as well, but I've never used one so not sure on that.
    If it was me I'd be disabling the PS controller plug-in to verify it's not this.

    However, try this first and see if you get movement. Go into ports n pins then Inputs and look for E-stop. Change the Active Low to the opposite of what it's set to now. ie If a tick toggles it to an (X).

    This is basically by-passing the E-stop and tricking Mach3 into thinking it's working, so be careful because you effectively haven't got a E-stop.

    If this works then it's either something on the E-stop wiring (or the BOB as blown an Input) or the PS controller or it's Plug-in are broken.

    Without knowing a little more about wiring and you tracing wires etc then it's hard to say for certain.

  8. #8
    thanks jazz will try this tomorrow not a fan of the play station control but thats what it came with
    thanks Geoff

  9. #9
    Quote Originally Posted by Geoff57 View Post
    thanks jazz will try this tomorrow not a fan of the play station control but thats what it came with
    thanks Geoff
    You don't have to use the PS controller it's just another method of operating the machine for jogging etc, rather than using the keyboard. It could be disconnected and just use the keyboard to jog etc.

  10. #10
    morning Jazz hope you are well
    i disabled the ps controller with no change
    next i bypassed the es now i can move the machine but the homing switch normally light up when i tried to home they are not working i ran a simple prog it ran ok put spindle will not run even tried mdi
    thanks Geoff

Page 1 of 5 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. mach3 won't reset
    By dougberrow in forum Artsoft Mach (3 & 4)
    Replies: 2
    Last Post: 27-05-2019, 10:25 PM
  2. Help needed with Mach 3 - reset external flashing light
    By Tom J in forum General Electronics
    Replies: 7
    Last Post: 26-03-2017, 07:34 PM
  3. Sieg KX1 & Mach3 won't come out of emergency reset
    By lateAtNight in forum Gantry/Router Machines & Building
    Replies: 32
    Last Post: 19-06-2015, 05:37 PM
  4. Please help me... It wont work.
    By kingcreaky in forum Artsoft Mach (3 & 4)
    Replies: 12
    Last Post: 22-01-2014, 09:42 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts