1. Folks,

    My 24V power supply went dead (conference this weekend) and Lee got me a new one that is 42Vdc but is not a rail set up as the 24V was.

    When wiring all three direct to the power supply get power but no motion and power LED's don't stay lit. Have wired them up on a joint spacer and no joy there either. The Motor are running at 1.5A and are 140Nm Nema23 from Steeperworld (yes I know I need to get better motors, need to earn some funs to pay for them).

    The Power supply could not have picked a worse time to go dead as have Gcode for three combs done and tested in Predator and everything is looking great plus covers for some custom work and was setting up to do some mouth pieces. This has put a MAJOR kink in the prospect of having everything ready for the National harmonica Convention this week end and would like to get at least five cut to go with me to sell and/or take orders. But empty handed is not going to work.

    Any help on getting the power supply i now have to drive the motors would be a blessing. They are 25's from DIYCNC and the BOB is also from Roy.

    Michael

  2. #2
    I think 42V could be too high for the 25's from Roy, check the spec - http://www.diycnc.co.uk/html/driver25ps.html

    What power supply have you got from Lee? the are adjustment pots on some which may let you turn the ouput voltage down but never tried it.

  3. Quote Originally Posted by HiltonSteve View Post
    I think 42V could be too high for the 25's from Roy, check the spec - http://www.diycnc.co.uk/html/driver25ps.html

    What power supply have you got from Lee? the are adjustment pots on some which may let you turn the ouput voltage down but never tried it.
    Model PS 407 Motion control unit
    Thanks

  4. Quote Originally Posted by m.marino View Post
    Model PS 407 Motion control unit
    Thanks
    I am trying to run three stepper off the one power supply.

    Michael

  5. #5
    Lee Roberts's Avatar
    Lives in Wigan, United Kingdom. Current Activity: Viewing Admin Control Panel Has been a member for 9-10 years. Has a total post count of 2,545. Received thanks 161 times, giving thanks to others 652 times. Made a monetary donation to the upkeep of the community. Referred 10 members to the community.
    Michael,

    I have sent you a PM with the wiring pdf i send people.

    The PSU i sent you was a PS407 this is rated at 40vdc 0a - 38vdc 7a. I dont actually sell a 42Vdc PSU ?

    The document for the 25's from Roy is saying:

    Power Input
    Maximum input voltage 35V, recommended regulated voltage 24-30V although
    the board will actually run down to 12Volts this will impair performance at higher
    step rates.

    If using an unregulated power supply, check peak voltage across output before
    connecting Driver25 board. A 25V unregulated supply can have 35V peak
    unloaded output. It may be necessary to place a load resistor permanently across
    the output to reduce the peak voltage as when the boards are not Enabled the
    power consumption is quite low.

    If you are looping through to three or four stepper boards it is a good idea to return the last board power connections back to the power supply thus creating a ring circuit and halving any voltage drop across the connecting wires.
    When you said "I don't know if the PS407 will have enough power as was using 350W" i still didnt know what driver units or PSU you had been using. This is why i compared the PS407 to the S35036 as this PSU was the closest match and you hadn't indicated an issue with the Output voltage.

    So i assumed you was looking to replace an S35036 unit and would have been using the driver50 units, the driver50 having a Maximum input voltage of 48V.

    You need to check with Roy to see if the LED's failing to stay lit is an indication of something, also ask him if supplying the driver units with 38v would have caused damage and what he would recommend you do.

    Michael, please let me know what Roy has said. If you would like to contact me, please email me so we can get you sorted out.

    Steve have you got a contact phone number for Roy?

    Thanks,
    Lee
    .Me

  6. #6
    Roy is in the process of moving house and doesn't have a valid phone number, email is best.

    .
    John S -

  7. The Alleggro A3977 chips used on those boards have a max operating voltage of 35V, above that they may experience various internal breakdown effects, however whether they are damaging or not depends on whether they were current/temperature limited. It is likely, but not guaranteed, that they would survive 42v in standby mode but back emf from the motors (if they ran) might produce high energy spikes that could be damaging.


    I suspect the power LEDs are taken off the 5v rail which is regulated off the 24v rail. It may be that the regulator is overheating at the higher input voltage and going into shutdown. Measure the 5v rail voltage at the output of the regulator (the L7805 3-legged beast)

  8. #8
    Quote Originally Posted by Lee Roberts View Post

    Steve have you got a contact phone number for Roy?

    Thanks,
    Lee
    No! Use email, that works best for Roy anyway.

Similar Threads

  1. Power Supply Suggestions please..
    By Ricardoco in forum General Electronics
    Replies: 37
    Last Post: 30-01-2013, 06:37 PM
  2. PCPPS V3 Power Supply?
    By birchy in forum General Electronics
    Replies: 4
    Last Post: 10-12-2012, 04:21 PM
  3. Replies: 0
    Last Post: 25-01-2012, 09:29 PM
  4. FOR SALE: 50V 20A Power supply
    By Jimmybristol in forum Items For Sale
    Replies: 8
    Last Post: 30-05-2011, 11:01 PM
  5. power supply
    By hitmythumb in forum General Electronics
    Replies: 6
    Last Post: 21-06-2009, 10:27 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •