. .
  1. #1
    hey guys

    my cnc machine started playing up by acting all random whilst doing auto tool zero. it would try to drive through the zero plate
    or if stops on touching the plate it would go up, reach the limit and still try to force its way up. I had simular behaviour in the past,
    so changed the Z motor cable. the problem remained. I changed the main board, problem stayed. I changed the stepper drive for
    Z and suddenly i can't control directions for xyz manually at all. however, when in Mach 3 i tell it to go to home coordinates it does fine, if i execute
    g-code it runs ok in all directions xyz. Any idea what could have caused the manual controls to be unresponsive.

    I run this gear http://www.cnc1.eu/en/profi4-controller.htm

    Thank you for any of your help.

  2. #2
    I'm not the most experienced here with touchplates, but sounds like the probe connection is screwy.

    Do you have the touch plate type with a switch in or is it just closing the circuit on contact?

    If its the switch type, the behavior you're describing would tally with the switch not activating in some cases (the machine keeps going down until it sees the switch close), or not releasing in other cases (the machine is supposed to hit the switch, then back off until the switch opens again - but never sees the switch open again so carries on up).

    Might also apply to the closed circuit on contact - but either way I'd be looking at my zero plate and it's wiring rather than the Z motor.

  3. #3
    Andy, thanks for your response.

    I have a closing the circuit on contact type. That kind of behaviour was occuring when running gcode. the router would go drive to plunging point and start drilling down the piece.
    Would that still be characteristic of a dodgy zero plate wire? I will have a look when get to workshop though.

    Any idea why the manual operation of xyz controls is not available all over sudden? I did check all the wiring or stepper drive and main board, all as should be. Can't see any visual
    problems.

    thanks

  4. #4
    Problems like these can be a nightmare to diagnose because could be anything from a loose connection to a faulty keyboard.
    In fact my first suggestion would be to replace the keyboard if you have one handy to quickly eliminate it. It's quite common for keyboards to go down.

    Next would be to do a Re-install of mach3 and any plug-ins if it's using any because I've seen it do things like this before. Save your current profile XML and re-install mach3 then load XML back in and you won't have to re-set anything.

    After that it's just a case of check all wires in case loose or damaged. Then if still not playing nice then I've no idea other than a computer issue which I very much doubt.!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CONVERSION: Bridgeport Manual to CNC conversion...
    By Davek0974 in forum Conversion Build Logs
    Replies: 413
    Last Post: 05-04-2020, 07:07 PM
  2. CNC is unresponsive to x y z movenment manually
    By eugeleb in forum Control Hardware & Systems
    Replies: 0
    Last Post: 29-02-2020, 01:35 AM
  3. Manual lube oil
    By alboy in forum General Discussion
    Replies: 3
    Last Post: 22-07-2016, 10:02 PM
  4. WANTED: Centec 2A manual
    By Web Goblin in forum Items Wanted
    Replies: 0
    Last Post: 03-09-2012, 08:56 AM
  5. Translating the manual
    By Robin Hewitt in forum Moulding Machines
    Replies: 22
    Last Post: 01-09-2012, 12:21 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •