Page 2 of 13 FirstFirst 123412 ... LastLast
  1. It was ordered on the 27/10/2009, and posted on the 28/10/2009, and got here today 10/11/2009, so two weeks to the day from ordering.

  2. Well with not quite knowing what is going on with regards to the current sensing resistors I tought it would be best to test how much current the board is pulling.

    I am using a bench PSU with a clean adjustable voltage output, the PSU shows me the set voltage and current load.

    I have preset the PSU to 13.8volts.

    The board by it's self with no stepper motors connected is pulling 0.20a.

    Here are the reading with just one stepper motor connected, with the board set to enable and motors at idle.

    DIP Switches 3-6 are set to ON.

    Bipolar Parallel
    DIP Switches 1-2
    ON/ON: 1.23a - 0.20a = 1.03a total /2 = 0.51a per phase.
    OFF/ON: 0.76a - 0.20a = 0.56a total /2 = 0.28a per phase.
    ON/OFF: 0.46a - 0.20a = 0.26a total /2 = 0.13a per phase.
    OFF/OFF: 0.25a - 0.20a = 0.05a total /2 = 0.02a per phase.

    Bipolar Series
    DIP Switches 1-2
    ON/ON: 2.10a - 0.20a = 1.90a total /2 = 0.95a per phase.
    OFF/ON: 2.10a - 0.20a = 1.90a total /2 = 0.95a per phase.
    ON/OFF: 1.05a - 0.20a = 0.85a total /2 = 0.42a per phase.
    OFF/OFF: 0.40a - 0.20a = 0.20a total /2 = 0.10a per phase.

    All the readings are aprox.

    Now I am even more confused then when I started. :confused:
    Last edited by Mad Professor; 10-11-2009 at 12:49 PM.

  3. Quote Originally Posted by Mad Professor View Post
    Well with not quite knowing what is going on with regards to the current sensing resistors I tought it would be best to test how much current the board is pulling.

    I am using a bench PSU with a clean adjustable voltage output, the PSU shows me the set voltage and current load.

    I have preset the PSU to 13.8volts.

    The board by it's self with no stepper motors connected is pulling 0.20a.

    Here are the reading with just one stepper motor connected, with the board set to enable and motors at idle.

    DIP Switches 3-6 are set to ON.

    Bipolar Parallel
    DIP Switches 1-2
    ON/ON: 1.23a - 0.20a = 1.03a total /2 = 0.51a per phase.
    OFF/ON: 0.76a - 0.20a = 0.56a total /2 = 0.28a per phase.
    ON/OFF: 0.46a - 0.20a = 0.26a total /2 = 0.13a per phase.
    OFF/OFF: 0.25a - 0.20a = 0.05a total /2 = 0.02a per phase.

    Bipolar Series
    DIP Switches 1-2
    ON/ON: 2.10a - 0.20a = 1.90a total /2 = 0.95a per phase.
    OFF/ON: 2.10a - 0.20a = 1.90a total /2 = 0.95a per phase.
    ON/OFF: 1.05a - 0.20a = 0.85a total /2 = 0.42a per phase.
    OFF/OFF: 0.40a - 0.20a = 0.20a total /2 = 0.10a per phase.

    All the readings are aprox.

    Now I am even more confused then when I started. :confused:
    Measure the voltage across each phase... I suspect only one phase is energised when the motor is idling so your "/2" is wrong... what motors are these and what DC resistance?

    At a guess I'd say your parallel and series figures are swapped. Again whats the DC resistance across A+ & A- in each mode?

    Also remember that the chopper current limiting will regulate peak currents. A 1.5A nominal peak will show up as a 1.5/sqrt(2) RMS current on an analogue meter, i.e. about 1A. It doesnt make a lot of sense unless the resistance of the motors is such that the figure should have been higher on the 100% setting but would need more volts (anything higher than 5ohms would not get to the expected 3A peak - 2.2A rms - current limit on 13.8v, would need 24v)

  4. I am using Astrosyn MY103H702 stepper motors <click link for datasheet.

    I will do the other tests shortly.

  5. Quote Originally Posted by Mad Professor View Post
    I am using Astrosyn MY103H702 stepper motors <click link for datasheet.

    I will do the other tests shortly.
    Same motors I have.

    I was wondering if the switches are actually adjusting the idle current when the motor is stationary and not the operating current, the data sheet isnt clear. If that was the case then the 100% setting corresponds to the RMS phase current set by the resistors which would be the RMS current shown by the ammeter

    The maximum peak current this could be for these motors on 13.3v (allowing .5v for Vref) is:
    Unipolar: 13.3/6.2 = 2A (which appears to be your bipolar series setting)
    Bipolar Parallel 13.3/3.1 = 4A
    Bipolar Series 13.3/12.4 = 1A (which appears to be your bipolar parallel setting)

    Do you have a stand-alone ammeter or a 'scope?

  6. I have tested the voltage outputs from both phases, and they are both powered wile at idle.

    Bipolar Parallel: 4.00 to 4.15volts.
    Bipolar Series: 12.95 to 13.00volts.

    I do have a DVM with ammeter but it is quite old so don't know how good it will be.

    I also do have a PicoScope 2202 USB Oscilloscope.
    Last edited by Mad Professor; 10-11-2009 at 07:27 PM.

  7. Quote Originally Posted by Mad Professor View Post
    I have tested the voltage outputs from both phases, and they are both powered wile at idle.

    Bipolar Parallel: 4.00 to 4.15volts.
    Bipolar Series: 12.95 to 13.00volts.

    I do have a DVM with ammeter but it is quite old so don't know how good it will be.

    I also do have a PicoScope 2202 USB Oscilloscope.

    Easiest way to verify the current is to plot the voltage across the sense resistors. If you have the latest PicoSoft 6 software it will, if I recall right, calculate the RMS and peak currents for you (I have a Pico3205 scope), or you can easily work it out...

  8. I am running PicoScope v6.3.4.0.

    I have not had this scope long so I am still finding my way around the settings, so I am not 100% sure what you are after.

    Bipolar Parallel:
    True RMS Avg 120mv.
    Peak to Peak Avg 1.15v

    Bipolar Series:
    True RMS Avg 80mv.
    Peak to Peak Avg 30mv.

  9. Quote Originally Posted by Mad Professor View Post
    I am running PicoScope v6.3.4.0.

    I have not had this scope long so I am still finding my way around the settings, so I am not 100% sure what you are after.

    Bipolar Parallel:
    True RMS Avg 120mv.
    Peak to Peak Avg 1.15v

    Bipolar Series:
    True RMS Avg 80mv.
    Peak to Peak Avg 30mv.
    1.15v peak over .33 ohm = 3.5A peak, RMS = .36A

    80mV over .33ohm = 0.24A, but the peak looks low, sure it wasnt 300mV?

    Can you post the waveforms?

  10. Sure I can save the waveforms, do you want them as screenshots or save the waveforms to an output file?

Page 2 of 13 FirstFirst 123412 ... LastLast

Similar Threads

  1. Replies: 1
    Last Post: 16-03-2014, 07:29 PM
  2. 4 Axis TB6560 CNC Driver For NEMA17/23/34 Motor 3A on Ebay update.
    By TommeyReed in forum Motor Drivers & Controllers
    Replies: 2
    Last Post: 06-03-2012, 06:01 PM
  3. FOR SALE: 4 Axis TB6560 Stepper Motor Driver Board
    By Mad Professor in forum Items For Sale
    Replies: 1
    Last Post: 04-01-2011, 06:54 PM
  4. eBay TB6560 Stepper Motor Driver Boards
    By irving2008 in forum Motor Drivers & Controllers
    Replies: 13
    Last Post: 07-04-2010, 04:48 PM
  5. manual for eBay TB6560 Stepper Motor Driver Boards?
    By Dan Brown in forum Motor Drivers & Controllers
    Replies: 5
    Last Post: 06-01-2010, 10:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •