Page 1 of 3 123 LastLast
  1. #1
    Hi All
    Got back to playing with my cnc mill. Tried to do some engraving but as the engraving proceeds accross the x axis the cutting depth gets greater so I assume the z axis is loosing steps.
    How is one supposed to test for this, I think I should try a dial gauge.

    Peter

  2. #2
    That sounds to me like the surface isn't parallel to the X-axis. Does the cutting depth get less when moving the other way around (just an obvious thing to check!)

    You could also try locking the Z-axis somehow (so it won't move).

  3. #3
    Problem is if you lock the z-axis you wont be able to do engraving!

    peter

  4. #4
    Yes, but you can check if it moves up and down - it's only for testing.

  5. #5
    Reduce the acceleration what is happening is that the Z axis is losing steps on the way up so when it lowers it goes deeper into the work.

    May pay to also reduce the microstepping as more steps, less torque.


    .
    John S -

  6. #6
    There is a difference between up and down.

    Up can be the start of two consecutive G0's with a 180 degree turn in the middle.

    A sort of worst case scenario for losing steps if you're accelerations aren't quite up to scratch.

  7. #7
    so what should the acceleration be!
    I thought more steps was better, obviously not.

    Peter

  8. #8
    Unfortunately no one can tell you as it's all machine dependant.

    You need to alter the settings and try it under power.

    Replace the tool for something with a flat end [ reverse the cutter ? ] and then get something like a 1/2" roller or just a piece of short scrap.
    Put that under the 'cutter' and zero onto it. Remove roller and move head up and down a few times and see if the roller will roll back under when it's in the down position.
    This will give you a bit of leeway for it to move without clouting into any work.

    .
    John S -

  9. #9
    Got back to my X1 mill and tried JohnS suggestion to reduce the acceleration. Tried a search on the web, not a lot of help so just winged it. Also tried JohnS suggestion about the spaced under the z-axis and it definately showed it losing steps on the up direction.
    Thought some more and have now tried a dial gauge, and old one I have had for some time and never found a use for in that it works by pulling up the plunger. So I fixed the plunger rod to a chuck in the z-axis and proceeded to raise and lower the head, could not detect that much change but it did alter over 10 cycles, ie gets lower.
    I then thought about the gibs and tried to adjust them, this has made it worse.
    I also noticed another strange thing in that if I jog up or down using the slowest jog rate the dial gauge shows the head to move in the same direction for a few steps after I have changed direction?
    I have read on the web that some have had problems with the head gibs saying that are difficult to set due the weight of it. I may now have to consider a counter weight system as for what I want the mill for a poor z-axis is next to useless.
    Peter

  10. Peter,

    How are you driving the Z-axis and what is the drive to the quill motion, a worm and rack or pinion and rack?

    Putting in a counterbalance arrangement will aid in supporting the weight of the quill etc, but at the expense of adding more mass to move = lower acceleration for the same motor torque

Page 1 of 3 123 LastLast

Similar Threads

  1. First steps, advice needed
    By Wobblycogs in forum Gantry/Router Machines & Building
    Replies: 6
    Last Post: 02-11-2012, 02:30 PM
  2. Help please Steps and control?
    By totts in forum Motor Drivers & Controllers
    Replies: 9
    Last Post: 31-03-2012, 07:44 PM
  3. Missing Steps + Stalling X-axis
    By danielbriggs in forum Linear & Rotary Motion
    Replies: 5
    Last Post: 02-09-2010, 02:59 PM
  4. Heelp! Dual axis steppers.. Losing steps.. Pulling hair out..!
    By fasteddy in forum Motor Drivers & Controllers
    Replies: 9
    Last Post: 14-05-2010, 02:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •