. .
  1. #1
    Iím getting towards the end of my DIY CNC build and Iím having trouble getting my spindle to run. When started it turns probably less than an 8th of a turn then stops and has a resistance if you try to turn it by hand until I stop the VFD. The display on the VFD with show a small Hz rating for a split second as the spindle twitches before going to 0 and output current is displayed as constant 5.9A.

    https://youtu.be/yG2R5bPUDbA

    I have purchased a 800w G-Penny water cooled spindle rated at 220 volts, 400Hz, 4A and 24,000rpm. To run this Iíve chosen an Invertek Optidrive E3 230v 1ph to 3ph drive rated at 1.5kW and 0-500Hz control range.

    Iím using a 4 core SY shielded control cable to connect the drive and motor with pins 1,2,3 to U,V,W respectively at the drive and pin 4 and the shielding both to the earth (pin 4 is connected internally and grounds the entire machine).

    Iíve connected a wire linking terminals 1 and 2 to act as an enable switch and all other terminals are empty. Then Iíve configured the basic parameters as:

    P-01 Max Speed = 24000
    P-02 Min Speed = 6000
    P-03 Acceleration Time = 3.0
    P-04 Deceleration Time = 3.0
    P-05 Stopping Mode = 0 (Ramped Stop)
    P-06 Energy Optimiser = 0 (Disabled)
    P-07 Motor Rated Voltage = 220
    P-08 Motor Rated Current = 4.0
    P-09 Motor Rated Frequency = 400
    P-10 Motor Rated Speed = 24000
    P-11 Low Frequency Torque Boost = Default rating dependant.
    P-12 Control Mode = 1 (Keypad Control, Single Direction)

    I believe the cable connections to be fine as I get almost identical readings if I measure the resistance between phases at the motor with the plug removed or at the drive via the spindle power cable. Iíve got 3.8 Ė 3.9 Ohms between all three phases and less than 0.7 Ohms from ground to any point on the CNC machine including spindle.

    Also with the power off the spindle rotates freely by hand so I havenít over tightened the clamp, it only gets hard to rotate when powered up.

    Any help greatly appreciated. Thanks.

  2. How are you starting it ? Also have you checked how many poles are set up in the VFD ?
    ..Clive
    The more you know, The better you know, How little you know

  3. #3
    I'm starting it using the keypad on the front of the drive. I've tried setting various speeds between 6k and 24k before hitting start and always the same result. Haven't seen an option for setting poles in the VFD (read manual a few times now). I've assumed as it was given motor rated frequency of 400hz and speed of 24k rpm it will know its a 2 pole motor.

  4. Quote Originally Posted by Bilbo9000 View Post
    I'm starting it using the keypad on the front of the drive. I've tried setting various speeds between 6k and 24k before hitting start and always the same result. Haven't seen an option for setting poles in the VFD (read manual a few times now). I've assumed as it was given motor rated frequency of 400hz and speed of 24k rpm it will know its a 2 pole motor.
    You are correct there is no mention of poles in the manual !! I can't think of anything else
    ..Clive
    The more you know, The better you know, How little you know

  5. #5
    Well I now know it's not an issue with the spindle itself or the cable. I dug out and cheap Chinese Furling VFD I had and did my best to program it via the chinese handbook and the spindle fire straight up to speed, no problem. So it's something I've setup wrong with the drive or it's a dud.

    EDIT: So now have it working on the Invertek drive. By changing P-51 from Vector Control mode to VF Control it works. However am I loosing out on torque if I want to use the motor down at low speeds (6k+) by running in VF mode instead of Vector? Any idea why it would behave like this?
    Last edited by Bilbo9000; 5 Days Ago at 08:35 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Spindle drive Boxford V190 VMC
    By mosoeng in forum Boxford Vertical Mills
    Replies: 4
    Last Post: 19-09-2019, 09:11 AM
  2. GEC Gemini spindle drive from Boxford 260 VMC
    By Roadrunna in forum Boxford Vertical Mills
    Replies: 17
    Last Post: 06-03-2015, 01:42 AM
  3. mitsubishi freqrol spindle drive
    By dave498 in forum Spindles & Drive Motors
    Replies: 1
    Last Post: 26-02-2015, 06:57 PM
  4. 800w spindle - noise & controlling remotely
    By HankMcSpank in forum Generic Chinese Spindles
    Replies: 49
    Last Post: 17-10-2013, 06:26 PM
  5. dc motor - spindle / shaft drive
    By dsc in forum Spindles & Drive Motors
    Replies: 21
    Last Post: 01-06-2013, 10:42 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •