. .

Thread: Driver help

Page 1 of 3 123 LastLast
  1. #1
    hi all, im after a little help. i recently upgraded to uccnc and two motors on the x axis. i cannot get movement from them. my y and z axis work perfectly. i am using a uc300 eth, with a stv2 breakout board. i have two matching drivers:
    https://www.omc-stepperonline.com/di...-34-motor.html
    Attachment 29658
    everything seems to be right, but i get no movement. i am getting the correct voltage to the drivers, and the dro's move correctly. all the settings seem correct and the motors lock when powered on but still no movement.
    I'm at the point of pulling my hair out now, please help
    ST-V2.pdf

    Click image for larger version. 

Name:	20210303_190235.jpg 
Views:	32 
Size:	195.9 KB 
ID:	29659Click image for larger version. 

Name:	20210303_190227.jpg 
Views:	30 
Size:	277.8 KB 
ID:	29660Click image for larger version. 

Name:	20210303_190207.jpg 
Views:	29 
Size:	173.0 KB 
ID:	29661Click image for larger version. 

Name:	20210303_190242.jpg 
Views:	31 
Size:	251.9 KB 
ID:	29662

  2. #2
    Do you have a diagram of how you've wired these drivers? - it might help find your problem. I also notice on the first screen that there's no enable pin listed, could this be an issue?

  3. #3
    yep im not using enable. maybe i should, im not using it on my y and z and they work. i have x step pin 2 to step- on the driver x dir pin 3 to dir- on driver and +5v to step+ and dir+. motors are 8wire 4nm nema23 from cnc4pc which are wired bipolar parallel

  4. #4
    Looking at the manual it seems that the MF input on the driver is more of a disable than enable function, so maybe that's not an issue. On your screenshots I see that the B axis DIR is ticked as low active, whereas X axis isn't and neither of the STEP outputs are set as low active either - have you tried setting these?

  5. #5
    Had a play around this afternoon and I have my x and b axis working. I set both to active low step and all of a sudden they work. Unfortunately my y axis now doesn't, even though it did yesterday.
    No settings have changed, I checked all the wires are still connected, but I just get a faint click when I try to jog the y.

  6. #6
    Have you checked the minimum pulse width that is outputted to the drive? Too narrow / short and the drive's input circuit may not be fast enough to see it. Another related parameter might be the maximum pulse frequency - similar issue if you have this set too high, may not be "seen" by the drive.

  7. #7
    Yep checked the pulse width, all seems ok. I am thinking its the bob as I can the z axis wiring in to the y drive and it works, but when I plug the y wiring in to the z drive it doesn't work. Can anyone recommend a good breakout board to use with the uc300 etc. I would like the ub1 but can't justify the cost of it at the moment

  8. #8
    John, I've used the generic Chinese BoBs with opto-inputs - got two stacked on a UC300 without any fuss at all. Your experience might vary.

  9. #9
    Quote Originally Posted by Doddy View Post
    John, I've used the generic Chinese BoBs with opto-inputs - got two stacked on a UC300 without any fuss at all. Your experience might vary.
    Have you got a link to ones you have please?

  10. #10
    eBay item code 373449654531 - I bought a batch of 5 of those recently - all a generic design (HCT245 output drivers, Opto inputs driving a HCT14 Schmitt trigger input) - just generally a cheap workable design.

    The only thing is you'd need a DB25-26W IDC header cable

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Driver led's
    By Duffman in forum Motor Drivers & Controllers
    Replies: 5
    Last Post: 16-01-2016, 01:41 PM
  2. Replies: 1
    Last Post: 16-03-2014, 06:29 PM
  3. Dc servo driver
    By Treemonkey in forum Motor Drivers & Controllers
    Replies: 11
    Last Post: 11-02-2013, 07:16 PM
  4. Driver Lights Red
    By Toddy in forum Motor Drivers & Controllers
    Replies: 6
    Last Post: 05-11-2011, 02:46 PM
  5. Driver box
    By John S in forum General Electronics
    Replies: 1
    Last Post: 21-06-2009, 11:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •