. .
  1. #1
    Misterg's Avatar
    Lives in North Wales, United Kingdom. Last Activity: 21 Hours Ago Has been a member for 0-1 years. Has a total post count of 9. Received thanks 8 times, giving thanks to others 2 times.
    I'm not sure if this should be in mills or routers, but here's some construction detail of a machine that I've made:



    It's something I drifted into and was not well defined (not an approach that I would recommend!). Bits were designed to suit whatever I could get hold of cheaply. When I first started it, the intention was to be able to do some 3D relief carving in wood, but as it progressed, I realised that I really would like to machine aluminium, even if slowly.

    The machine is designed around the cheap 500W ER11 DC spindle motor that's all over ebay, amazon, etc. At the time I didn't know better, but DO NOT do the same.


    Z axis was made from a length of aluminium 'U' section extrusion. As expected the back of it wasn't flat, so I hacked out the middle with a woodwork router and then levelled the rest using abrasive paper on a flat plate (I have a 25mm thick glass plate that I use as my flatness reference).





    The Z axis guides are 12mm THK rails that were NOS from ebay. They aren't ideal as they aren't preloaded and don't have side seals (but they were cheaper than Chinese ones. I set the rail centres such that 123 blocks were a convenient size to set the rails parallel (ignore the dial gauge - it's not doing anything)



    I made the Z/X axis adapter plate in 3 pieces to form a channel for the Z axis leadscrew to run in. The front plates were marked out and drilled as one piece before sawing a section out of the middle to create a channel for the Z axis leadscrew.





    The original idea was to machine the seat for the ballscrew nut with the parts assembled, but they wouldn't fit in my lathe, so each part was machined separately and then fitted together:









    The X axis rails were also NOS THK ones from ebay, but these were a bargain - they're 15mm 4 race type with medium preload.

    Out of photos for this post - will continue later.
    Last edited by Misterg; 1 Week Ago at 10:55 PM.

  2. The Following User Says Thank You to Misterg For This Useful Post:


  3. #2
    Misterg's Avatar
    Lives in North Wales, United Kingdom. Last Activity: 21 Hours Ago Has been a member for 0-1 years. Has a total post count of 9. Received thanks 8 times, giving thanks to others 2 times.
    The ganty was fabricated out of 100 x 50 x 3 hollow section steel. Thinner than I wanted, but I thought it might be OK if I welded on some thicker pads where the linear rails would fit, and possibly filled it with sand, or something to stop it ringing if that proved to be a problem.

    I tacked some 25 x 25 x 3 angle to the front to square up the corners and give something to secure the linear rails to.




    I was only going to stitch weld it at ~25mm intervals, but cocked up my marking out and ended up with the tack welds in the spaces between stitches - it looked cr*p so I filled in the blanks and they ended up fully welded.





    The hole in the top is there in case I decide to try filling the fabrication with something (sand) at some point in the future. The hole with a sleeve welded into it is for access to the screws on the back of the Z axis cars, and the four extra holes in the face are to allow any filling to flow into the uprights.

    The best I could scrounge for some uprights was some 80 x 40 x 3 which were notched to fit around the cross beam (I had it in my head that the joints would be more rigid if they spanned two faces of the box)






    I hadn't designed the bottom half of the machine at this point, so just made some flanges that could be welded to whatever I ended up with later:





    At this point, the face of the gantry was 0.3mm out of plane (judged against the glass plate). I laid it on its back, got it level and masked it off before slathering the rail beds with slow setting epoxy.



    I put a layer of cling film over the glass plate and carefully lowered onto the epoxy, squidging it out.



    Once I was reasonably confident that it wouldn't slide off onto the floor, I walked away and left it for a day.

    Getting the glass to release was a bit of a battle - I thought that they were permanently joined at one point. It eventually came apart and after a clean-up, it seems to have worked quite well:


  4. The Following 2 Users Say Thank You to Misterg For This Useful Post:


  5. #3
    Nice work!

  6. The Following User Says Thank You to Voicecoil For This Useful Post:


  7. #4
    Misterg's Avatar
    Lives in North Wales, United Kingdom. Last Activity: 21 Hours Ago Has been a member for 0-1 years. Has a total post count of 9. Received thanks 8 times, giving thanks to others 2 times.
    I set one of the linear rails sraight and parallel using the glass plate as a reference and marked for the securing screws.



    I got it indicating straight to within about 0.01mm which I was reasonably happy with - I'm not sure that the glass plate is that good.

    With one rail set and fastened in place, the carriage was used to get the second rail parallel



    After all the holes were drilled and tapped, a quick test build:



    All seemed to be working as it should, so I gave it the world's worst paint job and went on holiday for a few weeks




    Once I came back, I made up a bracket to mount the X axis stepper motor and leadscrew to the underside of the gantry - all 4 jaw work on the lathe. The leadscrew thrust bearing is a standard FK10 from China which came with pukka angular contact bearings in it.

    The leadscrews are all 12mm dia x 4mm pitch (selected pretty much at random!)



    The bracket is secured with 3 screws into the underside on the gantry. I realised that I hadn't thought this through properly when I was marking out for the screw holes so I had to get creative when drilling them.









    The loose end of the ballscrew is just supported by a normal ball bearing to stop it whipping around (the bearing is free to slide on the end of the ballscrew).



    X axis drive installed:


  8. The Following User Says Thank You to Misterg For This Useful Post:


  9. #5
    Misterg's Avatar
    Lives in North Wales, United Kingdom. Last Activity: 21 Hours Ago Has been a member for 0-1 years. Has a total post count of 9. Received thanks 8 times, giving thanks to others 2 times.
    I spent some time looking for a cheap surface plate to use as the machine base, but couldn't find anything that was cheap enough and not 200 miles away. So I went on the scrounge to see what steel I could find. I came back with some 80 x 80 x 3 box (again thinner than I would have liked) and some 40 x 40 x 5(?) which would do just fine for the Y axis.

    I cut a couple of lengths of the 40 x 40 and squared them up the best I could with files then wrestled them into the vertical slide on the lathe to clean up a slot for the leadscrew bearing mount:




    The bearing mount itself needed 3/4 of a hole boring in it



    The mount is bolted to through the 40x40 so that it's angle can be tweaked to be truly square to the Y axis leadscrew. The thrust bearing is a standard BK10 part from China. (I changed the standard ball bearings it came with for some angular contact ones.)




    With the 40 x 40 spacing set, I cut out the 80 x 80 section to suit. The area between the 40 x 40s also needed to be cut away and plated over to clear the leadscrew and ball nut.




    I added some gussets to try and brace the 40 x 40 rails to the bottom corner of the 80 x 80




    Before welding the mounting flanges for the gantry feet I put the gantry in position and set it square and level to the base



    Everything will be squared up properly when the thing is finally assembled, and the flanges bedded in epoxy, but I wanted to get it as close as I could at this stage.

    The mount for the Y axis stepper is bolted to the ends of the two 40 x 40 sections (I couldn't think of a better way of doing it).

    I welded a couple of blocks into the ends of the sections to give something to fix the stepper mount to






    And hacked a mount out of aluminium (wouldn't it be nice to have a CNC to do this stuff? )




    I thought that the Y axis still looked a bit flimsy in the side-to-side direction so welded in a bit more bracing - trying to tie the Y rails into the gantry feet




  10. #6
    Misterg's Avatar
    Lives in North Wales, United Kingdom. Last Activity: 21 Hours Ago Has been a member for 0-1 years. Has a total post count of 9. Received thanks 8 times, giving thanks to others 2 times.
    I capped all the open ends on the base and welded in a few more blind bushes where I expected to need to fix something, then keyed up the tops of the rails with some coarse paper on the sander before masking them up and doing the epoxy/glass plate thing again to level them off






    Again, the epoxy bedding seemed to work OK.




    A slightly better paint job




    And a look at progress so far.



    The Y axis carriage was made from an aluminium tooling plate offcut (ex ebay). It arrived cut nice and square, so by fixing the Y axis cars parallel to one edge, I could get the Y linear rails perpendicular to the X axis by setting the end of the plate parallel to the X axis (everything was just being roughly squared at this point).




    The linear rails are the Chinese ones I'd ordered originally (12mm x 300mm). I'd have liked them to be a bit longer and a bit heavier (even 15mm), but as I already had them, and was trying to do this on a shoe-string, it seemed a waste not to use them.

    I had trouble with the carriage binding when I tightened everything up initially, which I eventually traced to the Chinese ball bearing cars being different heights:




    I'd bought a pair of rails with 1 car each plus two spare cars from the same listing on Aliexpress. The heights depended on which rail they were mounted on, and also which way around they were fitted. By swapping them between rails and turning them end-for-end I eventually found a combination that was near enough that the carriage would run smoothly without binding. The tooling plate offcut also had a slight bow to it which didn't help. (Any height difference side to side wasn't really important as I would be aligning the gantry to the Y axis eventually.)

    I'd already ordered a leadscrew for the Y axis on spec, and as it turned out, it was too long. It was easily lopped to length with the angle grinder, but turning the end down to take the support bearing was a bit much for the mini lathe - the intermittent cuts on hardened steel turned it into a bit of a rodeo, and not something I'd like to make a habit of!




    It did it though




    I tried to cut a circlip groove in it using an HSS tool, but it (quite literally) didn't even scratch the surface. I eventually resorted to cutting the groove with a hacksaw.

    A a nice, parallel packing piece was needed to make up the space between the ballscrew nut and the underside of the carriage (stll a space in the photo) - this was just faced to length in the lathe.

    The Y axis assembled



    The support bearing for the end of the leadscrew was similar to the X axis one.

    And that was the major bits all made. :)

  11. The Following 2 Users Say Thank You to Misterg For This Useful Post:


  12. #7
    Excellent work Mr G, coming along nicely, nice and strong..
    -use common sense, if you lack it, there is no software to help that.

    Email: dean@jazzcnc.co.uk

    Web site: www.jazzcnc.co.uk

  13. The Following User Says Thank You to JAZZCNC For This Useful Post:


  14. #8
    Misterg's Avatar
    Lives in North Wales, United Kingdom. Last Activity: 21 Hours Ago Has been a member for 0-1 years. Has a total post count of 9. Received thanks 8 times, giving thanks to others 2 times.
    Thanks for the kind comments :)

    As I hadn't really got the means to machine the mounting faces of the gantry feet properly flat, I intended to use epoxy as a shimming material and to adjust the gantry alignment before the epoxy set.

    I fitted studs to the holes in the base and to try and stop the epoxy squeezing up the bolt holes in the gantry, I put an O ring around each stud.




    The studs themselves and metal faces were also given a coating of furniture wax to act as a release agent (in case it needs to come apart). After a dry run with bits of packing, etc. to make sure it was possible to get it all set square, I masked off the area around the joints and gave the mounting faces a liberal buttering of epoxy:




    There followed a frantic and stressfull couple of hours trying to get the gantry level to the table (side to side), and square to the Y rail travel and standing vertical (nod), all at the same time. I'd bought myself a 6" square to act as a reference, but I only had the one, so had to check each direction separately (with the square lightly clamped in place), make an adjustment, then go back and find out if it had affected any of the others (usually it had!). Do you ever wish you hadn't started something at 10:00 at night?

    I'd put jacking screws in the flanges on the gantry feet to help with this process, and while they worked fine for levelling the gantry and correcting for nod, I'd completely overlooked the need to adjust the angle of the gantry to square the X and Y axes. The O rings I'd fitted on the studs were quite effective in keeping the studs centred in their holes - not where I wanted them to be! After a lot of sweat, frustration (and almost tears), I got the gantry and table reasonably squared (I ended up hammering a screwdriver down one of the stud holes to stop the blimmin' thing creeping back on me ).


    I managed to get the 'nod' to ~0.01mm over ~100mm




    And the axes square to a little bit better than that




    And got the gantry levelled from side to side to within ~0.03mm over ~200mm as far as I could tell with the slightly warped table.





    There was a healthy amount of squeeze-out from the joints that also had to be cleaned up before I could get to bed.




    After a couple of days for the epoxy to go off, I fully tightened the nuts on the mounting studs and re-checked the perpendiculatity, etc.




    With it together, I hastily cobbled together the basics to drive the steppers with GRBL on an Arduino. It's not pretty:




    It would draw pictures though :)




    After driving various bits off the end of their linear rails a few times (and having to play hunt the ball bearings) I decided to fit the homing/limit switches (I found some nice little normally closed inductive proximity switches that are only 6mm dia.)

    The X axis homing/limit switch fits into the X/Z adapter and is triggered by 'flags' on the top of the gantry: (I was going to fit limit flags at each end of the travel, but ended up with just one that is used for homing.)




    The Z axis switch fits into the hole on the other side of the X/Z adapter plate, but facing in the opposite direction to the X one. It's triggered by 'flags' on the side of the Z axis. (The Y axis one is under the table).


    I also fitted a cable chain, etc. and did the final wiring on the machine side of things. There's a couple of tubes there intended for an oil mist style lubricator and a solenoid for the same on the side of the machine.



    I'd originally (rather reluctantly) decided to make the working table out of MDF, but then a decent sized offcut of 15mm tooling plate popped up on ebay. After cutting it to size, I clamped it to the Y carriage and used the machine itself to drill holes through the work table and the carriage below it. The first time it cut anything in anger, and my first CAM program (the mouth was very dry before I pressed the button...)





    Unfortunately, in the process, one of the clamps decapitated the Y axis homing switch!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Diy CNC mill-router-thing in my attic
    By Pencilfish in forum Workshop & Equipment
    Replies: 0
    Last Post: 29-11-2021, 06:18 PM
  2. Funny forum thing.....:disillusionment:
    By Voicecoil in forum General Discussion
    Replies: 4
    Last Post: 07-04-2021, 06:47 PM
  3. Replies: 11
    Last Post: 26-08-2020, 09:04 PM
  4. Trying to get this thing to work
    By GeneO in forum Machine Discussion
    Replies: 29
    Last Post: 21-01-2020, 09:29 PM
  5. Bought a laser, now there's a thing
    By Robin Hewitt in forum Laser Machines & Building
    Replies: 26
    Last Post: 25-02-2013, 07:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •