Page 5 of 5 FirstFirst ... 345
  1. #41
    Wow, thanks John and Irving2008

    Before I blow the dust off my GCSE electronics certificate (grade B - long time ago!), I will give Roy's suggestion a try when the part arrives. If it works, I will upgrade to a higher voltage capacitor as you suggest. I still remember seeing a capacitor explode when it was deliberately connected the wrong way around, as a warning, so am cautious about higher capacity units in general.

    If it does not work, I should give Roy the chance to swap the power supply for another unit if it is genuinely faulty. If that is still no good, then I will take you up on the offer of helping me make my own linear supply. I have ring terminals and an electricians crimp tool (proper heavy ratchet job, not cheap DIY one), and with a couple of questions and a diagram could probably put one together.

    The system 3 board is technically rated at 24v-30v, although Roy does allow 33v to give a bit more motor power. Anything higher is probably pushing it, and so the above specs might need to be revised a bit. Could I add a voltage regulator (?) or start with a different transformer?

    If I do end up making my own, I'll signoff from this thread and start another.

    Building a CNC machine to make a better one since 2010 . . .
    MK1 (1st photo), MK2, MK3, MK4

  2. In that case go with an 18v transformer not 25v... 18v *1.4 -1.1 = 24.1v nominal, 26v off load. Ideally you want a 22v transformer but the only way to get one is to roll your own.

    Actually there is a solution to this - its called buck windings. Basically you wind 10turns of heavy gauge wire onto the transformer and measure the voltage you get, then adjust the number of turns till you get 3v and connect that in series with the other windings in a way that reduces the output voltage from 25 to 22v. This allows you to fine tune the output voltage for a little more effort and messing about but relatively little cost (a reel of shellac insulated 14 gauge copper wire basically)

  3. #43
    More testing, and a video !

    The 10,000uF 35v capacitor arrived yesterday, so I connected it across the power supply to the board, but the glitching was unfortunately still there. I also added a further 0.1uF capacitor as well but this was no better. The scope showed that the capacitor reduced the ripple, but the steppers still glitched.

    With this scope connected to the power supply input I could monitor the waveform at different motor speeds. At very low speed (1KHz) there was ripple, which you would expect, but there was also a sort of saw tooth pattern which might be the stepper pulses appearing at the power supply. The stepper was glitching at these lower speeds.

    As I increased the frequency up to about 6KHz the waveform started to smooth out and the saw tooth slowly disappeared. The stepper was then very smooth and did not glitch. Above 6KHz the waveform and the steppers continued to be smooth.

    I've posted a private video on YouTube. Sorry it is low quality, my camera is quiet old. Also, YouTube has moved the sound well ahead of, and out of synch with, the picture. Don't know why.

    I've sent all this info to Roy at DIYCNC to see if a replacement PSU is the next thing to try.

    Other info, when I turn the steppers by hand, the blue power light comes on on the board (when it is switched off). They must be generating current as alternators. If I drive the steppers with my cordless drill then at quite low speed the drill stutters. If I repeat this but don't plug the motors into the board then the drill can spin them up to high speed very smoothly. Is this all normal behaviour?

    Building a CNC machine to make a better one since 2010 . . .
    MK1 (1st photo), MK2, MK3, MK4

  4. #44
    I have an idea that you might like to check out, find out exactly what current your PCB is drawing from the parallel port outputs in milliamps. Its only guaranteed to be a TTL output so when its high (5 volts) it should not exceed 2.6ma. When low (0 volts) it should not exceed 24ma..
    Many commercial and home built units simply take too much current and damage the interface.....
    Here is a good tutorial on the printer port:-
    You can find this at point 6. in the tutorial:-
    6. Electrical

    See also the tutorial section below on TTL outputs.

    The Data Out pins were orginally driven by a 74LS374 octal latch, which could source 2.6 mA and sink 24 mA. There were 0.0022uF capacitors between each
    line and ground to reduce transients. The manual warns "It is essential that the external device not try to pull these lines to ground", as this might
    cause the 74LS374 to source more current than it could handle without damage.

    Some parallel ports can supply more current, but it is almost impossible to know which one always take on the "legal" maximum for safety.....
    Having Windows running as well can cause problems, but as I am not a Mach3 user, take that with a pinch of salt, but you might check that you have the correct SP level for the software, that might be a problem.....

  5. #45
    Hi der_fisherman, guten abend.

    I've parked this problem for now until I've finished off some house DIY jobs, and can also finish off the mechanics of the CNC machine. I'm sure you know how it is!

    But when I'm back on this again I can do the checks you suggest above, although as I mentioned if I run the board from DC instead of the AC supply everything is fine. Roy's CNC board products have a good reputation and following, so I'd hope he know about handling the parallel port properly.

    On the suspected faulty power supply front because it was 2 years since purchase I'm understandibly on my own with that one, although it did have this problem from new but had ignored it. That leaves me with:
    Making my own linear supply (with Irving's and John's help above) - had the figure of ~55 for that option, plus my labour
    Purchasing a switched mode replacement unit from Roy ~60 (but sending it back for a refund or replacement if it glitches)
    Purchasing a lower spec (but exactly the same make) unit from China at 27v instead of 32v for ~40

    As for Windows SP etc, I've tried it with a fresh install of Linux running EMC2 and it still glitched.
    Building a CNC machine to make a better one since 2010 . . .
    MK1 (1st photo), MK2, MK3, MK4

Page 5 of 5 FirstFirst ... 345

Similar Threads

  1. Stepper motors - problem
    By dudz in forum Stepper & Servo Motors
    Replies: 7
    Last Post: 13-02-2013, 06:07 PM
  2. stepper motors not being driven
    By sprint in forum Machine Control Software
    Replies: 4
    Last Post: 12-02-2013, 02:42 AM
  3. Help with Stepper Motors
    By Scott in forum Stepper & Servo Motors
    Replies: 8
    Last Post: 04-04-2010, 01:35 PM
  4. rs stepper motors
    By chaz@2b in forum Stepper & Servo Motors
    Replies: 19
    Last Post: 06-08-2009, 10:05 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts