Page 1 of 2 12 LastLast
  1. #1
    Looking for some help and guidance.

    This is my first attempt at building a cnc 3 axis controller, I built the power supply and have attained 28vdc output, I purchased a System 4 motherboard and 3 drv25 driver boards, connected to sys4 m/b and get the Blue power light on, 2 Red lights that fade out, and a Yellow that is on all the time.
    Each axis board has 4 dipswitches I have them set to 1/8 step and 2.5A.
    Next I connected the motor wires 8 in total, green & black with white stripe are joined together, as are blue & white with red stripe joined together, 4 single wires left Red, White with blue stripe test out as a circuit, and have been connected to 1A & 1B on drive, Black, Green with white stripe test out as a circuit, and have been connected to 2A & 2B on drive.
    Next to Mach3.
    Set up Mach3 as per PDF details and driver test reports excellent, pulses 24840 -25141
    Configs port as should be, x axis enabled, dir active low checked, step active low checked, X axis Motor steps 200, Velocity 2300 all saved as should be.
    Next g-code a straight line 200mm long mach3 shows X axis running but motor not turning, can anyone help me, tell me how to test this out and get it working please.
    Regards Phill

  2. Where about's in Derbyshire ? I'm up that way on Thursday.

    Sounds like the motor wiring may well be incorrect.
    Can you pin out the 4 coils and tell us that two wires go to each coil.

    In config > ports and pins > motor outputs have you got step port and direction port set to 1 ?

    In config > motor tuning set step pulse to 5 and save.
    John S -

  3. #3
    have already got port set to 1, pulse set to 5, can you explain how to pin out the 4 coils please.

  4. Get a multimeter and find which two wires make up a coil.
    You have 4 coils so you will have 4 pairs of wires.

    I'm guessing Black and white with black stripe is one ?
    Red and white with red stripe second ?
    Blue and white with blue strip third ?
    Green and white with green stripe last ?

    If so join white with black and white with red together , then feed red and black into 1A and 1B

    Join White with blue and white with green then feed Bluee and Gren into 2A and 2B
    John S -

  5. The Following User Says Thank You to John S For This Useful Post:

  6. #5
    Thanks John, have done as you said, tried again still no motor turn, in Diagnostic's show's all ref xyz in Red and X counter running up and now Red flashing on Output 1.

  7. #6
    In Diagnostic's show's all ref xyz in Red and X counter running up and now Red flashing on Output 1.
    now tried different driver card in Y same no motor output, Y pos running up, this time no Red flashing on Output, Current state of port pins 5 Green led's, Input signals current state all blank, Output signals current state all blank.

  8. What motors are these? do you have datasheet?

  9. #8
    I don't have any datasheets for them the machine was purchased with them on, on the end of the motors it says FL57STH76-2808B, 1.8. 2.8A/PH they look like the Nema double 6mm shaft motors and they look new, if this helps.
    The controller for them was a cheep looking thing called (Aliencnc) and the wiring just taped together hence the reason to build a new setup.

  10. Ok, the data sheet for those motors is here (the S is single shaft, B = double shaft)

    With those motors & driver you have the option to run them wired bipolar series at 2A or bipolar parallel at 2.5A (which is the limit of the driver, not the motor)

    To run them in bipolar series, you need to join blue to red/white, use blue/white = 1A, red = 1B, join green to black/white, use green/white = 2A, black = 2B

    To run bipolar 1A = Red+Blue, 1B = red/white + blue/white, 2A = green + black, 2B = green/white + black/white

  11. #10
    Thanks for the link, Have now tried changing wires to both ways still no motor output, now looking at System 4 pcb, have blue power led on all time, have a green power save led on all time, 2 red signal led's fade out under 60 sec, 4 yellow direction XYZA led's never seen on.
    all port pins set as per sys4 book, power is 28vdc, mach3 settings all appear to be correct, am I missing something out should anything else be enabled? can sys4 board be checked out/tested?

Page 1 of 2 12 LastLast

Similar Threads

  1. Plasma Attempt #2
    By Robin Hewitt in forum DIY Plasma Build Logs
    Replies: 21
    Last Post: 02-09-2012, 07:05 PM
  2. ok, first attempt using sketchup 8
    By deannos in forum Gantry/Router Machines & Building
    Replies: 89
    Last Post: 25-08-2012, 02:00 PM
  3. BUILD LOG: My first attempt.... 8 x 4
    By trounce in forum DIY Router Build Logs
    Replies: 0
    Last Post: 18-10-2011, 10:31 AM
  4. BUILD LOG: My First Attempt Of A CNC
    By AdCNC in forum DIY Router Build Logs
    Replies: 61
    Last Post: 21-10-2010, 02:55 PM
  5. FeatureCam - first attempt
    By HiltonSteve in forum CAD & CAM Software
    Replies: 0
    Last Post: 01-09-2009, 06:46 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts