Page 12 of 14 FirstFirst ... 21011121314 LastLast
  1. I know how to set Mach3 up, as I just done that on my lathe this week!

    First you need to set the right step/dir pins in Motor Outputs, then on the Output Signals set the pins for controlling the relays according to the output #'s set on Spindle Control. You'll want to set the same output # for CW/CCW in the Relay Control (top left), and use that to control the additional relay that turns the supply on/off (the direction is controlled by the dir pin)
    Then you'll need to set the values for the Spindle in Motor Tuning to give the desired step rate for providing the required step rate to the V3 board, Which having had a quick look at the manual, is 2000 steps per second for 10V output, so the figures you put in Steps Per, and Velocity per min, need to multiply to give 120000 (2000x60sec). Also remember you need to save the settings before closing the motor tuning box, or any chances won't get saved, and to make sure the pulse width is set to something other than 0.
    And after that, set the pulley speed in the Spindle Pulley config.

    Then in the manual screen, clicking spindle should power up the relay, then entering a speed into the S DRO and hitting enter should see power appear on the analogue terminal. Personally, I left my motor drive disconnected until I was happy I was getting the expected power on the analogue pin, and the relay was working how it should.


    Having written all that, do I remember somebody mentioning that the Gemini doesn't need the full 10V?
    If so, adjust the step rate in Motor Tuning to get the desired voltage, if adjusting the V3 trim doesn't decrease it enough.

  2. The Following User Says Thank You to m_c For This Useful Post:


  3. #112
    Thank you so much for your info but i think im either doing something wrong here or im dunce

    So here is a break down what ive got set

    Ports and Pins

    Spindle: Enabled, Step Pin 7, Dir Pin 8, Step Port 1, Dir Port 2

    Output Signals

    Output #1, Port 1, Pin 8 (Dir)

    Spindle Setup

    Relay Control, CW output #1, CCW Output #1
    Motor Control, Use Spindle Motor Output (enabled), Use Step/Dir (enabled)

    I have tested the NO/C/NC connections buzzing out when its switched but nothing happens.

    Also VDC testing on the 0-10v output on the Spindlev3 isnt changing at all, stays at 0.02vdc

    Stu

  4. #113
    i2i's Avatar
    Lives in Cardiff, United Kingdom. Last Activity: 23-12-2016 Has been a member for 7-8 years. Has a total post count of 693. Received thanks 30 times, giving thanks to others 0 times.
    you need to change the dir port to 1

  5. #114
    Lol it is at 1, don't know why I put 2 lol

  6. #115
    i2i's Avatar
    Lives in Cardiff, United Kingdom. Last Activity: 23-12-2016 Has been a member for 7-8 years. Has a total post count of 693. Received thanks 30 times, giving thanks to others 0 times.
    do you have the outputs enabled

  7. #116
    i2i's Avatar
    Lives in Cardiff, United Kingdom. Last Activity: 23-12-2016 Has been a member for 7-8 years. Has a total post count of 693. Received thanks 30 times, giving thanks to others 0 times.
    are pins 7 and 8 duplicated in port and pins / motor outputs

    They cannot be duplicated.

  8. #117
    i2i's Avatar
    Lives in Cardiff, United Kingdom. Last Activity: 23-12-2016 Has been a member for 7-8 years. Has a total post count of 693. Received thanks 30 times, giving thanks to others 0 times.
    you also need to set an output for the speed signal, eg, output 2 pin 7 port 1, and enable it.

  9. #118
    i2i's Avatar
    Lives in Cardiff, United Kingdom. Last Activity: 23-12-2016 Has been a member for 7-8 years. Has a total post count of 693. Received thanks 30 times, giving thanks to others 0 times.
    another thing worth checking, go into the setup of the computer bios and set the parallel port to epp

  10. #119






    I set the bios option like you said, ive not enabled another output on pin 7 yet as i want to see the relay switching first :D

    Thanks for all your help

  11. #120
    Cooliced

    Pin 7 & 8 is fine for generating the voltage to the speed control

    But you need another pin for Forward and another for Reverse (If you need reverse)

    Otherwise you seem OK

    Phil

Page 12 of 14 FirstFirst ... 21011121314 LastLast

Similar Threads

  1. Can't reply to a thread
    By Washout in forum General Discussion
    Replies: 9
    Last Post: 24-10-2012, 06:56 PM
  2. Thread Engagement
    By GTJim in forum General Discussion
    Replies: 1
    Last Post: 12-09-2012, 11:13 AM
  3. Thread Tapping?
    By Tenson in forum Tool & Tooling Technology
    Replies: 6
    Last Post: 04-05-2012, 04:51 PM
  4. Thread diameter
    By Daniel in forum General Discussion
    Replies: 7
    Last Post: 23-02-2012, 06:18 PM
  5. Pipe thread in 22 tpi???
    By Robin Hewitt in forum Machine Discussion
    Replies: 3
    Last Post: 21-09-2010, 11:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •