1. #1

    I have Mach3 taking to my router but how do I get it to perform a test cut? I have a G-Code file loaded on screen, which appears to be off set from the 300x400 table set in Mach3. Also when I start the file the machine seems to head off and do its own thing.

    I may have missed something in the set up?

    Any help or guidance would be apprecaited.

    Also I noticed that the machine coordinates are away from the table. Im not using home switches as I await fitting these and cannot see how to re-reference the machine.

    I have all this great software, machine, bit and material and cannot output anything yet! Arrgghh.!!!

  2. #2
    Hi sfallan,

    What happens if you jog the machine using the keyboard, does it move in the correct sense?

    What happens if you press 'zero x' 'zero y' and 'zero z' on the first Mach screen, then go to the MDI tab (tab2) and type in 'G0 X50 Y50' at the finger prompt box. Should move from 0,0 (where it is now) to 50,50 on your table. Is this working?

    OK, next, you might be interpreting arcs incorrectly (assuming your gcode contains arcs), this can give strange results. So try the following simple shape,
    1 disable the Z axis stepper motor (in the Mach setup screen > ports and pins > motor outputs)
    2 jog the machine to the bottom left hand corner, and zero X,Y and Z on the first Mach screen
    3 run the attached Gcode, which will 'cut out' a rectangle 150 x 100, starting at 50,50 as the bottom LH corner
    4 keep your hand over the estop button until complete!
    5 enable Z axis

    Any luck?
    Attached Files Attached Files
    Building a CNC machine to make a better one since 2010 . . .
    MK1 (1st photo), MK2, MK3, MK4

  3. #3

    Managed to do a dry run with the GCode file I had, it would seem I hadnt confirmed the x,y,z axis therefore they were moving off the grid so to speak. The reconfigured settings came out as 133.3333 for all three axis which in reality seems really slow. Is there anyway of improving on this?

    The resulting was to see the spindle move from where I had zero set all three axis over to the start then move down 5mm cut then move down 1.5 as set in the GCode and cut again. As above the only draw back seem the speed of movement now.

    Thoughts anyone?

  4. #4
    Is the machine calibrated, so requesting 10mm moves 10mm etc? Sort this first. This is set with the 'steps per' box in the motor tuning and can be worked out from the stepper motor, thread pitch etc., or at least estimated by trial and error to get you going. Use the MDI box to ask for 100mm movement, and then measure how far it actually goes. Change this 'steps per' value until it is accurate.

    Once set don't use this to change the speed. Instead, alter the values in the 'velocity' box in the motor tuning section. This sets the max feedrate when jogging. I assume your 133.3333 are the jog speeds?

    But when actually cutting the gcode itself will contain the feedrate to use. Press the 'gcode edit' button in Mach3 and look for F500 or similar. Do a 'find and replace' to change this value to something quicker, but increment slowly. This rate is set when you (or whoever gave it to you) created the gcode.

    It would be worth reading up on the basic Gcode commands (G0, G1 etc), so you can understand a bit more about it.

    Your last sentence sounds like a multiple pass, which is quite normal for cutting thicker materials etc.

    Does this help?

    Building a CNC machine to make a better one since 2010 . . .
    MK1 (1st photo), MK2, MK3, MK4

  5. #5

    I managed to calibrate the machine and will increase the velocity as suggested. As you say when the gcode was created the feed rate was set. I'm using Vetric 2d to creat the code and the settings direct from there.

    Are there or is there a set of standards that should be adopted?

    Yes miltiple pass. The bit is 3mm and the pass is 1.5mm according to Vetric 2d.

    Not actually cutting yet as ive still to set up my table as suggested in earlier posts when getting the machine to work.

Similar Threads

  1. Well it passed the full Test cut.
    By m.marino in forum General Discussion
    Replies: 10
    Last Post: 15-09-2012, 08:20 PM
  2. gcode stops mid way can anyone test..
    By crossleymarko in forum CAD & CAM Software
    Replies: 16
    Last Post: 21-04-2012, 11:45 PM
  3. Test of new vinyl cutter
    By evildrome in forum Tool & Tooling Technology
    Replies: 0
    Last Post: 16-01-2011, 11:25 PM
  4. Test cutting materials
    By Kai in forum General Discussion
    Replies: 6
    Last Post: 05-12-2010, 09:27 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts