Page 1 of 3 123 LastLast
  1. #1
    Hi All...

    Have been testing my new cnc router under full speed in all 3 axis, individually and all together.. Runs sweet and goes round and round to stop bang on where it starts.. My dial clock cant measure any slop at all..

    2 x nema 34 on x axis (5.5Nm) (800 microsteps)
    Nema 23 3Nm y axis (800 microsteps)
    Nema 23 3nm z axis (800 microsteps)
    System 3 board using onboard drivers for the z and y
    PM752 drivers for the x axis, wired step and dir together into the 4th axis off the board.
    Separate power supply for the board (24v from Roy, Diycnc), and one for the nema 34's (from Jonathan (nice one)).

    So ran a small v carving code on it and ow..! Lotta noise from my motors which are juddering and losing steps.. The slower I run it, the worse it gets.. Spin it up to full speed and it runs very smooth with no loss of steps, dial the jog (Mach3) down to 5% and the z and y judder and lose steps big time.. Seems to halt for a moment every 1/4 turn.. The nema 34's seem to rum fine at any speed..

    Have spent the day changing the Mach settings around to alter speed and acceleration, kernal speed, and everything I could think of but nothing makes any difference.. I have read quite a few posts relating to similar problems but cant find anything that I either haven't tried, or applies to this..

    Anyone had anything similar happen? Just read a post about psu's so am going to see if I can dial down the power a little for the system 3 board (which powers the z and y).. Will welcome any and all suggestions as have little hair left to pull out now..


  2. 800 microsteps ?
    Is this a typo?

    OK forget that, now see you mean 800 steps per rev or 4 microsteps.

    In motor tuning what have you got pulse width set to ? Regardless try it at 5.
    John S -

  3. #3
    Hi John S..

    Just checked and only the X axis had the pulse width set to 0, and it was running fine, have set it to 5 now.. z and y were already set at 5, vaguely remember doing this way back when..

    Just fed in the code f25 z100 and it moved the z axis fine, for about 30 secs, then started juddering, faster and faster until it was juddering all the time.. Did the same with the y axis, and this took about 45 secs to start juddering.. Both the z and y are running off the system 3 board drivers and the 24v power supply, which is being fed through the board.. 2.30am now so starting to see double.. Will start some more hair pulling in the morning...


  4. #4

    Been reading loads of posts from around the world with folks having the same or similar problems.. Many of them were down to the PC they were using.. Mine is a P4 3GHz with 1Gb ram.. Used to be a server in my brothers company (loads of fans on it).. Am just gonna pop down and see if I cant strip some more crap out of windows and the bios.. Got a nagging feeling that it has an onboard wireless network card, an absolute no no from what I have read...
    Gonna use my biggest hammer on it...


  5. #5
    Are you using the lowest Kernel frecquency, 25kHz? If that isn't sufficient you may need to use 400 step/rev.

    I would check the bios ... disable everything you can that's not useful.

    Changing the pulse with from 0 to 5us wont make a difference as it defaults to 5us if you put 0 (I think, might be wrong).

    Have you ran the driver test program to check the parallel port? If not I'd start with that...
    Last edited by Jonathan; 31-07-2011 at 08:54 AM.

  6. #6
    Morning Jonathan..!

    Tried all kernal speeds from 25KHz to 60Khz, makes no difference...

    Seems my PC is a dual processor, 2 x 3GHz P4... Have it set for standard PC and have done all the optimizations recommended for Mach3.. Really is a bare bones machine and runs very fast, boots in 11 secs... Even running complex code the processors never get to more than 4% usage... Everything disabled that is of no use, using a pci graphics card (not onboard one which seems to be an issue on some machines)..
    Re-checked all my cables and drivers/board (which are very cool due to a pair of fans mounted above them)..
    Just swapped round a motor (had 2 spare 3Nm) and made no difference..

    Am at a loss now.. No hair left to pull out and no idea what to try next...


  7. #7
    I'd leave it on the lowest kernel frequency as that is inherently the most stable.

    Maybe the fans are causing interference in the step/dir inputs ... seems unlikely but you never know. Shielded cable might be the answer, but I reckon there must be more to it.

    Try EMC? If that works you know the computer is ok.

    Have you definitely wired the optocouplers the right way round on the driver?

    (Would type more but I'm going out for the day, now ... hence why I'm up early! Hmm, 800th post.)

  8. #8
    Running it at 25KHz, driver test ok.. Really strange the way the motors behave at low feed rates, almost a grinding noise from the motors and they stutter like crazy.. As soon as I put the motors in rapid (G0) they seem to 'kick' out of the stuttering and rough noise and run really smooth with no loss of steps..

    Have checked and re-checked everything I can think of, mechanically the z and y are slick and move very freely. Can pop a 6mm spanner on the rear shaft of the motors and turn them by hand with no effort so the problem does not seem to be there.. Even when under power at low feed rates, when they are stuttering, I have tried gripping the ball screws to see if I can slow them down, but I cant so does not seem to be a loss of torque (or I am as weak as a soggy digestive) and the motors are running cool.. Have a spare axis on the board (with an on board driver) and have tried swapping the the motors around but get the same result..

    Am at a complete loss as to what is happening here..

    Any ideas anyone? Or maybe you can lend me a bigger hammer...?


  9. Quote Originally Posted by Jonathan View Post

    Changing the pulse with from 0 to 5us wont make a difference as it defaults to 5us if you put 0 (I think, might be wrong).

    No it should sat at what ever you put in. A low setting can cause problems for some drivers as they don't have time to read the pulse.

    Where it affects machines the most is on spindle speed.

    What concerns me is the statement "Just checked and only the X axis had the pulse width set to 0, and it was running fine, have set it to 5 now.. z and y were already set at 5"
    You cannot have different values for different axis, what is set for one is set across the board - unless the latest version - which we don't use is different, perhaps I need to check.
    John S -

  10. #10
    Hi John..

    I am not controlling the spindle from the board.. The pulse width thingy may be to do with the wiring setup I have.. Z and y are using the onboard drivers (system3 board), and the x is a pair of PM752 drivers, just wiring the step and pulse into the 4th axis (no onboard driver).. Did not have this setup before, ran all three axis from the board.. This new setup was run from the previous Mach3 settings and had to alter various things to suit.. But the X axis has run flawlessly since I switched it on.. All these problems are to do with the z and y..


Page 1 of 3 123 LastLast

Similar Threads

  1. Machine Slow on Curves
    By swisscheese in forum Computer Software
    Replies: 31
    Last Post: 11-04-2014, 11:49 PM
  2. x-axis on Orac losing direction
    By asto in forum Motor Drivers & Controllers
    Replies: 3
    Last Post: 29-03-2013, 12:22 AM
  3. Forum Slow
    By pcstru in forum General Discussion
    Replies: 3
    Last Post: 27-01-2011, 02:54 PM
  4. Heelp! Dual axis steppers.. Losing steps.. Pulling hair out..!
    By fasteddy in forum Motor Drivers & Controllers
    Replies: 9
    Last Post: 14-05-2010, 01:32 PM
  5. stepper speed very slow
    By jonm in forum Stepper & Servo Motors
    Replies: 17
    Last Post: 01-11-2009, 11:39 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts