1. #1
    hi all. have a problem with homing in mach3. y and z are fine. on my x axis i hve two ballscrews with two motors and two drivers, x and b. they are slaved together in mach. when you jog them they re fine and move as one. when homing, z goes first, they y, then x but not b so it tries to twist the axis and then stalls. how do i get around this.

  2. #2
    Can you disconnect the motors from the ballscrews to see if the motors run free without moving the machine? You could then swap the connections to the motors to narrow the fault down to prove the motor and then the amplifier.

  3. #3
    sorted it now. had to play around with the homing directions in homing and limits and it all works fine now.

Similar Threads

  1. Mach3 PC problems, help please....
    By Davek0974 in forum Plasma Table Machines
    Replies: 13
    Last Post: 30-01-2014, 06:05 PM
  2. G540, homing switches and mach3
    By marbles in forum Artsoft Mach
    Replies: 3
    Last Post: 11-03-2013, 04:58 PM
  3. Homing switches & 'methods of working' (Mach3)
    By HankMcSpank in forum Artsoft Mach
    Replies: 15
    Last Post: 18-10-2012, 11:54 PM
  4. Homing Switches
    By m_c in forum General Electronics
    Replies: 3
    Last Post: 04-11-2010, 10:21 PM
  5. Limits or homing switchs???
    By Ross77 in forum Computer Software
    Replies: 11
    Last Post: 28-03-2010, 02:17 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts