Page 2 of 3 FirstFirst 123 LastLast
  1. #11
    i'm using a routout cnc bob and 5v comes directly from the sreial cable. all the other three drivers are fine just not this one, although it was working for the last 2 1/2 months

  2. #12
    where are the opto isolators on the 2m542 drivers and what do they look like o i can see if its burnt or anything. cheers

  3. ok, my suggestion is to get a 5V power supply, connect this to the positive side of the pul+, DIR+ and ENA+.
    Then the step goes to the PUL-, direction goes to DIR- and Enable goes to ENA-.
    This bob is very simble and has no opto isolation of buffering and you are reliying of the quality of the 5V from the parallel port.
    In most cases it will be under spec and 3V is borderling working or not, and any noise will give you problems.
    you could also use the 5V from the USB, but i would not trust that, so getting a 5V power supply is much better.

  4. #14
    i actually meant the optoisolator in the driver itself. if it needs 5v then why do all the others work fine, by the way it might be my multi meter, might try on different setting to se if that changes anything

  5. #15
    tried on all settings, definately 3v

  6. #16
    I've now tested your driver. I connected it up in place of my Y-axis driver. I use *752 series drivers, so they're on 70 volts hence I used a lab PSU set to 48V for your driver. It works fine... I've not done anything to it, just connected it and changed the switches to 1600 step/rev as that's what I use. Then tested it on 800 and 400, not really expecting that to make a difference, and it didn't.

    Interestingly the motor runs more quietly and possibly more smoothly (difficult to tell of course) with your driver. I'll have to test my own driver on 48V to see if it's just the lower voltage causing that. If not then that's useful information as it implies they use different control algorithms. As expected though the feedrate I can get with 48V is less (24000mm/min @ 2000mm/s/s acceleration) but still plenty!

    So what would you like me to do now? Just send it back and hope it starts working on yours too? I'll have a look inside anyway just to be sure.

  7. #17
    yeah just post it back and i'll play with it again. were you running it from a 5v power supply o straight from the parralel port. when you get postage cost pm me and i'll paypal you the cost. thanks alot

  8. Jonathan,
    the motor will run quieter at a lower voltage, this is typical with stepper motors.
    also you are running the 752 at 70V, this is the absolute maximum for this driver.
    I would advise to run it at a lower voltage.
    60V is a good voltage with the SY60.
    As i mentioned before the problem is not with the driver but the 3V is too low.
    I come across this a lot when people are using the parallel port.
    It is a very cheap and simple 5 minute fix.

  9. #19
    I am running it directly from the parallel port.

    Quote Originally Posted by Gary View Post
    the motor will run quieter at a lower voltage, this is typical with stepper motors.
    I suspected that, was just interested in checking the theory!

    Quote Originally Posted by Gary View Post
    also you are running the 752 at 70V, this is the absolute maximum for this driver.I would advise to run it at a lower voltage.
    I would advise myself that too, however I've checked it by connecting my oscilloscope to the MOSFETs (IRF540) whilst running and measuring the peak voltages at the points where it they switch under various conditions. There are no peaks above the rating of the MOSFETs, which is 100V, so I'm happy that it's safe.
    That's no reason for anyone else to do the same, since each system will vary.

    It looks like it must be the low voltage of your parallel port, but that still doesn't explain why the driver wouldn't work from the same pins on the parallel port that the other drivers worked with.

  10. #20
    going over everything i think it has some thing ti do with the act that its slved with another motor/driver. the drivers on single axis are ine but this only happened on the slaved axis so maybe it was dropping the voltage too low

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. tree problems!
    By kingcreaky in forum Woodwork Discussion
    Replies: 8
    Last Post: 02-06-2014, 11:35 AM
  2. Mach3 PC problems, help please....
    By Davek0974 in forum Plasma Table Machines
    Replies: 13
    Last Post: 30-01-2014, 06:05 PM
  3. F-Engrave problems
    By cropwell in forum CAD & CAM Software
    Replies: 29
    Last Post: 29-06-2013, 02:48 PM
  4. problems since update
    By motoxy in forum General Discussion
    Replies: 6
    Last Post: 02-11-2012, 05:14 PM
  5. NEW MEMBER: MDF Problems
    By MrWiz73 in forum New Member Introductions
    Replies: 4
    Last Post: 30-12-2011, 11:39 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts