Page 3 of 8 FirstFirst 12345 ... LastLast
  1. #21
    well its deffo the mach3 drivers. reinstalled them and hey pesto no dro movement, so i disabled my lpt1 port and tried that still no dro but had a constant 5v voltage on pin 2... whats going on at all.

  2. #22
    no none.. estop is enabled, port 0 pin 0

  3. #23
    Quote Originally Posted by ecat View Post
    Silly question:
    When LinuxCNC starts up it will disallow all control of the machine until the user clicks the magic EStop button - effectively saying they are in control of the machine and the environment. If I remember Mach works in much the same way, a big red stop button perhaps? Have you clicked it?
    not silly at all any input is welcome..

    but yes the reset button is clicked on start up.

  4. #24
    When the mach driver installed no dro. Also I have a constant 3.26v from boot up. When I close mach3 software down I get 0v. When mach3 driver is disabled dro changes and v from boot remains at 3.26. Even when I close mach3.

    Think I'm gunna try another machine.

    Sent from my HTC Desire HD using Tapatalk 2

  5. #25
    ok so rebuilt this hp desktop, installed vista.. ( 3 of my xp disks) wont install.. scratched to buggery... so ive tried vista.

    ok all works.. voltage up/down etc..... wehey!lol... BUT!!!!!

    my voltage is only 3.3v.... aaarrrggghhh lol.

    now on the disk i got with the software, there is a read me file that says to install memoryoveride reg file.. or itll crash on startup.. it hasnt though...

    how do i get the 5v needed..

    cheers all

  6. #26
    ok got it breakout board supplies 5v... slowly getting there.. am i

    so ive tested pin 2,3,4,5 al work x,y,z,a.. ive tested cable... all connected .. my next miff is the break out board..?

    on the x-1 i have xn,xd,xs,xe. same for y-1 and z-1 i tested all terminals to check voltage.,on the x terminals i get voltage change on the xs terminal.. on the y i get change on the yd terminal and on the z no change just 5.11v.. is it a faulty board...

    Last edited by crossleymarko; 12-04-2012 at 11:01 PM.

  7. #27
    First are you still on the laptop or desktop.?
    If laptop then forget it they are just too unreliable due to heavy memory management and Mach's driver really doesn't work well with most Lappy's. To use a Laptop reliably you need an external motion controler like smooth stepper, this is how laptop runs machine I use.

    If it's a desktop is it a PCI PP card or built into mother board.? If it's a modern-ish PC then chances are it's 3.3V PP if so thats it there's nothing you can do about it other than use a PCI PP card. Even then you have to be carefull because some use the USB bus to simulate a PP and again don't work with Mach. If you go to the Mach forum you will find more info regards this.

    Check the bios to see what the Printerport is set to EPP/ECP etc
    Are you actually hooking upto drives and motors like in a full working machine or just testing on the bench.?
    Does it have an Estop wired up or the BOB have a charge pump.?
    Does the bob need an external supply to activate it's opto's.? some do.!
    Also what are you using for a PP cable.? are you 110% sure it's a straight thru cable standard printer cables are very often not straight thru, I've even had some that tested ok with multimeter but still had some trickery built into the plug that switched signals.!!! (Drove me F'~@ing nuts)

    Have you done the Mach driver test.?
    Also can you post the Mach XML file your using, it will be in the Mach folder under the same name as the profile you use to load Mach.
    This will make it much easier to see if it's just a PP setting issue.? I'm curious because some where you mentioned port 0 pin 0 for estop this don't sound correct and it could be that your port address is wrong.?

  8. #28
    i feel ppl are thinking "man this guy is demanding" hahaha.. sorry ppl just tryin to learn a new trend...

    thanks all who have inputted.

  9. #29
    Quote Originally Posted by crossleymarko View Post
    i feel ppl are thinking "man this guy is demanding" hahaha.. sorry ppl just tryin to learn a new trend...

    thanks all who have inputted.
    hi thanks its a desktop pc now.. with onboard pp, i wasnt gonna use the lappy anyway.. but me being me had to play, and yes im just bench testing, (not even got motors yet) so testing what i can.. did a continuity test on the lead... mmmm trickery eh! well it came with the bob and 542 drivers. so who knows.. i think tomorrow ill test voltage through the lead would that help... how did you sort it...

    yes the bob uses usb power...

    so the 3.3v is converted by the bob.. to 5v is this right.

    which terminal should i be getting my voltage change on the bob.. ie xs or i said xaxis is x-s and y is yd

    think thats all

  10. #30
    John S's Avatar
    Lives in Nottingham, England, United Kingdom. Last Activity: 4 Hours Ago Has been a member for 9-10 years. Has a total post count of 1,933. Received thanks 124 times, giving thanks to others 44 times. Referred 1 members to the community.
    Quote Originally Posted by crossleymarko View Post
    no none.. estop is enabled, port 0 pin 0
    Port 0, pin 0 ?????????

    should that be port 1, pin whatever ?
    John S -

Page 3 of 8 FirstFirst 12345 ... LastLast

Similar Threads

  1. Replies: 12
    Last Post: 24-05-2013, 11:41 PM
  2. Milliamps and voltage help please
    By Fivetide in forum Resources & Help
    Replies: 13
    Last Post: 30-09-2012, 12:36 PM
  3. voltage on motor wires
    By phill05 in forum General Electronics
    Replies: 9
    Last Post: 11-02-2012, 02:43 PM
  4. Alternator low voltage
    By M250cnc in forum General Electronics
    Replies: 12
    Last Post: 24-02-2011, 10:23 AM
  5. Bipolar motor voltage
    By wildbill in forum General Electronics
    Replies: 10
    Last Post: 24-02-2010, 11:23 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts