1. #1
    Hi I hope you can help me this is my first post and its a plea for help :) I have a Heidenhain DRO quite an old model 731b the x axis has developed a fault its not the scales as I can swap them around and they both work fine on the y axis. The fault is the display will jump around and read all over the place it does move up and down but just flickers up and down. I'm thinking its possibly a voltage issue. Has anyone out there seen fixed this before ?

  2. #2
    The VRZ 731 supplies 5v to the scales on pin 3 & 4 of the round 9pin connector. Check that first.
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	11uApp Pinout.jpg 
Views:	2312 
Size:	202.8 KB 
ID:	6205  

  3. The Following User Says Thank You to Craig For This Useful Post:

  4. #3
    If one of the displays is ok I would think your voltage supply would be fine, probably the same supply for both displays and encoders buit you should be able to check this with a decent multimeter. Voltage will be around 5.1Volts.
    It could be one of the capacitors on the display board has died or one of the resistors has gone out of tolerance. I get this type of fault on some of our welding equipment displays regularly. Some boards also have an adjustment potentiometer as well for setting up the display and these die as well. It can also be the large driver chip on the board for the led blocks. You could easily swap these around to see if thats the problem or not. You can either attempt swapping out some components for some new ones, the parts wont be expensive, or you would need to get it to someone for repair and calibration.

  5. The Following User Says Thank You to Web Goblin For This Useful Post:

  6. #4
    Thanks for the pointers guys, I will have a good look inside at the weekend and put my rusty electrickery skills to work, once again thanks for the advice I will post my findings.

  7. Quote Originally Posted by Web Goblin View Post
    It could be one of the capacitors on the display board has died
    I used to fix monitors with built in PSU's just by changing the electrolytics. They dry out after a few years, I even fixed a BMW once by changing one cap rather than the whole circuit board. It sounds like you have noise on the quadrature inputs, so WG could be spot on here. They save pennies by using aluminium rather than tantalum and limit the life time. Take photos before you rip them out if they haven't marked the polarity on the PCB.

  8. The Following User Says Thank You to Robin Hewitt For This Useful Post:

  9. #6
    Result :) took the thing to pices and didnt spot anything obvious so before going any further I decided to clean the internal plug contacts. I put it all together and it works great must of been a bad contact on the internal X axis plug. This electrickery thing is easy :)

Similar Threads

  1. Plasma cutting fault diagnoses....
    By Davek0974 in forum Plasma Table Machines
    Replies: 15
    Last Post: 01-04-2014, 06:04 PM
  2. heidenhain vrz731b fault
    By p.cage in forum General Electronics
    Replies: 0
    Last Post: 31-01-2014, 02:56 PM
  3. Servo fault handling
    By m_c in forum Motor Drivers & Controllers
    Replies: 0
    Last Post: 23-09-2013, 03:39 PM
  4. ATX cycling fault?
    By mocha in forum Computer Hardware
    Replies: 7
    Last Post: 07-12-2011, 01:08 PM
  5. Denford Triac Spindle Fault
    By Sam_Smith in forum Denford Mills
    Replies: 5
    Last Post: 04-05-2011, 10:07 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts