Page 1 of 2 12 LastLast
  1. #1
    Hello and Greetings from the United States.

    I'm not really into the CNC world; however, I am into the IT industry and I am having problems with the software associated with the Busellato Optima.

    About my problem:

    We recently decided to build backup computers for the control station of this CNC machine. (The system that needed a backup is an ancient Windows 95 dinosaur) So, we built two new machines with Windows 98 SE. We installed the following programs: Driver PTP and Winner90. The installation of the software does not run into any problems. However, whenever we try to load the Driver PTP program we receive the following error: "Unexpected QuickWin Error". Most of the other programs associated with Winner90 run into the same error or a slight derivative of that error.

    We've tried to contact Busellato about this problem but haven't had much luck with their IT department in correcting this issue. Anyway, if anyone could assist with this issue we would be greatly appreciative.

    Sincerely,

    Sooner Millwork.

  2. #2
    Have you tried running the programs in win95 compatibility mode? right click the EXE and change from there
    If the nagging gets really bad......Get a bigger shed:naughty:

  3. #3
    Found this on a forum which may help -

    We've seen this reported on a dual-processor system. The solution seems to be to
    add CALL SLEEPQQ(500) at the beginning of the program - this allows enough time
    for INITIALIZEFONTS to complete.

    ---------------------------------------------

    If that doesn't work download a copy of process monitor and run that prior to running the program and then have a look at the results as it may shine some light on exactly whats going wrong.

    The other option would be to build the machines using windows 7 and then run a virtual copy of windows 95.

  4. #4
    Hello and thank you for the replies.

    The problem stemmed from a new installation. These were basic machines running basic hardware (I had a nightmare trying to find hardware this old to make it compatible with this ancient stuff). Well, after a late night of browsing through notes and tinkering (absolutely no sleep), we found out what the problem was.
    We found some old instructions that were in broken English. The Italian guy that gave us the instructions should have just sent it in Italian and had us translate haha, but anyway, if anyone experiences a QuickWin error with drverPTP on a new installation of the Winner90 software they need to load the PTP1000 program first and configure the COM ports. This executable was somewhat difficult to find because it wasn't installed where one would normally think. It was installed where the autoexec.bat executable is located in the root directory of the hard disk.

    I'll be installing more backup machines this week and provide a list of much better instructions. Anyway, you have to go into this DOS based program and change the COM port from its default setting. Afterward, you have to run some machine diagnostics and system configuration settings then change it back to its default COM port. (seems a bit absurd for new installation but this is how you get this old stuff to work) After doing this, we got the machine to run our backup programs like nothing changed. So, the machine works as it should now. If you know of anyone having this problem feel free to redirect them to me and I'll gladly assist.

    Sooner Millwork

  5. The Following User Says Thank You to wes5283 For This Useful Post:


  6. #5
    Can you post or send me full set of steps for instalation
    many thanks

    john

  7. #6
    Yes I will, I apologize things have been very hectic for me. Right now I'm away from the shop but I will be in that area on Wednesday. I believe a Finnish fellow is also looking for the instructions, so I'll post full details about it Wednesday morning which will be Wednesday evening/night your time. Also, if you have any software problems such as installation failures let me know about those, we can probably hammer those out as well.

    Weston

  8. #7
    Quote Originally Posted by JohnH View Post
    Can you post or send me full set of steps for instalation
    many thanks

    john

    Ok after you install the software you'll find the program PTP1000 in the C:\ drive. or "C:\PTP1000 (should be an executable)

    System Auxiliary
    F5 (configuration)
    Enter
    Enter
    F1 System Configuration
    system options
    Which PC serial line
    [ change it over to 2]
    [you can use space bar to change]
    [save]
    [enter]
    [esc]

    F10
    F3 (compilition)
    use cntrl and + (keypad)
    Enter
    List on "Enter"
    Enter
    Esc

    Now retransmitt (This is done is the PTP driver)
    After this the error will re-occur again.

    Repeat this process (but change serial line to 1 this time)

    this should solve the issue

    thank you

  9. #8
    Quote Originally Posted by wes5283 View Post
    Ok after you install the software you'll find the program PTP1000 in the C:\ drive. or "C:\PTP1000 (should be an executable)

    System Auxiliary
    F5 (configuration)
    Enter
    Enter
    F1 System Configuration
    system options
    Which PC serial line
    [ change it over to 2]
    [you can use space bar to change]
    [save]
    [enter]

    F10
    F3 (compilition)
    use cntrl and + (keypad)
    Enter
    List on "Enter"
    Enter
    Esc

    Now retransmitt (This is done is the PTP driver)
    After this the error will re-occur again.

    Repeat this process (but change serial line to 1 this time)

    this should solve the issue

    thank you

    Go Raidh Mile Maith AGUT (irish)
    100000 thanks to you

    Wes

    I will try this out this week

    Regards,

    John
    Last edited by Jonathan; 01-09-2012 at 09:49 PM. Reason: No need to type in capital letters.

  10. #9
    Quote Originally Posted by wes5283 View Post
    ok after you install the software you'll find the program ptp1000 in the c:\ drive. Or "c:\ptp1000 (should be an executable)

    system auxiliary
    f5 (configuration)
    enter
    enter
    f1 system configuration
    system options
    which pc serial line
    [ change it over to 2]
    [you can use space bar to change]
    [save]
    [enter]
    [esc]

    f10
    f3 (compilition)
    use cntrl and + (keypad)
    enter
    list on "enter"
    enter
    esc

    now retransmitt (this is done is the ptp driver)
    after this the error will re-occur again.

    Repeat this process (but change serial line to 1 this time)

    this should solve the issue

    thank you

    wes thanks so much for this information it has worked for me only installed yeterday

    i have one problem

    i have two optima machines and because they are of different age the versions of ptp1000 are diferent one is 4.4g and other is 4.4l

    with my new installation when the reer (eye) beam is broken the axis stop but the motor that is running dont stop.

    Would it be possible for you to send me a copy of your ptp1000 installation so i can see if it would correct my problem


    many thanks

    john

  11. #10
    Hello

    wes5283 i have the same maschine, and would please you if you can tell me, what all you needed to install windows 98 and get the maschine working ( does it work throught original rs232 port od did you haw to do any modifications?)

    and also, the owner who i have bought busellato maschine works on cnc90, does you optima also work on cnc90, mine also has ptp1000 controller (the install discets were lost), so i would please you, if you could wright small tutorial on how you installd the computer (with win98 ) and what else do i need (and if possible providing links for software)

    Sorry for the broken english.

    Regards Andi (slovenia)

Page 1 of 2 12 LastLast

Similar Threads

  1. tree problems!
    By kingcreaky in forum Woodwork Discussion
    Replies: 8
    Last Post: 02-06-2014, 12:35 PM
  2. Mach3 PC problems, help please....
    By Davek0974 in forum Plasma Table Machines
    Replies: 13
    Last Post: 30-01-2014, 07:05 PM
  3. Replies: 2
    Last Post: 11-12-2012, 12:58 PM
  4. problems since update
    By motoxy in forum General Discussion
    Replies: 6
    Last Post: 02-11-2012, 06:14 PM
  5. NEW MEMBER: MDF Problems
    By MrWiz73 in forum New Member Introductions
    Replies: 4
    Last Post: 31-12-2011, 12:39 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •