Thread: New Mobo

Page 1 of 5 123 ... LastLast
  1. #1
    Hi,

    I have just replaced the motherboard memory and processor on my milling computer. The old one was a Duron 1300 with 256Mb memory. It ran OK, but had the habit of freezing at the worst moment (half way through a milling run). I run Mach3.

    The new Mobo has a faster (non clockwork) processor and 512Mb memory. Not state of the art, but good enough to do the job, and hopefuly more reliable. I am using the same parallel port card, a NetMos 9815.

    Ihave re-installed Windows XP (repair) put in all the drivers and SP2 & SP3. Reinstalled Mach3 and checked all the ports and pins settings and I am using my normal xml file that was OK before.

    Now the problem.......

    Everything looks fine, all the drivers are there, but the X,Y and Z axes (axises ?) run very slowly and jerkily (judder) when I try to jog them. I have tried all different settings for kernel speed and pulse width, but nowt does owt better.

    I need help as to what might be wrong. I am now messing about with motor tuning and I can get slower and smoother, but nowhere near as good as with the original computer.

    Ideas and Help VERY welcome.

    Cheers,

    Rob

  2. #2
    SORTED ! - I removed and reinstalled the Mach3 pulsing engine drivers and now it is as smooth as the proverbial....

    Cheers

    Rob

  3. #3
    PS - almost a RTFM error

  4. #4
    Reading the manual takes all the fun out of it.

  5. #5
    DidI speak too soon ? The problem is back again. One thing that the brief episode of normal working showed me is that the electronics are all good.

    Now I revert to the status of Seeking Advice.

    Rob

  6. #6
    Seeing as you have just installed the OS has it done any updates after you installed the drivers? Reinstall them again and see what happens.

  7. #7
    bobc's Avatar
    Lives in Eastbourne, United Kingdom. Last Activity: 23-02-2015 Has been a member for 4-5 years. Has a total post count of 19.
    If you have a new mobo, you might need to set the parallel port mode in the BIOS. Not sure what it should be... maybe "EPP" or something.

    Another thing is that the mother board might need chipset drivers, to correctly handle PCI interfaces. I think otherwise it might default to safe/slow operation.

    There are many things... but that's where I would start.

  8. #8
    Quote Originally Posted by cropwell View Post
    DidI speak too soon ? The problem is back again. One thing that the brief episode of normal working showed me is that the electronics are all good.
    Don't be so sure.? . . It could easily be a lose or bad connection causing intermitant problems or wire thats breaking but not yet broke fully.? Double and triple check the wires/connections before doing anything else.! . . Esp the PP cable.

    If the PC has quick time on then take it off.
    Disable any screen savers or energy saving features. If any of the electrics, like BOB etc use USB then it needs setting so windows doesn't automaticly turn it off after a period of inactivity. This is often a cause of USB crashing machine but Mach3 getting the blame.!!
    Disable any programs that automaticly check for updates IE: Windows update. Adobe products are a pain for this and I wont have any on my computer that runs machine.

  9. #9
    Quote Originally Posted by JAZZCNC View Post
    Don't be so sure.? . . It could easily be a lose or bad connection causing intermitant problems or wire thats breaking but not yet broke fully.? Double and triple check the wires/connections before doing anything else.! . . Esp the PP cable.

    If the PC has quick time on then take it off.
    Disable any screen savers or energy saving features. If any of the electrics, like BOB etc use USB then it needs setting so windows doesn't automaticly turn it off after a period of inactivity. This is often a cause of USB crashing machine but Mach3 getting the blame.!!
    Disable any programs that automaticly check for updates IE: Windows update. Adobe products are a pain for this and I wont have any on my computer that runs machine.
    Done all that, completely reinstalled Mach3, used Driver Test.exe, got Goldilocks results, too slow, too fast, and just right. Smooths out as the motor velocity setting is lowered, but too slow to use, and still sounds poorly.

  10. #10
    check that hyper threading is not on if it has it in the bios. look for lapic in there too and switch it off, if all else fails give us the details of the board. Power saving must be switched off on everything from the bios and the OPS. You say you have 512 of ram? change the settings so that windows looks after your virtual memory. Put some more ram in as well if you can and update to SP3 if you have not?
    If the nagging gets really bad......Get a bigger shed:naughty:

Page 1 of 5 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •