Page 5 of 5 FirstFirst ... 345
  1. #41
    Quote Originally Posted by m_c View Post
    What happens when you manually click the spindle button?
    Does the spindle start instantly, or is there still a delay?
    It starts straight away

  2. #42
    Quote Originally Posted by D-man View Post
    It starts straight away
    This is strange.? The spindle button is exactly the same has M3 in the code which basicly just turns output #2 on, M5 turns it OFF.
    The Spindle General parameter for setting delay just creates a delay after the M3 command is processed before processing the next command.

    In the MDI type S6000 M3 and see if it starts instantly.? . . . then M5 to stop it.
    Then make sure the machine is safe to move 100mm in X direction and type. S6000 M3 G0 x100.
    Depending on the delay setting you should see the spindle start and a pause with Dwell LED flashing on screen with length = to the delay setting before the X axis moves.

  3. Just for test sake could you not just slap a G04 P1000 on the N160 line after the M3 command.. or am i missing the point on this one!! :-S

  4. #44
    Quote Originally Posted by AdCNC View Post
    Just for test sake could you not just slap a G04 P1000 on the N160 line after the M3 command.. or am i missing the point on this one!! :-S
    Yep could do that but the built in delay function should work that way and can't understand why it's not happening.?

    Just trying to determine if it's happening or not, the G04 P should work but that doesn't help if Mach's playing up.!!

  5. #45
    Ok complete brain fart (and a follow through!!) I set the settings to 15. Now what I have done wrong was I was looking for the delay from the moment I pressed start. I'm a tool I know!

    So jazz, what happens now is.....

    Press start - Z moves up. Once it reaches safe Z the spindle kicks in, and holds its position for 15 seconds (lol I will change that) after the delay it then proceeds to do its job. All I need to do it edit that delay and were good.

    Now.... How did you say I go about getting the spindle to shut off after job as you said you could not see the command.

  6. #46
    Ok guys the spindle now stops. I created a new tool path and it starts and stops just like it should. Reason that it was not in that code is because it was old code pulled from the computer before we set this up! (told you a brain fart lol)

  7. #47
    Quote Originally Posted by D-man View Post
    Ok guys the spindle now stops. I created a new tool path and it starts and stops just like it should. Reason that it was not in that code is because it was old code pulled from the computer before we set this up! (told you a brain fart lol)
    Great pleased your working.!! . . (Just make the cheque out to Andy & Dean CNC enterprises. . )

    The command was M5 but sure you've figured that already.!

  8. #48
    lol Thanks buddy, i will get you a pint if i see you lol i will get you two when it comes to wireing my spindle board up haha

  9. #49
    Sometimes we are good then other times just brilliant!

Page 5 of 5 FirstFirst ... 345

Similar Threads

  1. Chinese 300W DC spindle - is the spindle shaft grounded?
    By HankMcSpank in forum Spindles & Drive Motors
    Replies: 44
    Last Post: 26-11-2016, 07:25 PM
  2. Replies: 0
    Last Post: 13-11-2013, 07:50 PM
  3. eBay: uirobot stepper drivers and uniport 2 board
    By andrewuk in forum Items On eBay UK
    Replies: 0
    Last Post: 11-09-2013, 09:47 AM
  4. Spindle lock mechanism for 2.2kW china spindle
    By Jonathan in forum Generic Chinese Spindles
    Replies: 8
    Last Post: 13-08-2012, 08:39 PM
  5. Uniport and limit switches.
    By D-man in forum General Electronics
    Replies: 14
    Last Post: 13-02-2012, 11:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •