Thread: Tiddy CNC.

Page 5 of 12 FirstFirst ... 34567 ... LastLast
  1. #41
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 2 Hours Ago Has been a member for 9-10 years. Has a total post count of 1,838. Received thanks 192 times, giving thanks to others 5 times.
    Intermittent faults are a pain. Being a vehicle master tech, I've spent weeks (and occasionally several recovery trucks ) trying to find some faults.
    Only way to know for sure is to try it.

    Personally, I wouldn't solder wiring. Solder and wiring that moves/vibrates has a high risk of breaking causing intermittent problems. Connectiosn should ideally be crimp, or screw with suitable support to avoid movement at the join.
    Avoiding the rubbish customer service from AluminiumWarehouse since July '13.

  2. The Following User Says Thank You to m_c For This Useful Post:


  3. #42
    Maybe this is worth reading too ? it#s AM882's and SmoothStepper http://www.mycncuk.com/forums/gantry...html#post56967
    although I didn't get an alarm on the AM882 so your problem is likely something different.
    Last edited by EddyCurrent; 18-04-2014 at 07:55 PM.
    Spelling mistakes are not intentional, I only seem to see them some time after I've posted

  4. The Following User Says Thank You to EddyCurrent For This Useful Post:


  5. #43
    Thanks folks. I checked the wiring earlier and found a couple of loose terminal connections to the drivers, cant say for sure but one of them was quite suspect. In addition the driver alarm circuit is in and tested, I was quite motivated to put that in! :)

  6. #44
    Quote Originally Posted by TonyD View Post
    I couldnt reproduce the fault until a few mins ago when I noticed that one of the 882's went into an error state and stopped the motor with 4 blinks which per the manual is 'phase error protection' (short/break).
    Now arent you pleased you bought good quality drives because lesser drives would have let out the magic smoke when a phase wire falls out of bounces.!!

    Now the missed steps concern me because while a loose connection could cause loss of position it wouldn't loose 2-4mm just jogging around, which by the way isn't a small amount when your talking several hundred MS steps per mm.

    I would check that the SS frequency is same for Each Axis and it's not set to some silly high setting. 128Khz is more than enough.

    Also do you have a Cable to connect to AM882 drives and use the protune software.? If not then get one for the sake of £2 worth every penny.
    Check that each drive is set exactly the same with regards microstepping and Amp's. Protune as a Quirk in that it will some times default the Amp settings back to default which is around 2A, so check it hasn't done this on one of the drives.

    Makes sure the Motor tuning and steps Per in Mach is exactly the same for both slaved Axis. Don't set high feed or Acceleration until your sure machines mechanicly fine and no binding Etc. Even then be careful not to go daft with Accel which is the biggest cause of lost steps.
    What are your Motor tuning settings now.?

  7. #45
    Hello Dean. That would have been all I needed to see smoke! Its great building the thing but setting it up is nerve racking (no pun intended) :) I watched the youtube videos on Mach3 homing *a lot* before I finally hit the button, thankfully Z and Y homes nicely. X groaned too much so I stopped to investigate.

    I do have the RS232 cable, tired 3 pc's before I could get comms to the drives but I did get there, havent run the protune software yet, will add that to the list for tomorrow. I'm assuming that the racking was becuase one motor was running, the other wasnt.

    Currently, kernel speed (from ports and pins screen) is 35KHz, Motor Slaving & pins appears fine. 3 home switches fine, estop circuits pilz etc fine. I cant see where to check the SS frequency, in the plug in control screen I just get mach3 buffer time, 1000ms, PLCM buffer 500, accell overshoot 20%, plcm feedrate for DRO 1075.

    I'm using ballscrews with 5mm pitch. For X,Y,B motor settings are 320 steps, velocity 4000, acceleration 1000, step pulse 5, dir pulse 5
    For z its 320,3000,300,5,5.

    I'll definately run protune tomorrow, thanks for the advice. Before the gantry was bolted to the ballscrews it run quite well, there's a lot of mass there so it wasnt really easy to push but could move it about easy enough. That leads me to conclude that the linear rails are perpendicular. Now its bolted to the ball screws when I release the left hand side binding the right motors is really more stiff to rotate with no power to the drives than the left, so I'm looking at the bearing mounting for the ball screw on the left side of the machine, I may be able to shim it a little, I'll take more detailed measurements tomorrow and see if I can determine what the resistance/binding is... All advice, as always, appreciated :) thanks.

  8. #46
    Yep just a motor wire to fallout while Jogging would fry lots of cheaper drives.!

    Are you using the USB SS or ESS.? in either case they don't use Kernal speed but it's best to set it at default 25Khz.

    If using ESS then look in Plug in control and choose ESS Config. On left you'll see Max Step Frequency for each axis and Spindle. Set to 128Khz you won't need any higher than that.

  9. #47
    I will try to consolidate these issues under my build log later but a seperate post allows me to appeal to those who know and love ProTune directly.

    So for reference I have an EPLC3 SS and ZP5A-INT Zapp BOB and 4 AM882 drives. Following on from my adventures in racking yesterday I'm trying to tune the motors with ProTune and... it really is trying.

    I have 'the cable' (DB9 to Rj12), also a USB to RS232 cable with seperate driver (CH41?) and so far 4 different PC's trying to get stable comms to the 882.
    I ditched the USB to RS232 lead completely and cut off the DB9 connector from 'the cable' checking in the pinouts from RJ12 connector (using the data sheet from the Leadshine site) so as to re attach it from new, I didnt find any misaligned pins in the DB9. I've used 4 PC's to connect and generally I'm not getting anywhere.

    I went to the Leadshine site and downloaded the correct version of the AM882 Protune (according to them) and found it didnt play nice with my legacy XP (up to date as of the April cut-off) and found myself re registering several ocx components at which point I thought, enough, ask for directions!

    For what its worth I do get a read from the drives so I know that serial comms are working but every time I try something interesting in ProTune it says in effect comms dropped. I've tried all the dip switches on the 882 to off, and not (although not all on), the 882 is powered up and motor is connected to it, the BOB is not.

    I'll send real chocolate Egg to whoever can help me out here. This is driving me nuts. Thanks. Tony.

  10. #48
    Tony. I have not used Protune as yet but have you set the com port up on the PC with the correct baud rate, stopbits and type of handshaking ie xon/xoff etc. Just a thought, I am not sure the usb to rs232 don't always work ..Clive
    Last edited by Clive S; 20-04-2014 at 07:44 AM. Reason: added usb

  11. #49
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 2 Hours Ago Has been a member for 9-10 years. Has a total post count of 1,838. Received thanks 192 times, giving thanks to others 5 times.
    I've got no expereince of digital stepper drivers, but I've never had any issues with USB adapters setting up other drives. Could it be something like the USB/RS232 interface you're using not implementing the full RS232 standard?

    Not all USB adapters connect or implement things like the DTR/DSR/RTS/CTS lines, which could be the problem.
    I normally use FTDI based adapters, and any I've had implement the full pin set, however some do exist that don't.
    Avoiding the rubbish customer service from AluminiumWarehouse since July '13.

  12. #50
    Well, I've spent hours rebuilding PC(s) to Windows 7, finding pinouts on the web (leadshine's site) and I'm still no better off. Added to which is the frustration that I feel that whenever I'm able to some quality time on the machine its a public holiday weekend and I cant just drive to a supplier to buy a new cable.

    If anyone has used ProTune on a PC can I please confirm the following settings with them.

    RJ12 to DB9 Cable (the oh so special one!)

    RJ12 Pin # Cable Colour DB9 Pin
    1 White none
    2 Black none
    3 Red 2
    4 Green 5
    5 Yellow 3
    6 Blue none

    PC Settings: Windows [7 fully patched. No 3rd party firewall.]

    Control Panel>System>Device Manager>Ports>COM1>Properties

    Bits per Second: 9600, Data Bits:8, Parity: None, Stop Bits: 1, Flow Control: None
    >Advanced> Use FIFO buffers: Checked, Receive and Transmit Buffer: 1

    Please let me know what you have used that has worked. Thanks.

Page 5 of 12 FirstFirst ... 34567 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •