1. #1
    Hi All
    I have just joined your group and am having problems with a myford 7 conversion I have brought a optoport v3 breakout board from diycnc.co.uk and stepper drives from arceuro, on the breakout board there are 3 out puts for each axes gnd , xstep , x dir. I can understand that the x step and x dir go to pulse- and dir- on the stepper drives but can't work out where the gnd goes all the videos I've watched have common where gnd is and this goes to pulse + and dir + There doesn't seem to be a 5v coming from the gnd as anybody else come across this

    All the best LEZ

  2. #2
    picture paints 1000 words.!! . . . Just quick sketch but shows the connections.Click image for larger version. 

Name:	connections.jpg 
Views:	244 
Size:	43.8 KB 
ID:	8208

  3. #3
    Thanks Jazzcnc got it up and running for a while then i moved it into place and the z axis stop working I get a green light when i switch the box on but as soon as I press the button to move the axis the light just goes red and no movement do you think I have blown something up
    Thanks LEZ

  4. #4
    If it was all working & then one axis stopped when you moved it I would check the wiring to that axis, might just be a loose connection, You could also try measuring the output on the direction connection at the motor end with a multimetre, should be somewhere around the 5v mark in one direction & 0v the other, bit more difficult to measure the pulse I believe without an oscilloscope

  5. #5
    Quote Originally Posted by lez allen View Post
    Thanks Jazzcnc got it up and running for a while then i moved it into place and the z axis stop working I get a green light when i switch the box on but as soon as I press the button to move the axis the light just goes red and no movement do you think I have blown something up
    Ok first does this happen just on Z axis or all Axis.?

    If just Z axis that faults then swap outputs on BOB for one the other Axis outputs and see if it works. If still faults then it's some were else down the Z axis chain.?
    Work methodical down the chain by swapping known good components, before that thou check wires because chances are you have motor phases wrong on drive and they are protecting them selfs.? Shouldn't be hard to find.

Similar Threads

  1. Replies: 0
    Last Post: 13-02-2014, 07:09 PM
  2. Break board 3-axis optical isolation, simple!
    By thjremy in forum Electronic Project Building
    Replies: 0
    Last Post: 06-04-2013, 04:42 PM
  3. Requirements on a break out board?
    By Sodster68 in forum Motor Drivers & Controllers
    Replies: 3
    Last Post: 21-01-2013, 02:58 PM
  4. Stepper Driver / PSU / Breakout board Wiring ?
    By manofgresley in forum General Electronics
    Replies: 2
    Last Post: 16-08-2012, 05:41 PM
  5. Motor controller next to break out board?
    By m_c in forum General Electronics
    Replies: 2
    Last Post: 17-11-2010, 01:56 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •