. .
Page 2 of 2 FirstFirst 12
  1. #11
    Good luck with your query but this is 7 years old now . . .
    Building a CNC machine to make a better one since 2010 . . .
    MK1 (1st photo), MK2, MK3, MK4

  2. #12
    Yes, didn't spot that until after I pressed the Post button. One of the problems with Googling for a topic! Have got some advice from elsewhere so starting the checks.

  3. #13
    Quote Originally Posted by Ianwallis View Post
    I've got a very similar problem to yours. How did you decide it was the motor at fault and not the control panel please. Don't want to spend money on the wrong thing if I can easily test them. Ian
    Hi, wow that was a long time ago! I just went for the motor and for me that was the problem.

    Sent from my SM-G975F using Tapatalk

  4. #14
    Quote Originally Posted by Ianwallis View Post
    Yes, didn't spot that until after I pressed the Post button. One of the problems with Googling for a topic! Have got some advice from elsewhere so starting the checks.
    Waste of time the X2 if it has the 350w motor. My pot has gone screwy on one of them. Both my X2's are just sat there. Occasionally use the manual one for drilling holes. (they work but my Amat25 is sooooo much better).

    You're prob better off buying one of these when it comes in:

    https://www.amadeal.co.uk/acatalog/A...E.html#SID=420
    Better travels, brushless, R8 (far superior).


    Like, The X2 motor is 130, then it could be the board which is another 140, all adds up.
    Must admit though, I did upgrade my manual one to metal gears. Thing will take your hand off now lol!.
    Last edited by dazp1976; 25-04-2021 at 04:18 PM.

  5. #15
    Uzzy's Avatar
    Lives in Chatham, United Kingdom. Last Activity: 2 Weeks Ago Has been a member for 0-1 years. Has a total post count of 2.
    I have an Axminster Seig SX2 which does not want to play ball, it may run for 30 seconds but normally only 1 or 2

    Any suggestions please .

  6. #16
    Spindle motor?, does the spindle run freely?, in which case it's likely either the motor, the controller card, or a short in the cables that run between. Not very informative, I know, but it needs diagnostics to determine any further.

    A bit of history - I converted my SX2.7 to CNC, but when I first bought it it ran for <5 mins then died completely. Repaired under warranty by Arc Eurotrade - brilliant service and they had the kit to diagnose motor and controller (had to return both to them for this). Might be worth a call to see if they're prepare to help out - but it'll cost! Also, they stock the replacement motors and controllers....again, it'll cost.

    Once I'd converted to CNC I was trying to reverse-engineer the controller card and ended up blowing it up a second time. At this point I realised replacing the controller and motor with something that suited my purpose better was as cost effective as replacing the controller card alone. You might want to think out of the box to replace rather than repair.

  7. #17
    Uzzy's Avatar
    Lives in Chatham, United Kingdom. Last Activity: 2 Weeks Ago Has been a member for 0-1 years. Has a total post count of 2.
    Doddy,

    Yes spindle runs freely, I just need someone to service it and advise whats wrong and cost of repair :-)

  8. #18
    I'd replace it with an AC servo (if your X2 is belt driven) and get a new motor pulley to suit.
    https://www.aliexpress.com/item/3304...16109932%22%7D

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Warco WM16 Mill - Conversion to AC motor with VFD
    By birchy in forum Milling Machines, Builds & Conversions
    Replies: 15
    Last Post: 06-01-2017, 06:06 PM
  2. Replies: 2
    Last Post: 23-04-2014, 03:14 PM
  3. Help and Advice sought about new motor for my mill
    By alanb in forum Milling Machines, Builds & Conversions
    Replies: 0
    Last Post: 26-01-2012, 08:04 PM
  4. Motor problem
    By irving2008 in forum Milling Machines, Builds & Conversions
    Replies: 4
    Last Post: 13-09-2009, 01:06 AM
  5. Motor / drive wiring problem: help!
    By lateAtNight in forum General Electronics
    Replies: 2
    Last Post: 29-04-2009, 07:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •