. .
Page 1 of 2 12 LastLast
  1. #1
    Hi

    I have a X2 mill (Sealey) which has a problem and didn't know if anyone can help, it's less than a year old (only 1 hr use max) but if was an easy fix would rather do it my self as I've fitted a belt conversion etc.

    When you turn the knob to wind the spindle up it trips and the overload light comes on really easily, if I turn it really slow it doesn't trip until 3/4 of the way at which time the motor seems to burble and blue electrical spark around the armature. I have seen some posts on other forums saying the potentiometers play up?

    hope that make sense

    thanks in advance

    Allan

  2. #2
    If it is a DC brushed motor have you checked the brushes?
    If the nagging gets really bad......Get a bigger shed:naughty:

  3. #3
    I've had the brushes out and they look fine.

    It seems like whatever measures the load is faulty?

  4. #4
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 6 Hours Ago Forum Superstar, has done so much to help others, they deserve a medal. Has been a member for 9-10 years. Has a total post count of 2,553. Received thanks 307 times, giving thanks to others 8 times.
    I would of thought that it's more likely to be the controller, as that was a known weak point on the lower power machines.

    I'd recommend searching/posting in the benchtop machine forum over on CNC zone (Benchtop Machines) as the X2 is quite popular over there, and most problems have been discussed at some point.

  5. #5
    These otors and controllers are used in the small lathes as well. CNCZone seams to be awash with people having problems with the controllers. They all seem to upgrade in the end?
    If the nagging gets really bad......Get a bigger shed:naughty:

  6. #6
    m_c's Avatar
    Lives in East Lothian, United Kingdom. Last Activity: 6 Hours Ago Forum Superstar, has done so much to help others, they deserve a medal. Has been a member for 9-10 years. Has a total post count of 2,553. Received thanks 307 times, giving thanks to others 8 times.
    The general concensus seems to be to upgrade to a KB DC controller (KBIC is the bottom of the range and will most likely do everything you'll need it to)

    KB website is Variable Speed DC Drives and DC Motor Speed Control, and Axis Controls is a UK supplier who I've used in the past(KBIC DC Speed Controllers)
    Last edited by m_c; 23-03-2013 at 05:23 PM.

  7. #7
    Thanks for your replies, I'll look into the controller upgrade. Would be interested to hear from anyone else that has done the upgrade.

    Allan

  8. #8
    Update

    Just thought I would post an update as it might help someone else out, It was the motor that was gone on my very little used X2, new price 195 delivered (too dear). After looking for a replacement with no luck I came across the C3 replacement motor on the Arc Euro Trade site, looked the same in the picture and all the dimensions are the same, so ordered it and it fit perfectly, you just have to take the 4 screws holding the front casing on and fit the mounting plate from the old motor. 65 for the motor delivered and it works perfect now, no tripping as soon as it spins up! Arc Euro Trade Ltd







    Click image for larger version. 

Name:	b164c94c-9886-464a-9974-9e6400f375f2_390x172.jpg 
Views:	463 
Size:	17.0 KB 
ID:	8654
    Last edited by A11an; 05-04-2013 at 03:00 PM.

  9. #9
    Click image for larger version. 

Name:	photo (1).jpg 
Views:	323 
Size:	171.4 KB 
ID:	8660Click image for larger version. 

Name:	photo (2).JPG 
Views:	310 
Size:	600.2 KB 
ID:	8656Click image for larger version. 

Name:	photo (3).jpg 
Views:	385 
Size:	157.1 KB 
ID:	8661Click image for larger version. 

Name:	photo (4).JPG 
Views:	493 
Size:	695.6 KB 
ID:	8658Click image for larger version. 

Name:	photo.jpg 
Views:	300 
Size:	149.9 KB 
ID:	8662
    Last edited by A11an; 05-04-2013 at 03:15 PM.

  10. #10
    Quote Originally Posted by A11an View Post
    Update

    Just thought I would post an update as it might help someone else out, It was the motor that was gone on my very little used X2,
    I've got a very similar problem to yours. How did you decide it was the motor at fault and not the control panel please. Don't want to spend money on the wrong thing if I can easily test them. Ian

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Warco WM16 Mill - Conversion to AC motor with VFD
    By birchy in forum Milling Machines, Builds & Conversions
    Replies: 15
    Last Post: 06-01-2017, 06:06 PM
  2. Replies: 2
    Last Post: 23-04-2014, 03:14 PM
  3. Help and Advice sought about new motor for my mill
    By alanb in forum Milling Machines, Builds & Conversions
    Replies: 0
    Last Post: 26-01-2012, 08:04 PM
  4. Motor problem
    By irving2008 in forum Milling Machines, Builds & Conversions
    Replies: 4
    Last Post: 13-09-2009, 01:06 AM
  5. Motor / drive wiring problem: help!
    By lateAtNight in forum General Electronics
    Replies: 2
    Last Post: 29-04-2009, 07:40 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •