Page 5 of 5 FirstFirst ... 345
  1. #41
    asto's Avatar
    Lives in Attica, Greece. Last Activity: 14-09-2016 Has been a member for 3-4 years. Has a total post count of 65.
    Thanks John S!
    Take your time

  2. #42
    Spud's Avatar
    Lives in Coalville, United Kingdom. Last Activity: 08-04-2016 Has been a member for 0-1 years. Has a total post count of 3.
    Quote Originally Posted by asto View Post
    Hello everyone!

    New member here and knowledge thirsty.
    So here goes my first question...My lathe X-axis drive(PKS-DIGIPLAN SD2) lights up a red LED. Then a TO-220 Transistor or maybe a triac, I have no idea what this may be found dead. It has a printed code _PKS0320 but nowhere in the Net I was able to find data or a cross reference for this . So, I have no idea what it may be . I am just guessing this has to be a triac. In the Parker SD2 drive user guide though, only block diagrams I have found so far. Electronic schematics of the boards... nowhere.

    Just in case someone of you had access to a stepper drive like this and happen to know what kind of IC this is please help.

    regards!

    Asto

  3. #43
    Spud's Avatar
    Lives in Coalville, United Kingdom. Last Activity: 08-04-2016 Has been a member for 0-1 years. Has a total post count of 3.
    I am just about to put two SD2 drives on Ebay. Interested?

  4. #44
    Spud's Avatar
    Lives in Coalville, United Kingdom. Last Activity: 08-04-2016 Has been a member for 0-1 years. Has a total post count of 3.
    I have two SD2 if you are interested

  5. #45
    Quote Originally Posted by Spud View Post
    I have two SD2 if you are interested
    You do realise that this post is 3 years old
    ..Clive
    The more you know, The better you know, How little you know

  6. #46
    asto's Avatar
    Lives in Attica, Greece. Last Activity: 14-09-2016 Has been a member for 3-4 years. Has a total post count of 65.
    Hi Spud!
    I have finaly managed to fix the faulty board after i replaced a dead cmos ic.But i still have need of some boards from this machine like the main interface board. It looks like the one and only Ferranti IC located there is dead as well. If you still heve the old boards i am interested buying them.

    cheers
    Last edited by asto; 08-05-2016 at 04:22 PM.

Page 5 of 5 FirstFirst ... 345

Similar Threads

  1. Denford digiplan 300 drivers, i cant get them to run on mach 3
    By scnc in forum Motor Drivers & Controllers
    Replies: 5
    Last Post: 30-04-2014, 09:56 PM
  2. Replies: 1
    Last Post: 16-03-2014, 07:29 PM
  3. eBay: Denford Triac Parker Digiplan SD2 & SD3 Stepper Drivers
    By davidimurray in forum Items On eBay UK
    Replies: 0
    Last Post: 25-02-2013, 10:23 PM
  4. Digiplan parts left from "upgrade"
    By black5f in forum Motor Drivers & Controllers
    Replies: 1
    Last Post: 17-03-2011, 12:02 AM
  5. Parker Digiplan schematics
    By GT390 in forum General Electronics
    Replies: 1
    Last Post: 01-01-2011, 03:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •